Need More Info Issue where there is random restarts of my computer

Currently viewing this thread:

RamoBeed

Recruit
I have no idea why other than maybe a issue with the cpu or a memory leakage of the game itself. Im not entirely sure what the issue may be but it has caused the game to restart the pc itself for some reason. If their is any idea as to what may be going on I would be interested.Also to note the computer has done just fine running more cpu intensive games. So it overheating not entirely sure if that is the issue.
System Specs
gtx 970
i7-4790 3.6
 

Vampyr

Grandmaster Knight
WBWF&SNW
nvidia 1060 with an i7 4790k. I could run the game without any frame drops even before i turned all the graphics to low to see if that stopped the force reboots.
Having the same issues - owning pretty much the same hardware as you do. Pretty frustrating since I can't play properly since release. But the devs are working on it, so we should just have some patience.
 

Heinz Solo

Veteran
WB
thats great. all your drivers are really good and your hardware is good. cant see any problems with your PSU.

that leaves in my opinion two options: CPU or virus. you can eliminate virus cause by running malwarebytes free once.

then that would leave your CPU. I had the same problem as you last week. PC shutting down whilst playing the game. I had some £10 thermal paste lying around so i opened up the system, cleaned it all out, washed the non-electronic heat sinks, reapplied the paste and reset it. Havent had the problem since.

one indication that my system needed a clean/paste application was the fans were blowing hard just before shutting down. This game will be optimised (8 patches in 8 working days -thats crazy), but i'm thinking its stressing your system so your pc is shutting down to protect itself. if you are not comfortable opening up your system, then you might have to be patient/lower settings/switch to perfomance in your power plan for now.
 

Kuss

Recruit
CPU watercooled temp max out at 55c max load, ambient room temp 24c atm, (Hot outside for me) malwarebytes used and uninstalled always do dunno why i do it.
But i think its to do with gfx+-mem (shaders)?
 

denelor

Recruit
M&BWB
could OP or anyone else having this issue post there dxdiag, i would be interested to have a look. You can omit information after the DirectX Filters section to reduce the size of your post, but keeping the info about Sytem Devices would be useful

Link here to my own digging into this. This includes dxdiag and a save that will crash my computer every time I continue (in the second post) and instructions on how to do that.

It is very specifically replicable to conditions in game. For me it ONLY happens during transitions to and from the campaign map and it happens exactly at the slight pause that happens when those transitions start.
 

Kuss

Recruit
past experience same thing happened same way was fixed after a patch, cant remember the game but i can remember the dam crashes lol. I think that was in (EA) as well i got to many
 

Kuss

Recruit
Link here to my own digging into this. This includes dxdiag and a save that will crash my computer every time I continue (in the second post) and instructions on how to do that.

It is very specifically replicable to conditions in game. For me it ONLY happens during transitions to and from the campaign map and it happens exactly at the slight pause that happens when those transitions start.
when you lockup do your display say no signal like 30sec after the freeze and thats when you powerdown? for me thats what happens and i cant get it to bsod to read an error just a hard lock
 
I have been having the same issues, where upon a transition, there is a slight hangup, and then my system does a full restart

Edit: Went ahead and checked my Windows Crash Logs and it gave me the following

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 4/9/2020 4:04:38 PM
Event ID: 41
Task Category: (63)
Level: Critical
Keywords: (70368744177664),(2)
User: SYSTEM
Computer: DESKTOP-RASTOPR
Description:
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
 
Last edited:

denelor

Recruit
M&BWB
I have been having the same issues, where upon a transition, there is a slight hangup, and then my system does a full restart

Edit: Went ahead and checked my Windows Crash Logs and it gave me the following

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 4/9/2020 4:04:38 PM
Event ID: 41
Task Category: (63)
Level: Critical
Keywords: (70368744177664),(2)
User: SYSTEM
Computer: DESKTOP-RASTOPR
Description:
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.

@TheWhiteMamba Can you post a DXDiag? It seems to be what gets asked for the most since we can't post the Bannerlord crash logs (since they don't exist in this case).
 

denelor

Recruit
M&BWB
Reposting/updating from my other thread stuff here just to centralize.

DXDiag here.

Here is a relevant save.

The crash I'm experience is a direct crash into a reboot. It skips the BSOD or any other obvious fault notification. The time of the hang between the game and the reboot is noticable, but short (a second or two). This crash only ever happens during the transition to and from the campaign map. I've had it right as my army reached an enemy army and teh game tried to transition campaign->pre-battle screen. I've also had it post-battle after telling the opposing leader that they were my prisoner now. At the transition point from that conversation screen back to the campaign map, crash-reboot.

Above is a save where this happens predictably. The save is on the pre-battle screen. The crash happens every time in this save whether I simulate the battle (Send in troops) or fight and win it myself. The crash/reboot happened multiple times in a row using both circumstances. With tihs particular save it has happened since 1.07. I have tried it with 1.08 and 1.09. I was seeing the crash earlier in the same circumstance, but it wasn't all the time. I'm not sure if it started 1.05 or 1.06. For this particular save I have never been able to move passed this point in this particular save without a crash.

I have done memory diagnostics and whatnot. Everything is up to date. In my spare time I'm going through Event Logs around the point of crash to look for non-Bannerlord reasons, but haven't found anything. I routinely have GPU and CPU temp monitors up on a second screen. I have a PSU with a status monitor. None of those are showing any issues. The commonality seems to be specifically transitions to and from the campaign map. I haven't seen it happening in any other game.
 
Last edited:
I was having something similar to this during early access. I use the Nvidia Studio Drivers.

Now, I can't guarantee it was one thing or the other. Maybe they patched something, but I was having those shutdowns with no crashlogs, BSOD or dumps, exclusively while playing Bannerlord (no issue with other games or software way more demanding that Bannerlord). Nvidia released a new update and I never had those crashes again (and those studio drivers always goa bit behind because they are made for reliability).

But also it could have been an issue with the Bannerlord and the RAM that possibly was patched at some point around the same time. The RAM issue was my theory all along until it stopped happening.

Anyway, somehow it got fix eventually. It's good that you have a save where you can reproduce the crash, because that certainly will tip them in the right direction. Otherwise, you just have to hope they stumble upon it.
 
I was having something similar to this during early access. I use the Nvidia Studio Drivers.

Now, I can't guarantee it was one thing or the other. Maybe they patched something, but I was having those shutdowns with no crashlogs, BSOD or dumps, exclusively while playing Bannerlord (no issue with other games or software way more demanding that Bannerlord). Nvidia released a new update and I never had those crashes again (and those studio drivers always goa bit behind because they are made for reliability).

But also it could have been an issue with the Bannerlord and the RAM that possibly was patched at some point around the same time. The RAM issue was my theory all along until it stopped happening.

Anyway, somehow it got fix eventually. It's good that you have a save where you can reproduce the crash, because that certainly will tip them in the right direction. Otherwise, you just have to hope they stumble upon it.
Its kind of interesting because I had a similar issue with Fifa 20 last year now that I think of it. The fix (until it was patched) was going back to a studio driver. I guess I'll give that a shot.
 
Top Bottom