BL Coding Port to .NET Core

Users who are viewing this thread

Hello,

I wanted to target a .NET Standard 2.1 (.NET Core >= 3) library from a Bannerlord SubModule but current TaleWorlds assemblies target .NET Framework 4.7.2. Is it a limitation of the engine? Would you know the reason why it doesn't target the last .NET Framework version (4.:cool:? Is there some plan to port Bannerlord to .NET Core?

In November 2020, Microsoft will introduce .NET 5. Could it be an opportunity to migrate Bannerlord and benefit from the huge performance improvements and awesome features like the Pinned Object Heap?
 

ptp

Sergeant
WBVC
I was wondering the same thing. Is there a specific compatibility reason for using .NET Framework? What technology or platform does the engine use that is not supported in .NET Core or .NET 5?

@Mustafa Korkmaz
 
Upvote 0

Kiyakkoray

Backend/Multiplayer
Developer
M&BWBWF&SNWVC
Actually most of our DLL files are targeting .NET Standard 2.0. In fact, we are using .NET Core on our server systems(which shares lots of dll files with client itself). So there is nothing stops us from using .NET Core on clients as well. We'll discuss it internally.

Thank you...
 
Upvote 0
Top Bottom