Loose formation bug?

Currently viewing this thread:

Tukomika

Recruit
So almost every single fight I put my archers in loose formation. After some time or after enemy units come closer my archers start to adjust their position.
(I can't remember this happening with looters though).

It looks something like this
At the start:
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - -
After adjustment:
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -

I saw one post about this -> https://forums.taleworlds.com/index.php?threads/question-about-broken-formation.443733/
There was no answer on how to fix this. Any ideas?
 

Apocal

Grandmaster Knight
There was no answer on how to fix this. Any ideas?
Have you tried using the Face Direction or drag-and-drop to fix their orientation?

Edit: I just looked at the link you gave; if those commands aren't working I dont know what the problem is.
 
Last edited:

Zerofive

Veteran
its definitely already in 1.5.9. I saw it happen when more archers came from reserves, I thought the number of archers triggerd some kind of number threshold so they have to rearange their position in order not to get too wide if you know what i mean....maybe im wrong
 

Tukomika

Recruit
Also the scatter formation results in a line formation on the field. That's irritating
Haven't really used scatter. When I did, troops went in to a pile staying really close to each other. As far as I know, they should make a formation similar to loose formation.
 
its definitely already in 1.5.9. I saw it happen when more archers came from reserves, I thought the number of archers triggerd some kind of number threshold so they have to rearange their position in order not to get too wide if you know what i mean....maybe im wrong
i think you got it, and the formation changes the moment the reserve archers spawn in to the map, before they join your troops
 

Apocal

Grandmaster Knight
Try it out with looters. I don't think this bug occurs with looters at all.
Yeah, I can't get it to happen with looters or most bandits, so I suspect it has something to do with the AI defending itself against cavalry.

edit:
i think you got it, and the formation changes the moment the reserve archers spawn in to the map, before they join your troops
Or this. This would explain it; my battle sizes are set pretty high (1000) so most of my fights I don't have any reserve archers coming in.
 
It has been there a bit, I put them in loose formation they they bunch up and loose formation doesn't work and they get bugged, I have to put them in shield wall then loose formation to get them back in loose formation. and TW let me know Ill get ya video of it,, for some reason they leave loose formation and won't go back unless you use a different formation first.
 

Tukomika

Recruit
Or this. This would explain it; my battle sizes are set pretty high (1000) so most of my fights I don't have any reserve archers coming in.
Not really sure about that. I am playing with medium (400) battle size and it still happens. Had this bug occur in ~200v200 battle. And I had around 70-80 archers.
It has been there a bit, I put them in loose formation they they bunch up and loose formation doesn't work and they get bugged, I have to put them in shield wall then loose formation to get them back in loose formation. and TW let me know Ill get ya video of it,, for some reason they leave loose formation and won't go back unless you use a different formation first.
Strange. Does it really work?
 

Antaeus

Sergeant
I only ever have units moving to face the enemy if I haven't manually placed them. If I place them manually, they stay where I've put them.

If you have reserves joining, and you haven't set their position, they probably re-center their position based on where the reserve archers are - e.g. if you have 10 archers, and 5 more join, then the centre of the unit is going to be 1/3 towards where the new archers are.

This bug/effect also affects AI armies, who sometimes literally stop in front of me, and march back to their new centre point towards where the reserves are - turning their backs on my archers.
 
Not really sure about that. I am playing with medium (400) battle size and it still happens. Had this bug occur in ~200v200 battle. And I had around 70-80 archers.

Strange. Does it really work?
yeah when they bunch up just hit F2 F2 then F2 F3 to get them back in loose formation but again, it may not last long and they can go back into the bunch formation
 

iRkshz

Regular
So almost every single fight I put my archers in loose formation. After some time or after enemy units come closer my archers start to adjust their position.
(I can't remember this happening with looters though).

It looks something like this
At the start:
- - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - -
After adjustment:
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - -

I saw one post about this -> https://forums.taleworlds.com/index.php?threads/question-about-broken-formation.443733/
There was no answer on how to fix this. Any ideas?

I did tests - and I can say 100% that this bug is triggered in 100% of cases when reinforcement comes out (this can be seen in the video)

as I tested, incoming reinforcements have a default formation and will always break your formation


as you can see from the second video, the incoming reinforcements not only have a default formation and will break your formation, but also the reinforcements have default subdivisions (before the battle, I united all archers in 4 subdivision - "horsearchers", but the archers from the reinforcement did not join the general subdivision), but the reinforcements of the archers stood separately


that is, it is 100% a mistake of the developers in setting up reinforcements
 

Tukomika

Recruit
I did tests - and I can say 100% that this bug is triggered in 100% of cases when reinforcement comes out (this can be seen in the video)

If you are still looking for a solution, this is the best one IMO.
yeah when they bunch up just hit F2 F2 then F2 F3 to get them back in loose formation but again, it may not last long and they can go back into the bunch formation

I don't think this is going to get changed for some time. There are plenty of bugs that have been around for a while now.
 

Pedrohb

Recruit
This also happen if you place them in a "tight" area and then move them out of there, they will keep the shape they were in the other area...
 
Top Bottom