Need More Info Launcher opens but won't start after clicking play

Users who are viewing this thread

Version number
e1.7.2.316284
Branch
Main
Modded/unmodded
No, I didn't use any mods.

Krul_Ded

Recruit
Summary: When starting the game from steam, the launcher will start up and when selecting the option to Play or Continue, the game does not start. The game keeps running and I have to close the launcher on task manager or else it won't stop.
How to Reproduce: Try to start the game as usual and select Play or Continue.
Have you used cheats and if so which: Never used cheats
Scene Name (if related): N/A
Media (Screenshots & Video): N/A
Computer Specs:
OS: Windows 10 64-bit
GPU: RX 5600 XT
GPU Driver Version: 30.0.21017.1000
CPU: AMD Ryzen 7 3700X
RAM: 32 GB
Motherboard: TUF Gaming x570 Plus WI-FI
Storage Device (HDD/SSD): Sabrent Rocket 4.0 1 TB/ Samsung SSD 980 1 TB/ WD My Passport 2626 USB 1TB
 

Krul_Ded

Recruit
Found this in the logs. Any way I can download the missing dll?



Try to load dll TaleWorlds.MountAndBlade.Launcher.Steam.dll

Resolving: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Try to load dll TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers.dll

Resolving: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers
Try to load dll TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers.dll

Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.Official.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 0.7530
Playing sound: default
Playing sound: default
 

Krul_Ded

Recruit
I've verified the files, uninstalled and reinstalled onto separate drives. I had messed around and deleted some files I've seen in older posts and went to the 1.8 beta. The 1.8 beta worked for one session but upon closing the game and reopening at a later date, the issue came back.
I downloaded save files from the steam cloud and backed everything up just in case I lose data.
The app has controlled file access and one drive is synced up and everything.
Here is the log for my most recent attempt:

Loading assembly: TaleWorlds.MountAndBlade.Launcher.Steam.dll

Assembly load result: SUCESS
Resolving: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
Loading assembly: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers.dll

Assembly load result: NULL
Resolving: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers
Loading assembly: TaleWorlds.MountAndBlade.Launcher.Library.XmlSerializers.dll

Assembly load result: NULL
Can't reset context
Loading FiraSansExtraCondensed-Regular font, at: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\LauncherGUI\Fonts\FiraSansExtraCondensed-Regular/FiraSansExtraCondensed-Regular.fnt
Couldn't find .dll: ..\..\Modules\DedicatedCustomServerWebPanel\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.WebPanel.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.DedicatedCustomServer.Official.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.PS.dll
Couldn't find .dll: ..\..\Modules\Native\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Platform.GDK.dll
Init LauncherModsDLLManager
Total startup time: 0.7850
ASSERT!
Error while trying to get image online: The cloud file provider exited unexpectedly.

Playing sound: default
Setting engine methods at Controller::SetEngineMethodsAsDotNet
 

Krul_Ded

Recruit
Does the game window icon show up in the taskbar?
Nope. It will some times appear in task manager depending on if the game says stopping on steam or not. I purchased the GOG version to see if it was a issue with steam and GOG does the same. Yesterday I disabled Xbox Game Bar and got it to run for a bit but the next time I launched, it failed again.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Could you send us the log after the game crash from the event viewer? You can find details here:
 

Krul_Ded

Recruit
Could you send us the log after the game crash from the event viewer? You can find details here:
Theres different messages for different times I tried to run the game. I had switched drives yesterday

The program TaleWorlds.MountAndBlade.Launcher.exe version 1.0.0.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
Process ID: 51a8
Start Time: 01d8863fce6f9527
Termination Time: 9
Application Path: F:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Launcher.exe
Report Id: c7f5193e-bdad-4c14-abe7-49fb27f1f9ed
Faulting package full name:
Faulting package-relative application ID:
Hang type: Unknown




Faulting application name: TaleWorlds.MountAndBlade.Launcher.exe, version: 1.0.0.0, time stamp: 0x62ab069d
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1706, time stamp: 0x458acb5b
Exception code: 0xe0434352
Fault offset: 0x0000000000034fd9
Faulting process id: 0x13a4
Faulting application start time: 0x01d8825dfdc2707e
Faulting application path: D:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client\TaleWorlds.MountAndBlade.Launcher.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: d2319ff5-8c10-4c8a-af28-8d2f303eb0a4
Faulting package full name:
Faulting package-relative application ID:
 
Top Bottom