In Progress Game with current update is unplayable. Lags and stutter nonstop

Users who are viewing this thread

Version number
e1.5.9
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Summary: Half a year ago i could play the game with minimal lags and stutter and only after about 2 to 3 hours the game would crash. I stopped playing because the crashes got annoying and i wanted to wait for a more stable version.
Now with the current update the game is literally unplayable for me even on the lowest settings. Everything lags and stutters and is beyond funny anymore. If i manage to get through all the lags and stutter from menu to menu or on the world map i STRANGELY have no issues inside a battle on a field.

No clue why but the current patch ruined the game for me. Game doesn't crash but it is unplayable or enjoyable. And i can switch the graphic setting literally up and down however i like it makes 0 difference. Maxed out lags, stutters and fps drops the same way as lowest graphic or performance options.

So basically i can run almost everything on max setting on my PC without problems but the moment i touch the current build of Bannerlords it all goes down south. Someone told me a reinstall could fix the issue. But unless someone proofs to me that this would solve my issue i wont download 50GB again and waste half a day to only see that it didn't fix anything.

Should i roll back to an older version? Cause to tell you the truth i don't know which version of the game was stable for me anymore.

How to Reproduce: Start the game
Have you used cheats and if so which: Nope
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Win 10
GPU: Geforce GTX 1060 6GB
GPU Driver Version: 466.11
CPU: I7 7700K Octa 4,2 GHz
RAM: 32GB DDR4
Motherboard: MSI Z270 PC MATE (MS - 7A72)
Storage Device (HDD/SSD): HDD 3 TB
 
Last edited:

momo1

Sergeant
M&BWBWF&SNWVC
What is your RAM usage when you're playing Bannerlord?
Can you run the following command as administrator and then reboot your PC?
Chkdsk C: /f /r
PS. It might take an hour or so.
 
What is your RAM usage when you're playing Bannerlord?
Can you run the following command as administrator and then reboot your PC?
Chkdsk C: /f /r
PS. It might take an hour or so.

Ram usage is 6,2 of the 32 avaliable.
GPU is 50%
CPU is 33%

I will try the cmd input and write back.
 

DragaXZ

Recruit
I have the same problem, it's pretty much unplayable. I just got the game today and was excited to play it but starting the game up takes forever and each time I try to move around or even just open the inventory the game starts to freeze/stutter for like 2-5 seconds.

I have an RTX 3070 with and SSD drive and 16GB RAM, my fps while doing nothing are 140+, so that's pretty ridiculous.
 

momo1

Sergeant
M&BWBWF&SNWVC
No it uses 6.2 GB of RAM out of 32 GB RAM available. Sry i maybe didn't explain that the best way possible.

and the Chkdsk C: /f /r took 2 minutes with 0 issues found.
Bannerlord shouldn't go above 4 GB. Go to task manager, and under the Performance tab, look at Memory and make sure it says 32 GB.

Taleworlds a special performance build to check for these issues by collecting telemetry data. Can you switch to that build, test your performance and send them your data?
  1. Switch to “perf_test” from the Steam betas tab. You can find more info about it here.
  2. Open the game as usual and proceed to the stage where you are experiencing performance issues.
  3. Before the performance issues start, toggle the profiling tool by holding the “right shift” and pressing the “T” key.
  4. Record for 20-30 seconds, press the toggle key combination again. Please keep in mind that, the more you record, the more upload time it will require.
  5. Find the "test.tmcap" file in the "...\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client" folder. You can find the "Mount & Blade II Bannerlord" folder inside Steam’s application library folder.
  6. Finally, upload the file to the "upload.taleworlds.com" site. Please write your username and this threads URL into the description box so that we can find it easier. It is appreciated if you provide more information about your PC, what you were doing while the game was recording and your graphics configuration. If the data you are trying to upload is too big or the site fails to upload, you can use an alternative site to upload your data. If you choose to do that please leave a reply to this thread with the download link.
EDIT: Meanwhile you can try these workarounds.
1. Open task manager and end the tasks named 'Nvidia container' it will fix it for a while. It's annoying but better than having to restart every time.
2. Exit to the loading screen then reload and it fixes the problem.
 
Last edited:

momo1

Sergeant
M&BWBWF&SNWVC
I have the same problem, it's pretty much unplayable. I just got the game today and was excited to play it but starting the game up takes forever and each time I try to move around or even just open the inventory the game starts to freeze/stutter for like 2-5 seconds.

I have an RTX 3070 with and SSD drive and 16GB RAM, my fps while doing nothing are 140+, so that's pretty ridiculous.
CPU?
 
Bannerlord shouldn't go above 4 GB. Go to task manager, and under the Performance tab, look at Memory and make sure it says 32 GB.
Screenshot.

And im not recording my gameplay for TW to fix this issue. I am not their employee to send stuff like that in. Nor am i a paid tester for stuff like that. If they want recorded footage of stuttering and lags ingame they just need to start the game on their own on a similar rig.
Cause i have friends who get paid for that kind of stuff. Since i am not getting paid for said stuff i will not do any of that. But thanks for the offer.

im-an-idiot.jpg
 
Last edited:

momo1

Sergeant
M&BWBWF&SNWVC
I meant no offense, I got confused from the comma, in the US we use a period as in 6.2 GB. As for Task Manager, I didn't doubt that you had 32GB of RAM, I wanted to make sure that Windows saw all 32GB because if it didn't, it would mean you had a physical RAM issue.
Is the game on the C or D drive?

EDIT: Just to make sure there aren't any misunderstandings, was the game using 6.2 GB, or is it that when the game runs, the whole PC uses 6.2 GB?
 
Last edited:
I meant no offense, I got confused from the comma, in the US we use a period as in 6.2 GB. As for Task Manager, I didn't doubt that you had 32GB of RAM, I wanted to make sure that Windows saw all 32GB because if it didn't, it would mean you had a physical RAM issue.
Is the game on the C or D drive?

EDIT: Just to make sure there aren't any misunderstandings, was the game using 6.2 GB, or is it that when the game runs, the whole PC uses 6.2 GB?
Ah. My bad then, i apologize. I didn't know that the comma has a different meaning in the US.

Just with opera and a twitch stream open the PC uses between 5.2 and 5.6 GB RAM with the game Running it uses 6.2 GB RAM on world Map until i move as it goes up a bit. Then it jumps to 8.2 or 8.4 GB RAM usage inside a battle.

If i go into detail view in the task manager the game itself uses between 2.3 and 2.8 GB RAM!

And the game is on D.
 

momo1

Sergeant
M&BWBWF&SNWVC
Ah. My bad then, i apologize. I didn't know that the comma has a different meaning in the US.

Just with opera and a twitch stream open the PC uses between 5.2 and 5.6 GB RAM with the game Running it uses 6.2 GB RAM on world Map until i move as it goes up a bit. Then it jumps to 8.2 or 8.4 GB RAM usage inside a battle.

If i go into detail view in the task manager the game itself uses between 2.3 and 2.8 GB RAM!

And the game is on D.
That might be your problem. Run chkdsk D: /f /r and if no errors come up, see if you can reinstall the game on your C drive.
2.8 GB is a decent amount. However, I don't think that points to a memory leak, as most people with memory leaks reported the game using much more.
 
That might be your problem. Run chkdsk D: /f /r and if no errors come up, see if you can reinstall the game on your C drive.
2.8 GB is a decent amount. However, I don't think that points to a memory leak, as most people with memory leaks reported the game using much more.
Harddrive D has also no issues.

I can not install the game on C because thats only a 110 GB Harddrive and the only thing installed on it is Windows and small essential programs.
 

Zorion_no

Regular
Harddrive D has also no issues.

I can not install the game on C because thats only a 110 GB Harddrive and the only thing installed on it is Windows and small essential programs.

I havet it installed on my D, and have not had this severe issues.
Read I dont have it being unplayable in this build, I did in other build however.

My trick though when that was the case is to unplug my network connection and play offline.

My take is that the anti-cheat-programe they used sometimes go crazy and tank performances(read when I played with my computer online I could play for 5-10 min before it got unplayable, then I jacked it out and could play for 4hrs(read I didnt play for longer in sessions, as I do take breaks tbh).
I'm not sure if thats the issue in your case, but its a "simple fix" unplug cable, see if it works, great, dont work, plug cable in.

I dont think it was directly the program at the time but most likely a conflict between it and my firewall/anti-virus perhaps.

For the record I have previously also unistalled the game, and reinstalled it(and I mean full purge where you manually go in and delete all the files that dont get uninstalled, and that didnt help me atleast).

So try unplugging the cable and see if it helps worth a shot.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Please note that we can't be sure where in the game is causing these stutters unless you record the telemetry data and send it to us. If you don't want to co-operate we can't help you to fix this issue.
 
I havet it installed on my D, and have not had this severe issues.
Read I dont have it being unplayable in this build, I did in other build however.

My trick though when that was the case is to unplug my network connection and play offline.

My take is that the anti-cheat-programe they used sometimes go crazy and tank performances(read when I played with my computer online I could play for 5-10 min before it got unplayable, then I jacked it out and could play for 4hrs(read I didnt play for longer in sessions, as I do take breaks tbh).
I'm not sure if thats the issue in your case, but its a "simple fix" unplug cable, see if it works, great, dont work, plug cable in.

I dont think it was directly the program at the time but most likely a conflict between it and my firewall/anti-virus perhaps.

For the record I have previously also unistalled the game, and reinstalled it(and I mean full purge where you manually go in and delete all the files that dont get uninstalled, and that didnt help me atleast).

So try unplugging the cable and see if it helps worth a shot.

Doesn't work for me and i already did a clean reinstall of the game as well. But thanks for the try.
Please note that we can't be sure where in the game is causing these stutters unless you record the telemetry data and send it to us. If you don't want to co-operate we can't help you to fix this issue.

Ah yes on that note can you send me my stamp card and tell me my working hours? I have friends who work as testers they get paid for stuff like that. I do not get paid for any of that. So care to explain in detail why i now work for you guys and do your job? Not trying to offend anyone but lets call one of my friends bob.
Bob works in vienna and uses all kinds of hardware and software to recreate bugs, crashes and similar stuff customers have to later send that in to another team to fix said stuff.
Maybe Bob should give you guys a call........

I will provide said information you require to help me and upload it. But i will not remove or apologize my joke about the stamp card. This is the most ridiculous thing i have encounterd in my 30 years of gaming.

And the website: http://upload.taleworlds.com is not working once you hit the upload button. Absolutely awesome.....
 
Last edited:

DragaXZ

Recruit
Since I have the same issue and also already posted in this topic I just did the performance test thingy and sent it to you.

Ah yes on that note can you send me my stamp card and tell me my working hours? I have friends who work as testers they get paid for stuff like that. I do not get paid for any of that. So care to explain in detail why i now work for you guys and do your job? Not trying to offend anyone but lets call one of my friends bob.
Bob works in vienna and uses all kinds of hardware and software to recreate bugs, crashes and similar stuff customers have to later send that in to another team to fix said stuff.
Maybe Bob should give you guys a call........
I know that it sucks but there is no need to be rude about it now. That's why it's called an "early access", bugs are to be expected. If you find a bug and want the game to be improved you should report them. I'm also working as an indie game developer and I know how hard it can be to fix bugs or issues, especially since it sounds like only we two seem to have that issue. That's why we have to send them the telemetry data so they can figure out what causes our issues.
 
Since I have the same issue and also already posted in this topic I just did the performance test thingy and sent it to you.


I know that it sucks but there is no need to be rude about it now. That's why it's called an "early access", bugs are to be expected. If you find a bug and want the game to be improved you should report them. I'm also working as an indie game developer and I know how hard it can be to fix bugs or issues, especially since it sounds like only we two seem to have that issue. That's why we have to send them the telemetry data so they can figure out what causes our issues.

Oh trust me i wasn't rude for one second there. Its a side stab joke. A spicy one maybe but not rude.
I did testing for some games. We sent in tons of stuff that didn't work and got paid for it. Even translation issues. But you also had programs to record data and send in stuff. Difference is we got paid to do that stuff.

Now i have no problem sending data over to them. But the amount of time i am wasting on this issue right now is 2 days with reinstaling the game. Checking both my harddrives for errors (D did take 6 hours) and finding online solutions for said problem. Meanwhile a game that takes way more resources on my rig "AC Valhalla" runs smoothly with 60fps despite my graphic card being not the optimal choice and lacking 2 GB of power. It just works.

I'm just tired of needing more and more of my time wasting fixing issues that shouldn't be there for more and more game titles that come out. I didn't expect the game going from crashing after 2 or 3 hours to being unplayable with a few new patches. Just makes you think you wasted your money on a game that will never work on your PC.

And the upload doesn't work for me neither as my file is 2.8 GB big but the moment i hit upload the website stops working.
 

momo1

Sergeant
M&BWBWF&SNWVC
Oh trust me i wasn't rude for one second there. Its a side stab joke. A spicy one maybe but not rude.
I did testing for some games. We sent in tons of stuff that didn't work and got paid for it. Even translation issues. But you also had programs to record data and send in stuff. Difference is we got paid to do that stuff.

Now i have no problem sending data over to them. But the amount of time i am wasting on this issue right now is 2 days with reinstaling the game. Checking both my harddrives for errors (D did take 6 hours) and finding online solutions for said problem. Meanwhile a game that takes way more resources on my rig "AC Valhalla" runs smoothly with 60fps despite my graphic card being not the optimal choice and lacking 2 GB of power. It just works.

I'm just tired of needing more and more of my time wasting fixing issues that shouldn't be there for more and more game titles that come out. I didn't expect the game going from crashing after 2 or 3 hours to being unplayable with a few new patches. Just makes you think you wasted your money on a game that will never work on your PC.

And the upload doesn't work for me neither as my file is 2.8 GB big but the moment i hit upload the website stops working.
Use Google drive
 
Top Bottom