Need More Info It crashes when you destroy the last part of the empire []

Users who are viewing this thread

Version number
No, I didn't use any mods.
I won the Northern and Southern Empire, when I won the Western One, I clicked continue and the game crashed, I tried to update the drivers, change the language, set the lowest settings, but nothing helped, there are no problems with performance
How to Reproduce: Destroy the last part of the empire (Task from Arzagos)
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video):

Computer Specs:
OS: Windows 11 Pro
GPU: RTX 4070
GPU Driver Version: 552.12
CPU: 13th Gen Intel(R) Core(TM) i7-13700F 2.10 GHz
RAM: 32gb
Motherboard: PRIME Z790-P WIFI D4
Storage Device (HDD/SSD): SSD
Last edited:
To help you further and continue our investigation oF the reported issue, we need the crash report identifier. You should see a pop-up window when the game is crashed. Please follow the instructions there to complete the upload and get the crash report identifier. It will be copied to your clipboard automatically. You can find more info about the crash report identifier here. Have you tried the workarounds for common crashes detailed here? Thanks for reporting and sorry for any inconvenience!
Top Bottom