Common problems and Solutions! (READ BEFORE POSTING!)

Currently viewing this thread:

Vincenzo

Count
M&BWBWF&SNW
Best answers
0
We will try to keep a somewhat updated list of frequent problems and solutions here. please check the soltutions here before posting your question.

I have the Gamersgate version and it does not work at all, everything is white,  or I spawn naked!
Install this:
http://download.taleworlds.com/mb_warband_setup_1153.exe

Then this:
http://download.taleworlds.com/mb_warband_napoleonic_wars_setup_1006.exe


I have Warband on Steam, and the DLC from Gamersgate/Amazon/Taleworlds, What do I do?
Go to your steam library, rightmousebutton on Mount & Blade: Warband and select “View CD Key” Write down the cd key for warband, you will need it later for the installation.

Download and install the non-steam version of warband:
http://download.taleworlds.com/mb_warband_setup_1153.exe

Then install the non-steam version of the DLC here:
http://download.taleworlds.com/mb_warband_napoleonic_wars_setup_1006.exe


That didn't work! I have some weird 5x5 serial key warband does not accept it!, what do I do?
Look here to convert your serial: http://forums.taleworlds.com/index.php/topic,155134.0.html


I have a non-steam version of warband, how do I register it with steam?
Find your warband CD key and enter it in steam, it should register the game to your steam account.


I get a error when starting the game: “Missing  xinput3_1.dll” What do I do ?
This is because you are missing the latest DirectX 9 Redistributable, get it here:
http://www.microsoft.com/download/en/details.aspx?id=35


I have the steam version of the DLC and when I try to join a server I get a “Invalid CD Key” error message.
Restart steam and it should work.


I accidentally entered a wrong character when trying to join a server for the first time, Now I can’t join a server! I just get a “Invalid CD Key” error message.
[list type=decimal]
[*]Click Start > Run
[*]Enter regedit
[*]A new window will open, browse to HKEY_CURRENT_USER > Software > MountAndBladeWarbandKeys
[*]Search the entry, serial_key_nw, make sure that the value is the same as your CD key. Also make sure that the key is separated correctly. Double click the entry and modify it until it is correct. Watch out for invisible spaces in the CD key.
[*]If you are done with that, close the Registry Window and start the game, connect to the server and have fun playing!
[/list]


How do I host a server?
Look here:
http://forums.taleworlds.com/index.php/topic,227828.0.html


Manual
You can find the full game manual here:
www.flyingsquirrelent.eu/PDX_M&B%20Warband%20DLC_Onlinemanual_.pdf

Connection is lost to server
The following quote is a compilation of fixes on this issue, note that sadly they don't work for everyone. The problem may be connected with specific INTERNET providers / routers.
gorkill said:
I've been doing some research and came up with a way to fix my specific problem. I can't assure this will solve your problem though.

These are possible methods:

*Look for the file rgl_config. Open it and look for Use_Secure_Connection. Set it on 0 if it isn't already.

*Force single threading in the configure menu when you start up the game.

*Lower your graphics to avoid too much lag (laggers usually are the first to get thrown out of a server)

*Let Mount & Blade Warband past your Firewall. you should allow both Public and Home/Personal so there's no connection problem.

*Check your Ping. This could be a reason you DC (Disconnect).

I hope any of these has been of some help. Most of them I found on different fora so I take no credit for finding the method.

Feel free to add other possible ways.

If it doesn't work don't be mad at me. I don't know how your PC works.

Enjoy M&B Warband!
 

WhiteSavage

Recruit
M&BWBWF&SNW
Best answers
0
Thanks a bunch you guys. Release is always so unreasonably hectic. Right out of the tube a lot of our clients were broken... You dealt with a lot of our problems better then multi-million $ AAA titles. Look forward to playing N and buying your future titles as long as they stay this fun :smile: Thank you FS and TW :smile:
 
Best answers
0
i got nw in taleworlds.com and i get warning:material2_defualt not found. when i tried to get in a server all the map is white then i crash
 

Vincenzo

Count
M&BWBWF&SNW
Best answers
0
the_great_knight said:
i got nw in taleworlds.com and i get warning:material2_defualt not found. when i tried to get in a server all the map is white then i crash
Install this:
http://download.taleworlds.com/mb_warband_setup_1153.exe

Then this:
http://download.taleworlds.com/mb_warband_napoleonic_wars_setup_1006.exe
 

Jarvisimo

Grandmaster Knight
Best answers
0
So, my friend very kindly tried to purchase Nw for me.
However, when attempting to buy it, he gets an error.
We think this may be due to the lack of CD keys, but I just wanted to confirm that this was the case.
Is the CD-key 'drought' still going?
 

MaHuD

Section Moderator
WBM&BNWWF&SVC
Best answers
1
Seems like it happened again:
http://forums.taleworlds.com/index.php/topic,225974.0.html

But you can also buy it from www.taleworlds.com and use the key you got to activate it on steam. That's what I did.
 

hhorde

Recruit
M&BWBWF&SNW
Best answers
0
Ok vince how about this i got it from Steam bought the whole set including the DLC from steam when i try to go into muliplayer Servers it just says unable to connect to server on EVERY server , So then i downlaoded it from the talesworld site put in my code STILL the same thing its just starting to get a annoying please help 0.o
 

Vincenzo

Count
M&BWBWF&SNW
Best answers
0
Try:
1) Find the RGL_config.txt in your "My Documents/Mount&Blade Warband" Folder and Open it.

2) Find the use_secure_connection = 1 and change it to 0.

3) If it's already 0 change it to 1

4) Save and Start Warband.
 
Best answers
0
I can't take screenshots in-game with my new laptop, so there must be another key combination to do it. Does anyone have a complete list of different combinations for it? Also, I have non-steam version of the game.
 

Leberecht Reinhold

Master Knight
WBWF&SNW
Best answers
0
Danik Golovanov said:
I can't take screenshots in-game with my new laptop, so there must be another key combination to do it. Does anyone have a complete list of different combinations for it? Also, I have non-steam version of the game.
Ctrl+Insert.
Being a laptop, it may be that Insert doesnt exist, but its part of another key. You need to push a key called "Fn" and another one that has the "Insert" label on it.

Also, F12 to use Steam screenshoot system. You dont have to have WB on steam, just launching it through it.
 

Permanganate

Recruit
Best answers
0
Hi, is there an alternate link for download.taleworlds(dot)com/mb_warband_setup_1150.exe as I can't get it to connect (likely too much traffic)
 
Best answers
0
i have version 0.000 and when i go to play it says that the server is running version 1.003. can anyone give me the link to download this?
                                                                                                                                                                                          thank you for you time
 

Vincenzo

Count
M&BWBWF&SNW
Best answers
0
Install this:
http://download.taleworlds.com/mb_warband_setup_1153.exe

Then this:
http://download.taleworlds.com/mb_warband_napoleonic_wars_setup_1006.exe
 

Konkrete21

Recruit
Best answers
0
I'm trying to join my regiments training server, but every time I do it says I don't have the required modules. I click on the link but it doesn't take me to anything to download. what do I do?
 

codybanks

Recruit
WBNW
Best answers
0
hello my name is cody hobbs i bought NW on may 5th and every time i want to join a server it says "Unable to connect to server" i read the last one about changing the files to 1 or 0 and it still dose not work plz help me  :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
 

Vinbuster

Recruit
Best answers
0
You are not alone i am having the same problem I tried doing the mb warband test it didn't work i tried the use connection file from 0 to 1 didn't work and what should the max connection be set to mine is 16 please some one help me i really want to play this game and I got wb warband it works just fine i can get into any server that doesn't have a password any ways please help me  :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry: :cry:
 

Lordeliphas14

Recruit
WBWF&SNW
Best answers
0
Yeah I'm having a problem updating whenever I try to update my Napoleonic Wars to the newest patch and I finish downloading and have to install it, it says that I don't have the game when I bought it on steam. Please help :sad:
 

Durstan

Recruit
Best answers
0
Steam will automatically update the game program.  The only thing you have to do is to make sure that the M&B game on Steam is set to automatically update and then when there is an update and the Steam program runs, the update will be downloaded.  I've been on Steam for more than a few years and have nine or ten games there and that's how the update works.  It avoids exactly that issue that you're having now.