Resolved Beta 1.4.1 new version new game breaking bug, Formation Glitch in battles

Users who are viewing this thread

KingEroc1st

Veteran
This is my first thread so I'll be including all my bug findings up to this date. Frankly I wasn't going to bother and register an account and post some bugs that others probably have done so 100 times already but this recent problem has really gotten on my nerves and the game is officially completely unplayable for me except for practice arenas so i got nothing better to do.

Got the game 1 week after initial early release. looked pretty good, i know my rig was not the most up to date and expected some performance issues, after setting everything to low i was able to play fine, with some stuttering and frame drop but completely within expectations. at this point i've already encountered 2 problems, 1 being formations never saving so you have to reset them every load. and 2 being companions will auto donate troops to garrison effectively reducing your army size.

then 2 weeks later a new patch drops, i think it was 1.2 something. came with graphics updates which was cool but a new problem began: MEMORY LEAK. I have 12GB of ddr3 ram and at the point 4GB of dedicated vRam from my gpu. a whopping 16G of usable ram yet after 1 hour or so of playing it reaches 100% and game runs as smooth as sandpaper. this problem has persisted till this day. but i can play around it by restarting my pc ever so often and i can still play.

Installed a couple of mods to negate the formation not saving and companions donating troops, worked fine at first.

Then, I decided to get a new gpu, the nvidia rtx 2060 super with 8GB of onset vRam. Theoretically i can now run the game on highest setting no problem but i'm still running it on low to preserve ram. it worked, the game became smoother, and i don't need to restart as often.

then 1.3 drops,more graphics update, totally uneeded since the game is still not fully functional, i'd rather have a working game of stick figures than perfect rendered models and unplayable but that's just me, guess that's why i'm not a developer right? another patch another bug. my mods are completely messed up now and so are my saved files. started new campaign. decided to opt in for the beta version cause i got nothing to lose. it works slightly better than 1.3 surprisingly, of course no mods this time and i have to manually reset all the formations and not hit up towns so my companions don't donate troops.annoying but playable. this is when i discovered that if you have troops in formation 5-8 (skirmisher, heavy infantry, light cav, heavy cav) they will not spawn with the rest of your army in village raids and bandit hideout attacks. but instead they'll spawn close to the enemy, sometimes even behind them.

and fast forward till now. 2 days ago i think, 1.4 dropped. and like an idiot i thought, lets keep the beta going and update it to beta 1.4.1 lol big mistake. at first it looked normal with changes and what not. but personally i don't think inflating a weapon's price to 250k (often worth 3-10 times of the total wealth of a town) is a good move or realistic. just sounds like lazy designing at "balancing" the items and forcing them to be "late game items". and here comes the Bug: total FUBAR formations in field battles. field battle is my favorite part of the game and the main reason i play Mount and Blade. so when formations are messed up i cannot play the game anymore.
the problem:
-Infantry in an almost permanent loose formation. at the start of the battle they are standing in a line, but the moment i move them, they are in loose formation very far apart from each other. and this persists when i try to switch to any other formation. line is loose, shield wall is slightly tighter but still loose, loose is basically scattered, and scattered formation is like you are trying to cover the entire battle field with your units. needless to say trying to fight with this is like auto resolving or f1+ f3+ afk.

-Archers are experiencing a similar problem but to a less degree, i'd say 30% of the times they are completely loosely formed regardless of command and 20% of the times in super tight formation (lol???) regardless of command, but still 50% of the other times they somewhat listen. problem arises when you are trying to position them on a hill which is basically 100% of the time, they are either too tight, too loose or not shooting despite having clear line of sight.

-Super long "line formation" basically sometimes when i order to form a line, my infantry or archers will do a 1 layer shoulder to shoulder super long ass line with the 200 men all the way from one end of the field to another, stretching super thin and unable to fight properly. i think in this state my troops can perform at 30% of the capacity of a brainless f1+f3 charge.

-Infantry and archers randomly splitting apart. aside from the stupid loose formation, sometimes during the battle the infantry shield wall will automatically open a gap in the middle, the soldiers in the middle will move to the sides, separating into 2 groups on the left and right. allowing enemies to pour into my army from the center, cutting it apart and hitting my back line. the same goes for the archers. they start running around instead of shooting the enemy below me after not receiving a command for 20 seconds. sometimes they'll run behind the hill cutting off their line of sight to the battle and stopping their attacks.

and lastly, i'm not sure if this is a bug or i just don't understand the algorithm of how troops are selected to go into battle. i've set the army size in battles from the options menu to 666 units(if i understand correctly, that's upto 666 units per side). my army has about 675 men and the opponent has 550. we have 85 cavalry and they have 110. but at the beginning of the battle. about 300 of my army are in and 250 enemies. but we only start with 10 cavs while they start with 60 ?!?!?!? like wtf? the 1 step ahead perk already doesn't work and i get 30 seconds to set up bugged formations before they charge me with 55% their cavs while i only have 12%? how does this make sense?

honestly even if i experienced all these problems at first i wouldn't be mad, but the fact that they come every time there's a major patch is really ruining the experience for me. its like they are actively making the game worse every week. i mean with the formation not saving. people had to have reported it 1000 times for 6 weeks now, but no fix? while they keep pumping out graphics updates, like most people are running the game on lowest setting due to how poorly optimized it is. and no self respecting pc gamer is going to value graphics over playability. so maybe prioritizing on working to fix the bugs instead of updating textures n models.

Summary:
How to Reproduce
: roughly 500 vs 500 man battle with unit setting to 500+, 100-200 infantry and archer. trying to set infantry formation on flatland and archer formation on hill
Quest/Settlement Name (if related): n/a
Media (Screenshots & Video): maybe i'll update when i play it again
Version: beta e1.4.1
Installed community-made modifications: n/a
Computer Specs
:
OS: Win7
GPU: nvidia rtx 2060 super
CPU: i7-4790
RAM: ddr3 12GB (8GB vRam on gpu)
Motherboard: asus z97-k
Storage Device (HDD/SSD): standard Hard drive no ssd
 
Last edited:

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hello, i have informed the devs about the problems you mentioned and i am sure they will be fixed as soon as possible.
 

PhlaagoRexor

Recruit
On thing to note about the formationbug: it only effects the player, enemy armies still have working formations and it seems to come up when the unitcount goes up somewhere above 200 in that commandgroup (I know I have seen it with less than 300 infantry, cant remember if I have seen it with less than 200).

I have suffered through the formation bug in every large battle in 1.4.1beta about 20% of the time the infantry is fine if I don't try to resize their formation, meaning they can be formed as they start in line formation facing the way they are but repositioned... any attempt to change formation sets them to loose formation (even though the audio for the correct formation plays). As for the archers I usually keep them deployed in loose formation 95% of the time anyway so I notice that less.
As for OP's take on the battlefield limit: I think its total number of units on field for both sides combined, the fact that he got hosed on the cavalry ratio doesn't look good though (I haven't experience that myself but the formation bug keeps me out of most big army battles)

Performance is quite good for me though although I did stop running everything at max settings back in 1.2 (its between medium and high on most options) and while framdrops still happen it doesn't effect me personally that much since I play as a horse archer (framedrops in melee as you try to connect precisely with a strike is much worse)
 

KingEroc1st

Veteran
As for OP's take on the battlefield limit: I think its total number of units on field for both sides combined, the fact that he got hosed on the cavalry ratio doesn't look good though (I haven't experience that myself but the formation bug keeps me out of most big army battles)
Yeah thanks for your input, ive noticed in the last couple of days that the battlefield limit is the combined number. Also the ai might be prioritizing sending in allied troops instead of my own troops first into the battle and since most of the cavs are in my party maybe that's why they were'nt there at the start. still, tanking a 60 man charge without my shiledwall is suicide and i've started a new save doing horse archer only army. lol
 

AlcoholV

Recruit
I kept waiting........ but hotfix still hasn't come out.
It is impossible to proceed with the game normally.
Is it meaningful to do a beta test?
 

KingEroc1st

Veteran
I kept waiting........ but hotfix still hasn't come out.
It is impossible to proceed with the game normally.
Is it meaningful to do a beta test?
i guess we are finding these bugs and they'll eventually be fixed hopefully so that's the point of beta testing, have quicker fixes.

is it impossible to proceed? i think unless you have another older saved file from earlier version you are as screwed as me. maybe try a few cheese strats now that the game is bugging you. or just say screw it. horse archers only army. ggwp like me
 

Figulus

Regular
i guess we are finding these bugs and they'll eventually be fixed hopefully so that's the point of beta testing, have quicker fixes.

is it impossible to proceed? i think unless you have another older saved file from earlier version you are as screwed as me. maybe try a few cheese strats now that the game is bugging you. or just say screw it. horse archers only army. ggwp like me
Yep cav only..until the S P A C E D O U T infantry is fixed.
 

William7667

Regular
Read somwhere that the infantry space out because theres some cavalry -- ex cavalry in them. Apparently as a work around if you ask the infantry to unhorse first I'm not sure what button to use they will then be be able to use their correct formations not tried it myself as I dont have the issue as yet
 

KingEroc1st

Veteran
Read somwhere that the infantry space out because theres some cavalry -- ex cavalry in them. Apparently as a work around if you ask the infantry to unhorse first I'm not sure what button to use they will then be be able to use their correct formations not tried it myself as I dont have the issue as yet
interesting, let me try it out thanks a lot
 

PhlaagoRexor

Recruit
Read somwhere that the infantry space out because theres some cavalry -- ex cavalry in them. Apparently as a work around if you ask the infantry to unhorse first I'm not sure what button to use they will then be be able to use their correct formations not tried it myself as I dont have the issue as yet
That actually lines up quite well with this bug happening when one of your other partyleaders in your army commands the infantry, and they would be the "ex-cavalry" in question in that scenario...
 

warpowerfull

Regular
Having the same issue with the infantry loose spacing. The weird thing is that sometimes when you click on a map there are spots where they line up normally. So I usually have to click around a lot close by in the area where I want them to be in hopes that I can get them to form up a close line. Also not sure if it was mentioned but when they are loose you can't command them to get closer, even shieldwall they do it in loose formation. I will have to try to unhorsing workaround. Hope its fixed in the next patch.
 

KingEroc1st

Veteran
since this bug i've abandoned use of large numbers of infantry and opted for a small shield wall and mass archers. the small wall of 30 man works like before. but sometimes the archers are in auto loose formation, which is fine. but the moment i put them on a hill, it depends on the precise location i click. they would be standing super tightly together, essentially the opposite problem with the infantry. but the saving grace is that i can work around it by repositioning them a few times. takes like 30 more seconds but at least playable.
 

elysebluemoon

Community Support
Community Support
Are you still having the same problem on our current build? If yes, can you upload a video of this to upload.taleworlds.com? Please paste the link to this thread in the description box on the upload website so I can identify it.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
As the asked information was not provided within 2 weeks, this thread is marked as solved. If the issue still continues, please update this thread.
 
Top Bottom