WeaponUsageData does not work ( Vanilla )

Users who are viewing this thread


Example with throwing axes:
Throwing axes are missing alternative "OneHandedAxe" mode

Image link (google drive) - in-game mode switching attempt just circles back to throwing mode ( with mode switch animation )

crafting_templates.xml from native module:

<CraftingTemplate id="ThrowingAxe" item_modifier_group="axe_throwing" item_holsters="throwing_axe:throwing_axe_2:axe_right_hip_2:axe_back" default_item_holster_position_offset="0,0,0.05" always_show_holster_with_weapon="true">
      <PieceData piece_type="Handle" build_order="0"/>
      <PieceData piece_type="Blade" build_order="1"/>
      <WeaponUsageData id="ThrowingAxe"/>
      <WeaponUsageData id="OneHandedAxe"/>
    <StatsData usage_data="ThrowingAxe">
      <StatData stat_type="Weight" max_value="7.0"/>
      <StatData stat_type="WeaponReach" max_value="300"/>
      <StatData stat_type="MissileDamage" max_value="500"/>
      <StatData stat_type="MissileSpeed" max_value="200"/>
      <StatData stat_type="Accuracy" max_value="100"/>
    <StatsData usage_data="OneHandedAxe">
      <StatData stat_type="Weight" max_value="7.0"/>
      <StatData stat_type="WeaponReach" max_value="300"/>
      <StatData stat_type="ThrustSpeed" max_value="200"/>
      <StatData stat_type="SwingSpeed" max_value="200"/>
      <StatData stat_type="ThrustDamage" max_value="500"/>
      <StatData stat_type="SwingDamage" max_value="500"/>
      <StatData stat_type="Handling" max_value="200"/>
      <!--<StatData stat_type="FollowUp" max_value="200"/>-->

Some experimentation: I've managed to add "TwoHandedMace" WeaponUsageData to "Mace" CraftingTemplate and it works. However there were many already existing WeaponUsageDatas in the file that do not work - for example "TwoHandedSword" has alternative WeaponUsageData "OneHandedSword", but this does not work.

I've tried to search through xml files in game directory and haven't found anything that could overwrite these configs - so I assume there's an issue somewhere in .dll

UPDATE1: Not a .dll bug - CraftingPiece has it's own PieceUsages - and for throwing axe components "OneHandedAxe" is disabled. Now I suppose these axes should be used in melee as well ( warband ) so I'll leave status unsolved, feel free to change it to "solved" if this is the design

UPDATE2: Marked as solved
Last edited:
Top Bottom