Warband in Linux

banker247

Recruit
WBWF&S
Best answers
0
i'm having severe slowdown issues when running MB under dx9 seems to be better on dx7. however when theres people on the screen my framerate craps out.. it could only be a few people and framerates drop massively... i wonder if i have something configured wrong as i've read someone else may have the same problem? game runs perfectly in windows i think my dx9 config in wine might be messed up.. i tried adding the direct3d to the registry that i read up earlier in the post it didn't make any difference.. any advice? i have ati
 

Caydel

Recruit
M&BWBWF&S
Best answers
0
banker247 said:
i'm having severe slowdown issues when running MB under dx9 seems to be better on dx7. however when theres people on the screen my framerate craps out.. it could only be a few people and framerates drop massively... i wonder if i have something configured wrong as i've read someone else may have the same problem? game runs perfectly in windows i think my dx9 config in wine might be messed up.. i tried adding the direct3d to the registry that i read up earlier in the post it didn't make any difference.. any advice? i have ati
Yeah, I should have mentioned that. Don't count on using DX9 with this game under Linux.
 

Muladin

Recruit
Best answers
0
Caydel said:
Yeah, I should have mentioned that. Don't count on using DX9 with this game under Linux.
i play M&B Warband now with Direct X9 and High Graphic Settings,

I installed Warband with the newest WINE Version (1.3.8 ) (with Playonlinux) and after that i add the Mouse-fix patch to the wineprefix from M&B. Also i installed DirectX 9 with winetricks!

Thats all, and now i can play M&B with maximum settings.

My system:
Ubuntu 10.10 64bit

Nvidia geforce 9600GT with 1024MB Ram
8GB Ram
Quad Core 4x2,6 GHZ Processor

It would be intressting if someone can confirm that, that M&B works perfect with the newest version (Only a few graphic glitches wenn HDR is at maximum)
 

Muladin

Recruit
Best answers
0
Here are some pictures from my play session today! And also on some pictures you can see my settings from the game!

http://muladin.mu.funpic.de/MB/

And if the pictures are not enough to show you that i play with high settings and DX9 i can make alonger video from a play session!

 

Vornne

Count
M&BWBNWVC
Best answers
0
I have been playing warband fine in DX9 mode since early beta - at first with a nvidia 6600GT and 1GB RAM, then with a 7900GS and 2GB. My computer is pretty old, so if the map is large or there are a huge amount of players the FPS can drop pretty low, but it works fine for native MP maps and player numbers. I suspect a factor in the problems some are having is that the linux ati drivers are generally worse relatively to windows than the nvidia ones.

I used the latest wine version up to 1.1.41, and then stayed with that until the other day, when I got around to finding and patching the bugs so 1.3.9 works: this black screen at start bug is the main one (probably only happens with nvidia and 64 bit linux), and for a start I needed to patch this crash on start, but strangely it dissapeared so I don't need the patch anymore; also using the latest XInput2 patch to fix the mouse bug. I'm not using any other wine tweaks, just the default wine with no dll overrides or DirectX installs; though as detailed earlier I have in rgl_config.txt "use_secure_connection = 0" to connect to servers, "use_winmm_audio = 1" for the sound to work, and "render_buffer_size = 200"; HDR doesn't work properly, but I don't care.
 

iLag

Sergeant at Arms
Best answers
0
I finally figured out my problem with sound not working.  In winecfg's library tab, quartz must not be set to native.  Setting it to native will result in the game instantly crashing unless all sound devices are disabled.  After switching quartz to builtin, the game started up just fine.  I think this discovery should be put in the first post, as quartz has to be set to native for other games to work.
However, not all was well.  The game still didn't have sound, outside of the intro video.  After experimenting, I changed use_winmm_audio to 0 and disabled mmdevapi in winecfg, and the sound came back.
 

banker247

Recruit
WBWF&S
Best answers
0
hey guys - found the fix! got the fps up..actually seems like its running better in linux than in windows now.. funny thing all i did was follow this tutorial
http://www.unixmen.com/linux-tutorials/1300-install-and-configure-wine-to-play-latest-windows-games-in-linux-ubuntu-linuxmint-fedora

and.. then made this important entry

For ATI GPU use : "VideoDriver"="ati2dvag.dll" , for Video discription and video memory use  your current video card settings.

after i did this and launched the game EVERYTHING drastically improved and i believe i was right earlier that the game wasn't using all of my video memory - so this wasn't a game issue it was a wine config issue.. mind you i have ATI and am having NO problems now hope this helps someone.. this was my 30th or so attempt and i almost gave up however now everything is running great see you in deathmatch!
 

Dilettante

Recruit
WBWB
Best answers
0
@banker247: Awesome! And thanks for sharing! Indeed, to have an acceptable FPS, I used to disable most features from both regedit and M&B, to the point that it looked cartoonish. Now it looks good and it's fast, although I disabled some features and lowered some settings because I'm on a poor laptop graphic card.

And btw, I'm not using the stable version but some last one - 1.3.10. I'm also on 64bit - I was not sure if it will work on my computer.
 

banker247

Recruit
WBWF&S
Best answers
0
what features did you disable in regedit to increase FPS - i'm on a laptop hd2600 and performance still gets kinda choppy in sieges and 100+ man instances
 

Dilettante

Recruit
WBWB
Best answers
0
banker247 said:
what features did you disable in regedit to increase FPS - i'm on a laptop hd2600 and performance still gets kinda choppy in sieges and 100+ man instances
Both now and then: UseGLSL=disabled. Previously I was disabling pixel shader, too (PixelShaderMode=disabled or $ winetricks psm=off) - now I just disable it in M&B.
Then, I put most M&B settings at a minimum, just I don't disable "fast water reflections" and "ansotropic filtering".
 

adept7771

Recruit
Best answers
0
Hello! Make sh file, thats need to run Wine + mouse Fix. It's doesnt work!  :mad:
I take modifyed file from forum (dinput.dll.so) ant put it into wine directory. There was the same file, i backuped him.
Ordinary start without sh script starts the game normally (but with mouse bug)...

I write to sh script:

#!/bin/sh
cd "/home/adept/.wine/dosdevices/c:/Program Files/Mount&Blade Warband/"
export WINEFORCEMOUSEWARP=yes;
wine ./mb_warband.exe

When i starting it from terminal with - sudo sh myscript.sh, thats say to me:

cd: 2: can't cd to /home/adept/.wine/dosdevices/c:/Program Files/Mount&Blade Warband/
: not found:
wine: /home/adept/.wine is not owned by you

But when i say to terminal cd "/home/adept/.wine/dosdevices/c:/Program Files/Mount&Blade Warband/" - i see the files, and directory exists!

About owning, i push the command, chown -R adept.adept /home/adept/.wine , but error stil appearing...

Help me plz..... :oops:
 

Vornne

Count
M&BWBNWVC
Best answers
0
adept7771 said:
When i starting it from terminal with - sudo sh myscript.sh, thats say to me:
Firstly, don't use sudo or sh; programs with wine should never be run as root, only as your user; just change to the directory that the shell script is in, and run "./myscript.sh"; or alternatively give the absolute path from anywhere, like "/home/adept/myscript.sh".
adept7771 said:
About owning, i push the command, chown -R adept.adept /home/adept/.wine , but error stil appearing...
The correct chown command would use a ':' rather than '.', like "sudo chown -R adept:adept /home/adept/.wine".

If you are willing to compile one of the latest versions of wine, and have a fairly recent linux distro, you could use the XInput2 patch rather than the old mousewarp one, to fix the mouse bug. It's a much better solution; allowing rotation on the SP world map at the screen edges, and not warping the pointer back to the middle when you hit the edge, in menus.
 

adept7771

Recruit
Best answers
0
Vornne said:
adept7771 said:
When i starting it from terminal with - sudo sh myscript.sh, thats say to me:
Firstly, don't use sudo or sh; programs with wine should never be run as root, only as your user; just change to the directory that the shell script is in, and run "./myscript.sh"; or alternatively give the absolute path from anywhere, like "/home/adept/myscript.sh".
adept7771 said:
About owning, i push the command, chown -R adept.adept /home/adept/.wine , but error stil appearing...
The correct chown command would use a ':' rather than '.', like "sudo chown -R adept:adept /home/adept/.wine".

If you are willing to compile one of the latest versions of wine, and have a fairly recent linux distro, you could use the XInput2 patch rather than the old mousewarp one, to fix the mouse bug. It's a much better solution; allowing rotation on the SP world map at the screen edges, and not warping the pointer back to the middle when you hit the edge, in menus.
Bit thx Vornne! But i make it myself *_* )))) what i did?

SH file:

env WINEPREFIX="/home/adept/.wine"
export WINEFORCEMOUSEWARP=yes;
wine C:\\windows\\command\\start.exe /Unix /home/adept/.wine/dosdevices/c:/users/adept/Главное\ меню/Программы/Mount\&Blade\ Warband/Mount\&Blade\ Warband.lnk

I just copied the parameters of shortkut, which was created by Wine automaticaly after unstall the game (parameters env, wine link, and .lnk path) and adde to it our parametr about Export! That's all ^-^ )))

Thanks for help )!!!
 

adept7771

Recruit
Best answers
0
Hi there guys! Sorry but i come to get help again.

Warband works not correctly, there are too many lags with video options. I set video to minimum but it no give me any results... when 2-3-4 enemyes come to me, video card start to hang up. there is no possibility to play in game with this lags... I have 4 Gb Ram, have powerfull quad core processor, and game hanging up! Its wonderfull!

But in the windows all normally without any lags.

I think problem in some dynamic lybraries working with video, in wine.
In first post topic starter says "1.) (May not be necessary) Acquire and install DirectX 9.0c in Wine, or copy data from the .cab files as described in the link above"

Not found where described in topic - how to install dx 9.0 to wine, or any words about this ".cab" files. I'm blind?)))
 

adept7771

Recruit
Best answers
0
Vornne said:
adept7771 said:
When i starting it from terminal with - sudo sh myscript.sh, thats say to me:
Firstly, don't use sudo or sh; programs with wine should never be run as root, only as your user; just change to the directory that the shell script is in, and run "./myscript.sh"; or alternatively give the absolute path from anywhere, like "/home/adept/myscript.sh".
adept7771 said:
About owning, i push the command, chown -R adept.adept /home/adept/.wine , but error stil appearing...
The correct chown command would use a ':' rather than '.', like "sudo chown -R adept:adept /home/adept/.wine".

If you are willing to compile one of the latest versions of wine, and have a fairly recent linux distro, you could use the XInput2 patch rather than the old mousewarp one, to fix the mouse bug. It's a much better solution; allowing rotation on the SP world map at the screen edges, and not warping the pointer back to the middle when you hit the edge, in menus.
Vorne can you help me to setup this patch. I follow your link. I saw there many comments and link to download the patch file. How i can install this new mouse patch to the game?  :???:
 

Vornne

Count
M&BWBNWVC
Best answers
0
That patch depends on a recent version of the Xorg server, which if you are using ubuntu (my guess) you need to have a recent version (lucid / 10.04 or greater), I think. You then need to either download the wine source code for version 1.3.9 (1.3.10 might work, I don't know) or use git and check out the wine-1.3.9 tag, save the latest patch in the bug report to a file in the wine source directory, run "git apply patch_file_name_here" or "patch -p1 < patch_file_name_here" which should complete successfully, then compile wine with "./configure --disable-tests" and "make" - which will probably take an hour or so unless you have a fast computer. Once that is done, you should have a script called "wine" in your source directory, which can be used to run the new version; so you would change the usage of "wine" your script to "/home/adept/wine_src/wine" or whatever. If the configure or make steps fail, you might need to install the common development tools: for ubuntu try something like "apt-get install build-essential" - if I recall correctly, I use the gentoo distribution myself.
 

Thallian

Squire
WBWF&SNWVC
Best answers
0
The 1.3.10 version of wine works definitely too.
I patched the source and built it successfully a few days ago (after getting all the different dependencies on which it relies). The hard thing was to realise that I had to install the xinput2 libraries which I had not by default (and wine doesn't complain if you want to build the patched version but haven't got the correct xinput libraries). After fiddling around with the registry and sound settings warband now runs as smooth as before on windows (maybe even better^^).

this link helped me with the registry settings: http://www.unixmen.com/linux-tutorials/1300-install-and-configure-wine-to-play-latest-windows-games-in-linux-ubuntu-linuxmint-fedora
and this post with the sound: http://forums.taleworlds.com/index.php/topic,99405.msg3602004.html#msg3602004

Thanks to all those who provided me this information here =)

(I am on Lubuntu 10.10 btw)
 

adept7771

Recruit
Best answers
0
:grin: i has wone lags and hungs with video. I just set in video - Directx7! And now there is no hung up! Yeeeep!!!)

But mouse with old dinput.dll.so still work not correctly ! When you looking to right side of screen or up (down), all normally, but when you truying go to left side or you see in left corner of screen, appearing system mouse arrow! i think wine simply cant fixe coursor of the mouse when you torn to left.

Maybe there is method to solve a problem without making wine from source code? I noob in linux and afraid make harm to the system and wine.

 

Thallian

Squire
WBWF&SNWVC
Best answers
0
I could try to describe all the steps needed to build wine from source (it is actually not that hard). But you would have to wait untill I am at home (around 7 PM).