[Outdated] BRF Edit --out-of-date, see OpenBRF-- (last version 12/5/2008)

Currently viewing this thread:

Status
Not open for further replies.

ealabor

Baron
WB
are you guys setting up your version lines in .ini ?

at the bottom
Code:
works_with_version_min  = 960
works_with_version_max  = 960

Also I notice the in BRF color tool actually transfers the true color painted to the game now.

Its a nice fix, as previously I had to make colors a little darker in BRF for them to translate in game.

However this means that I'd have to recolor many of the models ive touched, specifically the sleeveless armours which show different skin tones. Has anyone figured out the paint tool for the new version, or if it works for that matter?
 

Shik

Baron
M&BWBWF&S
Alright, after testing this new BRF edit, it turns out I'm still having a few issues.

Whenever I open up BRF edit, I get an error that says unable to open mb.fx. No idea why. (Is anyone else having this problem?) Now, I figured out that mb.fx was the file with all the shaders in it. That explains why some models turn out pitch black in viewing - they are using those particular shaders. It seems that I'm having problems with all of the items that are using the newer shaders.
 

ealabor

Baron
WB
Fei Dao said:
Alright, after testing this new BRF edit, it turns out I'm still having a few issues.

Whenever I open up BRF edit, I get an error that says unable to open mb.fx. No idea why. (Is anyone else having this problem?) Now, I figured out that mb.fx was the file with all the shaders in it. That explains why some models turn out pitch black in viewing - they are using those particular shaders. It seems that I'm having problems with all of the items that are using the newer shaders.

have you updated your drivers? Thor put a link up along with the BRF on the repository
 
damnit I can't get this thing to work.

I open it and the first 75% loads pretty fast but a long error message comes up and windows start lagging horribly and it wouldn't continue loading. 30 seconds later another(the same one?) long error message comes up and after I close that it takes another 30 seconds for another one to come up.

After that windows semi-freezes(everything is too slow to do anything) and eventually another error message comes up.

Anyone have any idea what might be causing this?

I cam kind of suspecting that the Editor loads all the module.ini files it could find, and I still have older versions of MB in my C drive, so maybe it's loading those and causing the problem?

So could Thor tell me what the editor is loading while it loads?
I am sure the problem is caused by one of the things the BRFEditor is loading since everyone else seem to be able to successfully load it.
 

Spanky

Veteran
Thorgrim, I can't realy complain since you're the one putting all the hard work into this. Thanks!

The new version allowed me to import my own, older brf with weapons and armor into costumes_c as a preliminary workaround. I put this new version into the module's resource folder and changed the module.ini entry for that file to load_mod_resource. Works great! Hope that helps the rest of you guys having problems. Ealabor, fyi it didn't help changing the minimum version number previously.


Zephrelial said:
Spanky said:
Guys, am I right in that no one has been able to use this version with .960? I tried merging a BRF I had made for.903 with one of the .960 ones as well as using the .brf on its own in the resources folder of my module. In both case, the game hangs up on loading the module.ini (the load resources reference is at the same point as in the .903 version). I'm thinking there's something about the new brfs that the editor isn't tackling...


    I use the old version of brf editor and the very samething happened to me always sofar. :sad: Maybe it has nothing to do with the brf editor.

  Here is the whole deal guys:

  I suspect that there is a problem with the module.ini of version 0.960.I downloaded the module system and made some modifications and everything worked fine.However when I attempted to put my items.brf file at under the resource folder,and when I entered the line:

  load_module_resource = zeph_items

  at the module.ini file...

  When loading and when the game processing the module.ini file I got an assertion failure error.The textures are at the correct places.Everything is in place but the game just does not accept my brf file.I've checked if it was anything wrong with the brf file for the game to prevent from loading.. However the test worked fine.. At version 0.903 the game was able to load,and when processing the module ini no problem occured.

  Has anyone encountered a similar problem? Am I missing something? Currently I can't add any items.Thank you.



That's exactly the problem I had. My guess is that there is something about the old brf format that produces the error when it's loaded into the file. One might be able to open and save it again with the new editor version to get a working file?


 

Zephrelial

Recruit
WB
@Ealabor-  I've checked the module.ini and checked the codes as well.Everything seems normal:

works_with_version_min  = 960
works_with_version_max  = 960


@Spanky- The new brf editor seems to be problematic as well.But I think it's worth a try.Uhh where exactly can I download the most recent editor,along with its patch?
 

Spanky

Veteran
That's right Zephrelial, I recommend you try - it worked for me. It's right on the first page of this thread, the topmost download link. Good luck
 

Ancientwanker

Master Knight
Hey, that's great Thorgrim.

You are the one indispensible person in the modding community so hopefully you can continue to find some time for m&b.
 

Llew2

Cheap ass bum
Count
M&BWB
Ancientwanker said:
Hey, that's great Thorgrim.

You are the one indispensible person in the modding community so hopefully you can continue to find some time for m&b.
Aye, 'tis truth.

We should have a Thorgrim's day on Taleworlds.  :razz:
 
I don't believe my eyes but the editor is working(!!!!)

I moved all the old Mount and Blade versions into a new folder and the editor loaded.
I think it was the texture locations in all those old module.ini files that caused the freeze.


Once it's loaded the stuff inside are all black for some reason but I can live with that.
(nvm works perfectly now)
(IT'S PERFECT!!!!!)

Llew2 said:
We should have a Thorgrim's day on Taleworlds.  :razz:
I should sig that...
 

grailknighthero

Sergeant Knight
M&BWBNW
Installing new versions over old versions causes problems for some programs.  I imagine a lot of unexplained bugs for M&B happen because some people have installed .89x over .808, .90x over .89x, .95-6x over .90x.  This can cause major problems and the same is for BRFEDIT.  Always install new versions (there usually isnt a problem with a patch)  to a new folder.
 
Ok it can't import edited meshes.
It says can't load module.ini and can't load something from an old MB version's folder.
the new mesh just doesn't show up.


Nvm I got it working by logging into a different account.
 

Zephrelial

Recruit
WB
Spanky said:
That's right Zephrelial, I recommend you try - it worked for me. It's right on the first page of this thread, the topmost download link. Good luck

  Thanks a lot.Glad to hear that it worked for you..I'll try it right away.
 

Kayne

Sergeant
uhh... i'm having the d3d9_29.dll (or whatever its called) problem upon install and running. Went to the direct x site (i have ati Radeon X300se) and turns out i already (probly my dad) had it, and seems to have been run... should i also do the genuine windows check?
 

andrewzx

Regular
ealabor said:
andrewzx said:
i keep getting an assertion failure when trying to add new brf files, anyone have a fix for it?

have you installed over an old BRF version?

no i deleted the whole brf folder before installing new version. was installed on a second drive, and windows never had it as a removable program. no uninstall icon either for the brf editor.

i think the problem is that for some reason the editor isnt recognizing thet texture files. the .dds is fine but in the brf itself on the texture tab its always blank nothing comes up.
 

kavien

Banned
error message I got after installing:

this application has failed to start because d3dx_29.dll was not found.
re-installing may fix this problem.

I re-installed it, same error. any suggestions on how to fix this?
 

Apollon-04

Check the first page, throgrim gives a link to dowload those .dll's.
 

Mirathei

Sergeant Knight
I'm still getting the error about d3dx9_29.dll despite installing the recommended link. Any idea how to fix this?
 
Status
Not open for further replies.
Top Bottom