[Outdated] BRF Edit --out-of-date, see OpenBRF-- (last version 12/5/2008)

Currently viewing this thread:

Status
Not open for further replies.

Apollon-04

Well, first of all, are you sure they were dowloaded and installed correctly?

If so, maybe try redownloading BRFEdit, or possibly restarting your computer.
 

grailknighthero

Sergeant Knight
M&BWBNW
Mirathei said:
Tried all of the above. What is the correct install location?

I dont think it matters where.  Ive installed it to my desktop, c drive, and a flash drive before, although the desktop is on the c drive but o well.  Have you tried to re download it?  Sometimes downloads become corrupt, although that is rare.

Also
Thorgrim said:
Download Link: 
Download BRF Edit 0.8.95
Mirror: http://members.iinet.net.au/~dstent/mnb/BRFEdit0-8-95.exe
Requires .NET framework:  Download

If you get an error about d3dx9_29.dll not being found, try download a new DirectX version, such as the following one:  Download
Note that any DirectX version since Feb 2006 should be supported, so this should not be an issue for most people.

If you have any problems running BRFEdit, make sure you have the latest drivers:
For Ati cards: http://ati.amd.com/support/driver.html
For Nvidia cards: http://www.nvidia.com/content/drivers/drivers.asp
 

Zephrelial

Recruit
WB
Spanky said:
That's right Zephrelial, I recommend you try - it worked for me. It's right on the first page of this thread, the topmost download link. Good luck


  Worked like a charm Spanky!! Thanks everyone..  :grin:
 

James

Grandmaster Knight
For some reason, every time I try to change the material of a model, it turns black and won't show anything. The thing is, it does it to more than just the one I tampered with, but not all the models in the file. They are .smds, if that matters.

Help?

EDIT: never mind. Apparently, having shaders on did something weird.
 

Zephrelial

Recruit
WB
andrewzx said:
still getting the assertion failure error when trying to add brf files, there any fix for this?


  All you have to do is .. After having copied the brf file to the resource of v0.960,you need to open your brf file and save it again.. (do it for each one of brf file you intend to add) when you apply this the assertion error will be no more.
 

andrewzx

Regular
i encountered no problems for v9.60, but still have assertion error for v9.03. Also how come in the brf file the texture doesnt show? name of texture is there but no image.
 

Apollon-04

For some reason, and brf files I open from a module, the textures won't show up. The models are all black.

Similarly, the textures themselves are just blank in brfedit.
 

Shik

Baron
M&BWBWF&S
Jallon said:
For some reason, and brf files I open from a module, the textures won't show up. The models are all black.

Similarly, the textures themselves are just blank in brfedit.

I'm getting that too - I'm only getting it on the newer models though - the old models still work fine. I think it has something to do with shaders - whenever i open up brf edit, I get "error opening mb.fx" which of course, is the shaders file.
 

Elenmmare

I'm getting a problem with map icons.

I took a castle icon and turned it into a planet. Made a texture and all, then followed this tutorial:
http://mbx.streetofeyes.com/index.php/topic,17.0.html

Anyway, I made a seperate Material, Mesh, and texture already. (Note, the BRF edit added the code into my .ini file automatically, should I change it or what?)

It didn't work, even after giving the planet the new mesh code.

Fine, so I made 1; I took all the files and imported them, adding that to the code. Didn't work. I'm not sure if this is limited to map icons, but can someone help out?


EDIT: scratch that, it worked, my own stupidity.
 

grailknighthero

Sergeant Knight
M&BWBNW
grailknighthero said:
Thorgrim said:
Ok, so I just uploaded a minor patch.  It should add support for loading older BRFs.  This should make the porting process a little easier for some of you.  Note that it will still only save in 0.950 format, so you cannot really use it for creating mods for older versions of M&B.

Also note that this is again a very quick fix.  At the moment I can only manage to spend maybe an hour or 2 every couple of weeks working on M&B projects, and although some people may not realize it, it takes quite a lot of time to keep something like BRFEdit up to date.  Especially when you consider that I have no source code to know what the BRF files contain.

It is also kind of unfortunate that I got half way through re writing most of the rendering engine, and then ran out of time.  So yes, there are lots of bugs, and some features that don't work at all, and I apologize for the delay in getting things sorted out.

Awesome.  Before it took me hours to get a few models ported.  Thanks Thorgrim.

Edit:  If anyone is having troubles with the viewing area, be sure to delete the old 0.8.9 version and not install over it (install to a fresh folder), otherwise there are problems.

grailknighthero said:
Installing new versions over old versions causes problems for some programs.  I imagine a lot of unexplained bugs for M&B happen because some people have installed .89x over .808, .90x over .89x, .95-6x over .90x.  This can cause major problems and the same is for BRFEDIT.  Always install new versions (there usually isnt a problem with a patch)  to a new folder.
 
Ugh! I can't get this to work even after downloading the .Net software and the latest drivers for my GeForce video card with the latest DirectX version. Help!
 

andrewzx

Regular
so many problems and no help.... 10 points for the internet and 50 for the people who dont care and dont want to help. lol

still having assertion failure for ver 9.03, if its because of new brf then could someone send a link to download an older version?
(even though i dont see how it wouldnt be compatible with older versions of M&B)

Anyways if anyone can get back to me thx alot for the help and the effort.
 

andrewzx

Regular
the brf works fine, except that for some reason the textures in a brf file are blank, the name of texture is there but it doesnt show. Then while trying to add a brf file to a v9.03 game i get an assertion failure.
 
Status
Not open for further replies.
Top Bottom