Hosting a Dedicated Server Guide

Ra'Jiska

Subforum Moderator
WF&SWBNWM&BVC
Best answers
0
bigwizard93 said:
how do you change module
Make sure your server holds the module you like in the folder 'Modules/' and its configuration file (if needed) in the folder '/'.
You're now ready to change the launching options (in the .bat file on Windows), with:
Code:
mb_warband_dedicated.exe -r <Mod_Config_File.txt> -m <Module_Name>
 

yedrellow

Sergeant at Arms
Best answers
0
Hey guys, I got access to a server sort of that I know very little about in terms of pretty much anything at all. And I have the task of trying to improve the performance of it. There is a bit of an issue where hit registration seems a bit unreliable and people often move jerkily after bumping them from time to time.  The only line I can really modify for performance is probably the below line.

set_upload_limit 1000000000


I know literally nothing about this server, and it's a complicated story for why I even have access at all (would have died otherwise, and no other battle server over here).

The main question is this, is slight jerkiness in movement and poor hit registration a sign of a poor processor or a poor upload bandwidth? If it's the hardware I can't really do anything about it. I realise that this value is already really high, maybe if it was set too high that could be the cause of it as well.

Does anyone have any thoughts?
 

Namakan

Sergeant Knight
WF&SNWWBVC
Best answers
3
Regular restarts help a lot. Not sure if increasing the upload limit would help, never had to do that so far.
 

yedrellow

Sergeant at Arms
Best answers
0
Namakan said:
Regular restarts help a lot. Not sure if increasing the upload limit would help, never had to do that so far.
I was thinking it might have been the other way around, that value is 100Mb upload and while I have no knowledge of the server, I sincerely doubt the server actually has access to that. Could overshooting this value cause jerkiness?

It is already scripted to restart once a day at 5am, people anecdotally say that it is better in the morning, but I am unsure if it is because of this restart or other issues (bandwidth becoming less available is a possibility). I might try to restart when I notice this lag to see if it causes it to disappear instantly, or if there's another cause.
 

elcapo29

Sergeant at Arms
Best answers
0
Have any of you guys ran a server while using Kaspersky Anti Virus. I could run one before just fine, but with Kaspersky I can't seem to get it to work even after following all the steps on Kasperskies web site. Thanks!
 

AK Jedi

Recruit
Best answers
0
Hi so I have a Belkin Router and I have followed all the steps so far but when I got to step 4 on the website for finding a port, i could not find default guide, so what do I do?
 

EmielRegis

Sergeant Knight at Arms
Best answers
0
AK Jedi said:
Hi so I have a Belkin Router and I have followed all the steps so far but when I got to step 4 on the website for finding a port, i could not find default guide, so what do I do?
No one here will find how your router works for you.  This is individual problem for each router model.
 

KissMyAxe

Master Knight
WBWF&S
Best answers
0
Has any of you had a problem where the faction randomizer appears biased? We've been often getting the same factions for many maps in a row. I know "that's how randomness works", but it's been happening so often it's suspicious. Can the randomizer be broken from a module modification? FYI, here's the relevant part of the config. I think it's pretty standard, but maybe I've done something wrong?

Code:
add_factions fac_kingdom_1 fac_kingdom_1 # Swadia
add_factions fac_kingdom_2 fac_kingdom_2 # Vaegirs
# add_factions fac_kingdom_3 fac_kingdom_3 # Khergits
add_factions fac_kingdom_4 fac_kingdom_4 # Nords
add_factions fac_kingdom_5 fac_kingdom_5 # Rhodoks
add_factions fac_kingdom_6 fac_kingdom_6 # Sarranids
set_randomize_factions 1
 

aekilju

Sergeant Knight at Arms
WBNWVC
Best answers
0
KissMyAxe said:
Has any of you had a problem where the faction randomizer appears biased? We've been often getting the same factions for many maps in a row. I know "that's how randomness works", but it's been happening so often it's suspicious. Can the randomizer be broken from a module modification? FYI, here's the relevant part of the config. I think it's pretty standard, but maybe I've done something wrong?

Code:
add_factions fac_kingdom_1 fac_kingdom_1 # Swadia
add_factions fac_kingdom_2 fac_kingdom_2 # Vaegirs
# add_factions fac_kingdom_3 fac_kingdom_3 # Khergits
add_factions fac_kingdom_4 fac_kingdom_4 # Nords
add_factions fac_kingdom_5 fac_kingdom_5 # Rhodoks
add_factions fac_kingdom_6 fac_kingdom_6 # Sarranids
set_randomize_factions 1
I have no idea how the randomization actually works but on the GK servers we have had the same issue of getting the same factions many maps in a row. I think it's just a bug or something
 

Lord-Newt

Recruit
Best answers
0
does this work on hosting dedicated servers for mods (persistent world,persistent frontier, anglo-zulu war mod, to name a few)?
 

aekilju

Sergeant Knight at Arms
WBNWVC
Best answers
0
Lord-Newt said:
does this work on hosting dedicated servers for mods (persistent world,persistent frontier, anglo-zulu war mod, to name a few)?
Yes
 

HeroSlayer951

Recruit
WB
Best answers
0
Hello there Warband communitty.I have a problem.Me and my friend to be exact have a problem.We can't play multyplayer.Every time we connect to a server it's just kicks us automaticly.We just bought the game,after playing the trial version for a very long time,and nothing that we try works.The rege edit fix nope,the rgl config fix nope,nothing.Please if you have any insight into this problem please,helps us.We have a copy of the game on steam and steam support doesn't do anything for us.I created this account in the hopes of getting a answer or a solution.Please,it's one of the best games i have ever played,and i want to play battle time with my friend on the modpack floris.Please.Thank you for your attention.
 
Best answers
0
Hello, where can the dedicated server files be downloaded for 1.173?
The link on the taleworlds website is for 1.171u and trying to manually enter 1.173 states it can not find the resource.
Napoleonic Wars has it updated it seems, should I just use that?
download2.taleworlds.com/mb_warband_napoleonic_wars_dedicated_1173_nw_1200.zip
 

Ra'Jiska

Subforum Moderator
WF&SWBNWM&BVC
Best answers
0
LowLatencyServers said:
Hello, where can the dedicated server files be downloaded for 1.173?
The link on the taleworlds website is for 1.171u and trying to manually enter 1.173 states it can not find the resource.
Napoleonic Wars has it updated it seems, should I just use that?
download2.taleworlds.com/mb_warband_napoleonic_wars_dedicated_1173_nw_1200.zip
Yes, use this link. You may want to keep only the binaries out of the archive and extract them in your own warband dedicated folder.
 

Dredd4DoM

Recruit
WBNWM&B
Best answers
0
I have made every single step and still I can only host the server only in LAN.
For some reason I can't change to NW module too. I change the bat file to -m Napoleonic_Wars but still it says native.

Help me please, I have spent a lot of time and can't think anything else to do..
 

Woeski

Veteran
WBNWVC
Best answers
0
Papagiorgis said:
I have made every single step and still I can only host the server only in LAN.
For some reason I can't change to NW module too. I change the bat file to -m Napoleonic_Wars but still it says native.

Help me please, I have spent a lot of time and can't think anything else to do..
I thought you had to change the .exe or something. Which .bat file do you mean?
 

aekilju

Sergeant Knight at Arms
WBNWVC
Best answers
0
Papagiorgis said:
I have made every single step and still I can only host the server only in LAN.
For some reason I can't change to NW module too. I change the bat file to -m Napoleonic_Wars but still it says native.

Help me please, I have spent a lot of time and can't think anything else to do..
Are you sure that you have a copy of the NW module in the server's module folder? Not the game's module folder. Also keep in mind that NW has its own dedicated server files separate from the normal Warband ones.
Be sure that your ports are forwarded properly. FYI if you are hosting a server on your home network and try to join from a computer on the same network your server will always show up in the LAN list. It will be visible in the internet list for everyone else.

Woeski The Husky said:
I thought you had to change the .exe or something. Which .bat file do you mean?
He means the batch files used to start the server program. "-m Native" for example in one of the batch files tells the server to start using the Native module, but it needs a copy of whatever module you want to host in the server's module folder.




Just realized as I finished this post that I'm two months late.
 

revoltinstyle

Recruit
Best answers
0
Whats up with the server downloads? I can't access the 'download2.taleworlds.com/mb_warband_napoleonic_wars_dedicated_1173_nw_1200.zip' page without it taking atleast 10 minutes for it to start downloading, and it says the download will take a few days. My internet is fine, is the site down or something?