Need More Info Bannerlord not launching from launcher

Users who are viewing this thread

Version number
e1.7.1
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
Won't upload
Summary:
How to Reproduce: Whenever I launch the game I get an application faces an error message and game closes. TWcrash uploader, won't upload, says failed try again.
Have you used cheats and if so which:
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10
GPU: NVidia GEforce GTX 1650
GPU Driver Version: 31.0.15.3758
CPU: INTEL (R) Core (TM) i5 - 9400f CPU @ 2.90 GHz
RAM: 16GB
Motherboard:
Storage Device (HDD/SSD): Tried Both

Hi there, have been playing Bannerlord sucessfully for a number of years, but it has stopped working, I have tried everthing, and nothing will get it working.

I have tried:

  • Re-installing game (multiple times)
  • Updating graphic drivers
  • Updating various dotnet files
  • Moving to a different hard drive
  • Validating files (many occasions)
  • Running from various .exe's from the game folder
 
Hey, have you tried our workarounds? If the issue is persistent please let me know.
‘Launcher not Launching’ / Game is not launching Workarounds
If you experiencing any issues with the launcher, you can try the workarounds here to fix the issue.
 
You are trying to play an old version. Could you try to reproduce this issue on the latest version of the game?
 
Back
Top Bottom