Need More Info Application crashed because a fatal error occurred while checking sound bank files. CRC Check failed!

Users who are viewing this thread

Version number
Yes, but I removed mods.


Well I have a crash for few days now which gave me this message:

Application crashed because a fatal error occurred while checking sound bank files. CRC Check failed!

Re-validating game files may solve this issue. -

-File(s) : *.bank
-Error : Validation failure

For your information i can still play the game but i don't have any sounds and if i click on the ok button of the error message the game shutdown so for now i just move the window away and i still play without sound but it is annoying.

I know that several people have already reported this problem but I tried all the solutions already discussed and still don't work I tried:

- checked the integrity of the game

- deleted the sound folder BUT when i do that i have exactly the same error but with *.sedf now

- modified in the engine_config.txt file the code line "sound_device = 0" to "sound_device = 1" (apparently this solution worked for some but not for me)

- chech if some of my pc files are corrupted by doing "sfc / scannow" but nothing was corrupted

- Tried a "Clean install" method

And for your information i do have mods but even without mods i have the same problem so it is not link with mods

I'm desperate if anyone can help me I'm interested
Last edited:
Could you try the workaround below and report back please?
“.bank” sound bank file-related crash
If you crash with a sound bank file problem, you can try the workaround below to fix it:
  • Open: “C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Sounds\PC” folder.
  • The error message should have the name of a file with the file extension “.bank”.
  • Locate and delete the file in the folder.
  • Verify the game files.
I can not try this because the error message is :

-File(s) : *.bank

So the name of the file is not specified
I tried to delete all the soud/PC folder but doesnt work and even try to delete all the SOUND folder but when i did this i had a new error message with :

-File(s) : *.sedf
Top Bottom