Need More Info Resource Browser Factor color in resource editor and importing textures not working correctly

Users who are viewing this thread

Version number
1.5.7
Branch
Main
Modded/unmodded
Modded

Lonewarrior

Sergeant
The Coloring on the resource browser when opening an armor for example is not working.

Firstly the items are too bright.

HOW IT USED TO LOOK in older versions of the game:
8MR7vnD.jpg




Please note the darker color is fine and working, i reduced the factor color

Importing same armor and textures to a brand new module:

This is what happens in the resource browser:
txMhFmj.jpg



Note that the colour is much lighter and has weird artifacts
Changing factor color 2 has no effect at all:



Ai4W2lB.jpg








In previous versions this would make the armor be darker but the colour hasnt changed when using the lower factor colour See below:



YmAyY61.jpg


These texture issues happen with both textures imported and textures already added in 1.5.6
 
Last edited:

Lonewarrior

Sergeant
Edit: changing to metallic shading has helped on some armors but I’m still getting weird colours on some of them
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Buracula

Developer
Hi, can you please check if the corresponding material has "use_double_colormap_with_mask_texture" flag set in the "Material Shader Flags" pane in Material Editor. If this flag is set, shader requires a suitable mask texture in Diffuse2 slot to determine which regions of mesh will be affected by factor color. If you want factor color to be applied to the whole mesh, then you can unset this flag and no mask texture will be required.
 

Murat Türe

Developer
Those factor color slots that you change are being used by the in-mission faction colors, namely the primary and secondary colors. It is normal for the game to override those.
 

Lonewarrior

Sergeant
Those factor color slots that you change are being used by the in-mission faction colors, namely the primary and secondary colors. It is normal for the game to override those.
Sorry for the late reply.
I had forgotten about this.
I’ve since solved it by using some different layers.
I still have some issues where it won’t always come out the same color as I Set it in substance painter (where in the past it always would)
But I’m able to work around it now
 
Top Bottom