Need More Info CTD when entering Amitatys, after 5 hours CTD in every battle

Users who are viewing this thread

Version number
No, I didn't use any mods.



Hey guys,

i am experiencing crashes when I am entering Amitatys on foot. The game progresses to the loading screen, then 1 sec black screen, followed by a CTD.

Every time i get the same message d3d_device_context_ -> Map at rglGPU_device::lock_texture Failed!

I tried every solution i could find:

Lower Graphics, put shadows on none, increased texture budget etc. Nothing helped, the I checked for corrupt files, made a clean install (erased every folder). Again nothing helped, also raising my VRAM didnt help. I know the standard answer is its a GPU issue. The thing i played the game for 200h hours without any problems a year ago, big battles etc. on high settings, no problem. Now i come back a year later and wanted to get achievements and the game is unplayable for me. I could leave Amithatys alone, but after 5 hours of playing, random battles against 5 Looters create the same issue (was in aserai territory). The only difference, i can fight for 2min then the game crashes, so in this case its not crashing while loading, its crashing in battle after a short time. At that point, the game gets unplayable. Even if i start a new game and run directly to Amitatys (no tutorial) its crashing in the same way. So for me its not a GPU issue, its in the game. There are so many threads with the same issue, but most of them have no answers, only more people who have the same issue, but no solution.

Can anybody who has nearly the same specs help me? Maybe there is a not so obvious solution? Is there maybe a more stable version than v1.1.6.26219? I gets really annoying, I didnt expect this after a full release. 3rd Day of my vacation and this game forces me to start again from scratch, where are the days when games actually worked, when they are released :smile: Maybe I am just unlucky.

Sorry Im no PC guy and its very frustrationg spending 3 Days of my free time, reinstalling drivers and what not, just to find out that after 5 hours the game is unplayable again.

How to Reproduce: Enter Amitatys on foot
Have you used cheats and if so which: No
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10 Pro
GPU: AMD Radeon RX 5700 XT
GPU Driver Version: 23.Q3.1
CPU: AMD Ryzen 7 3700X 8-Core
RAM: 16 GB
Motherboard: B450 TOMAHAWK MAX
Storage Device (HDD/SSD): SSD
I had similar issues, eventually had to upgrade my GPU with 24G mem. This work-around bypassed my issue.

For you, I suggest trying Beta 1.2, it seems more stable now than the old release version.
I will try that, thank you! Weird error, I mean I know nothing about that stuff, but why is my card only affected in amitatys? I can run around other towns no problem (didnt check all of them). Cant remember anything special about that town that is so different from other towns. Seems very specific.
To help you further and continue our investigation of the reported issue, we need the crash report identifier. You should see a pop-up window when the game is crashed. Please follow the instructions there to complete the upload and get the crash report identifier. It will be copied to your clipboard automatically. You can find more info about the crash report identifier here. Have you tried the workarounds for common crashes detailed here? Thanks for reporting and sorry for any inconvenience!
Hi Marda,

here is my crash report identifier:2023-12-06_11.09.14_a3c1bc4b920f1b9e9451d9e1140280c8.

Thank you for looking into it! Upgrading to Beta 1.2 didint help, game still crashes when trying to enter amitatys (on loading screen).

I tried ervery solution in the forum i could find, nothing helped and nothing changed.

Updated Drivers, checked files, clean driver and game install, upped my vram like the forum says, upped texture budget, put everything on low, closed Anti Virus, tried Beta 1.2, tried to put shadows off and everything else, game still doesnt want me to be in amitatys :smile:
Top Bottom