Castle Gates

Currently viewing this thread:

hastycakes

Recruit
Hey there,

I am trying to create a castle gate and it keeps saying "There must be one enity with wait position tag under castle gate". I have an npc_wait entity down in front of the gate but it just won't work. Any suggestions will help. Thanks!
 

prefrontal

Recruit
The naming of the prefabs is very bad. it doesn't correspond to their tags and you can't search for tags in the mod tools as far as i could tell. You can add an empty entity and just put the tag on it, though. Just look at it in the inspector, the last drop down menu is called tags. You can just add a wait_pos tag to it and save it as wait_pos prefab to your mod so you have it handy.
 

hastycakes

Recruit
I appreciate the response. I gave that a try but it is still happening. I think it might have something to do with my navmesh maybe
 

hastycakes

Recruit
I did not but I just did and the error disappeared. Thanks! I had a feeling that it had to be under it in that context i just couldn't figure it out until you said child entity! Next mission is to figure out why i can't use battania_gatehause_door_closed. I'm doing a Battle of Alesia scene, hoping to make a video of it. Thanks for your help!
 

prefrontal

Recruit
I'm sorry. It's very hit or miss with the modding tools right now. There is so much cool stuff that could be done but as it is now it is very frustrating. Anyway, let me know if you get anywhere or if you figure it out just write the important steps down somewhere public so whenever someone else runs into the same problem they can get a google hit.
 
Top Bottom