Need More Info Cannot Launch Game

Users who are viewing this thread

Version number
1.0.0
Branch
Main
Modded/unmodded
No, I didn't use any mods.

manatauro

Recruit
Summary:
Like the title says, I can't launch the game. It's weird because a while ago I tried to play the game and the instability turned me off. And since the game was still getting regular updates, modding wasn't an option since everything broke way too easily.

A few months ago I tried playing again, but I couldn't get past the launcher.

Now with the full release of the game, it's still the same. The launcher comes up and I press play, but the game doesn't launch at all. I actually struggle to close it as well, forcing me to restart the computer.

I meet the computer specs, I've tried turning off my firewall, I tried updating drivers, I've tried running as admin, and nothing. Any help?

How to Reproduce: Try to play the game
Have you used cheats and if so which: No, I can't even play the game
Scene Name (if related):
Media (Screenshots & Video):
Computer Specs:
OS: Windows 11
GPU: Nvidea GeForce GTX 1650 Ti
GPU Driver Version: 522.25
CPU: AMD Ryzen 5 4600H with Radeon Graphics 3.00 GHz
RAM:16.0 GB
Motherboard:
Storage Device (HDD/SSD):
 

Rackie

Veteran
WF&S
Completely uninstall the game, and delete bannerlord folder existing in documents. Then install it again. Also remove 3rd party launchers if you have those, such as Vortex (nexus mod loader)

also make sure updated drivers (especially for gpu)

another common thing causing trouble are anti viruses. If you have any anti virus enabled, try disabling it. If that helps, you can then try to enable it and make an exception for this app.
 
Top Bottom