Resolved Whenever I host a custom server, it closes after 20 seconds

Users who are viewing this thread

Version number
I was trying for several hours to get a Captain server going yesterday (whenever the warmup phase ended, me and the other guy just entered spectator mode and couldn't choose loadout), and now I can no longer host. Whenever I try to host a server either through the .bat file or through Steam' "Mount & Blade II: Dedicated Server" it just closes after 20 seconds. What is the cause of this?

When I go to multiplayer and custom server list, I still see 4 servers which I tried to host earlier are still listed. I am not hosting these still (I've restarted the pc and reinstalled the dedicated server tool on Stean), and when one try to join them, it just says "Please wait.." until it says I can't connect. Is this why I can't host? Because Taleworlds think I am already hosting?

-Edit 2-
Trying to join those servers and waiting until the game says you couldn't join them seems to remove those servers from the list. Will see if I can host once I've removed them all.

-Edit 3-
Yup. Joining those servers and thus removing them fixed this problem for me.
Last edited:


Community Support
Community Support
Hey, the default number of servers your can host is 5 servers per token. I think the problem was caused by this limit. I am glad the problem is solved, though. You can reach out to us about increasing the limit of your token.
Top Bottom