Resolved Connection with server timed out for dedicated server

Users who are viewing this thread

Version number
I guess I posted it in the wrong place the first time, but here I am again, desperate for someone, especially someone from TaleWorlds to tell me what is wrong with my server after I have seemingly done everything right.

I am using a bare metal dedicated server from OVHCloud with Linux 22.04 LTS and I have been trying for literal weeks to get this thing to work. Before using OVHCloud, I also tried hostinger and my own old windows laptop--both could display the server in the server list but had the same issue of connection with server timed out.

I have a static public IPv4 and I have opened the ports 7210/UDP and 7210/TCP (though people say it is not necessary because the IP is already public; I have tried with and without opening the ports and it does not make a difference). I have also tried using a /Port argument to try another port which the server provider (it works somehow, I have used it, but it has low specs). I have downloaded wine 8.0.2, and am using RDP xrdp Xfce4 (not that it matters). I have transferred the Mount & Blade II Dedicated Server by copying it over through onedrive, and I have also done it by downloading the Dedicated Server tool through steamcmd (it makes no difference, but as you will see, I ran out of ideas for what could be the point of failure).

I have tried multiple variations for startup, which have all worked in starting the server and displaying it in the server list. Here is what I have been using recently, and some variations:
cd ~/Documents/STEAMAPPS/bin/Win64_Shipping_Server (STEAMAPPS is where I installed the dedicated server files with steamcmd)
wine DedicatedCustomServer.Starter.exe /DisableErrorReporting /dedicatedcustomserverconfigfile ds_config_sample_sergeant.txt /dedicatedcustomserverauthtoken {mytoken} (I have tried as {mytoken} two very recently gotten tokens from my two different steam account which both own bannerlord)

Variations: I have tried it without the arg /DisableErrorReporting, I have tried with _MODULES_*Native*Multiplayer*_MODULES_ at the very end, I have tried adding a different port like /Port 5019 at the end and opening that port udp+tcp as well. I have tried winecmd first, then cd and execute like on windows.

I have also tried adding a MultiplayerForcedAvatars directory to Modules/Native, as suggested @6:35 in this video .

I have contacted Cerwin (dev) on discord, and he has shown me this screenshot, which supposedly shows the master server seeing my IP as (image link because you don't let me upload a simple file). I interpreted this as my external public IP not being accessible or something, but that is really quite unlikely after I have opened all ports and am using a dedicated server anyways. I have also checked which ports are listening (left=while server is running, right=server is not running). IIRC, 7210 UDP is the critical port, while TCP is used for the dedicated custom server helper panel that you access through browser (I could not access it, but it is not my priority atm). So, to my understanding, the output meant that 7210 UDP is able to listen from all IPs?

I should mention what it says in the console when I (or any other player) try to connect to the server. Nothing!! It gives me no clues and no hints as to why I am disconnected. It just says:
```[19:55:32.845] Player [DofA] David Hilbert - with IP address {my home IP} wants to join the game
[19:55:32.856] >>> AddNewPlayerOnServer: [DofA] David Hilbert index: 0
[19:55:32.856] > AddNetworkPeer: [DofA] David Hilbert```
and then, a little while later: ```> RemoveNetworkPeer: [DofA] David Hilbert```
The text between those is just the normal repetitive server text.

And then I get disconnected.

Here is my config (it is still called ds_config_sample_sergeant.txt, but I have edited as follow):
```ServerName David Hilbert Testing once again
GameType Captain
add_map_to_automated_battle_pool mp_sergeant_map_007
add_map_to_automated_battle_pool mp_sergeant_map_008
add_map_to_automated_battle_pool mp_sergeant_map_009
add_map_to_automated_battle_pool mp_sergeant_map_011
CultureTeam1 battania
CultureTeam2 empire
RespawnPeriodTeam1 3
RespawnPeriodTeam2 3
RoundPreparationTimeLimit 25
MaxNumberOfPlayers 15
AllowPollsToKickPlayers True
FriendlyFireDamageMeleeFriendPercent 75
FriendlyFireDamageRangedFriendPercent 75
MinNumberOfPlayersForMatchStart 2
RoundTotal 5
Map mp_sergeant_map_008
RoundTimeLimit 700
WarmupTimeLimit 2
AutoTeamBalanceThreshold 1
NumberOfBotsPerFormation 55
SingleSpawn true
set_automated_battle_count -1
AdminPassword password1234```

I have really tried everything here. I have followed all instructions and then tried other variations. I have spent so many hours trying to get this to work. I have already asked a lot in the discord, but I think I have to go to the devs with this one because nobody that has tried to help me so far has any ideas left. If you need any more information, just ask.

Edit: I also just saw this thread, but that is not the problem because my external IP address is able to be recognized by the internet as you can see
Hey, i have been informed that turning off the ipv6 in windows settings on the pc thats hosting the custom server has helped with some of the users experiencing this issue. Can you please try that and let me know if the issue is persistent?
Hey, i am glad the issue is fixed. Please let us know if you encounter any other issues.
Top Bottom