RGL Error : Unable to lock vertex buffer. Possible ways for fix error.

Knight0815

Sergeant at Arms
Best answers
0
i have also a question and didnt found an answer of it.
will warband be more stable and will the vortex problem be solved? or is this  a real hardcoded problen in the game engine?
 

Splintert

Count
M&BWB
Best answers
0
i get this problem even on dx7.. thats pretty sad... my old integrated card never had any problems like this.. dont tell me i have to switch back just to play a battle...

Intel Core 2 6300 @ 1.87 GHz
2 GB RAM
ATI Radeon HD 4350
  Resolution 1152 x 864
  512MB DDR2 video memory
  Core Clock 600MHz
  Memory Clock 400MHz
 

Alyce

Recruit
Best answers
0
I started getting this issue after installing Swords of Damocles 4.5 Gold Beta.
Before it was never happening.
Since this mod is compleatly amazing in my eyes, i cant even allow me to consider going back to vanilla M&B


So, to get crunching:

My Specs are:
Windows 7 Home 64-bit
4gb Ram
AMD Athlon II x2 215 ~ 2.70Ghz (Clocked to 3.1Ghz)
ATI Radeon HD 4800 Series 1gb DDR5

Anyhow, i spent alot of time trying to figure out whats happening. But for me, the biggest leecher seems to me to be the map. It's spinning camera around here fast that is my main issue. I keep my camera focused and away from main map towards closest edge this RLG error occour much more rarely.

Battles: Nothing really helps here, this error comes from start to near end, it's quite random:
Fixes Tested: Change Ragdolls, Battle Seize, Corpses, Various Visual Options. Nothing has the slightest impact.

Map: Crashes mainly occour when swing view around and when a large portion of the land is visible.
Fixes Tested: Not much to test but various options in visual settings. Nothing is a sollution

Saving: Often crashes game, especially after swing map view around, or after large battles.
Fixes Tested: Not Save game and hope for the best?  :roll:

So, after testing various sollutions posted here none has had the slightest impact on my crashes.


I have tested doing theese changes:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro l\Session Manager\Memory Management

Double click on "PagedPoolSize". Hexadecimal is listed first.
Change the "Value Data" to one of these below:
Note: You only need to enter EITHER Hexadecimal or Decimal.
They both are the same. I recomend using 256Mb should solve the problem.
Code:

Megabytes Hexadecimal Decimal
192Mb 0c000000 201326592
256Mb 10000000 268435456
384Mb 18000000 402653184



Only thing that has 100% stopped them from happening is going down to Directx 7 rendering.

I'm not a genious. If anyone could in a comprehendable way explain the diffrences, not visualwise, i see those, but in technical terms explain to me why this would have sutch a great impact on performance, i'd be thrilled since it could potentially allow me to pinpoint the problem for myself and my machine and my settings. Please if possible, in a PM. Thanx

 

Barf

Sergeant Knight at Arms
Best answers
0
Ever since installing 196.21 and warband 7.20 multiplayer my warband freezes, if I alt-tab out and in it will sometimes un-freeze
but when it doesn't I get the RGL error : unable to lock vertex buffer.

I will roll back my drivers and post results.
 

Turanien

Barf said:
Ever since installing 196.21 and warband 7.20 multiplayer my warband freezes, if I alt-tab out and in it will sometimes un-freeze
but when it doesn't I get the RGL error : unable to lock vertex buffer.

I will roll back my drivers and post results.
I would like to confirm this error.

Warband occasionally locks up and seems to 'flip' between two slight variations on the angle. It's effectively switching between two frames. Sounds from the current round can still be heard...

I have to alt&tab out and then back in to continue and unlock my game.

It seems to happen more often on the Hunt mod, so I'm not sure what's happening. It does however happen in native warband.

Tried varying drivers. Bug is only present in this version of Warband.



Update

I had a friend spectate me. When I died, his screen was flooded with red error messages. This is a screenshot of his log after the event...

 

Radix

Veteran
Best answers
0
The question is, why on the  same setup, with same battle size (200) I get the f...unny vortex error when on my old comp I had no problem??!!

my old comp was radeon 6800(but im not sure what series thatw as, im guesing) 1 gb ram, and 2.x procesor windows xp

My new comp- Gforce 8500 GT , Athlon dualcore 5000+ 2.6 GHz, 2.5 gb ram, windows 7

I'm really disapointed, what the hell is wrong...... everything is preety the same... 1.11 MB version, well graphical setup is higher than before but this is understandable and even though I played on old comp on quite high deatils anyway..... I have changed only mod... on old comp I played radiant cross and now Im playing propherycy of plendor. battle size same as on old comp, 200.

I dont know whats going on, I bought serial number and... COOL cant play properly when I have payed but I could when I didnt pay..............................

And moreover I see on forums that this problem exist from nearly one year so far and there is no path or any solution yet??? ehh I should know that if u buy game created by low prestiged company u shouldnt expect anything more than bugs, bugus,bugs and more bugs but no fixes.
 

xyth

Recruit
Best answers
0
My 8600 GTS card has the same problem.  Maybe the error is related to that series of video cards.
 

ppga

Sergeant
M&BWBVC
Best answers
0
I first started getting this error after installing the graphical enhancement textures pack 2.5 (as suggested by Nick Altman for Lords and Realms), often enough to be annoying but it largely went away turning down/off ragdolls, etc., as previously suggested.  Except for sieges, as noted.  I finally got to one siege that I could not get through without the error, uninstalled the texture pack and installed the speed and stability patch.  Went through like a charm, although I must admit that prior to installing mods (and especially the texture pack) I never got this error. 

Which is unfortunate, as I really like the texture pack.  My guess is that the texture pack adds polygons to the missiles, or enough polygons to everything else that it becomes a problem in sieges.  I re-installed the texture pack and reloaded the save with the siege that was giving me such trouble and it still kept giving me the error, so the texture pack must over-write the fixes from the stability patch, or add too many polygons elsewhere, I'm not knowledgeable enough to tell which.  Would it be possible to make them compatible, or if there is a simple way of fixing this, i.e. if I install the texture pack, could I simply copy a file or two over from the stability patch that reduces the polygons for missiles and then see if that would work for me in sieges.
 

Ewan

Banned
Best answers
0
i have RGL ERROR ( Unable to open file Common.Res\costumes_a.brf
please help me and upload it now now :grin:
 

princeofiowa

Recruit
Best answers
0
Use an laa (large address aware) application.  Before I used this, I had the same rgl errors.  After I can run Mount&Blade with rag dolls, corpses, and blood with no problems.
 

Honved

Knight
Best answers
0
For any player who gets this error, princeofiowa made a good suggestion.

There are several small utilities that can "patch" an executable file to allow it to access 3 or 4Gb of video memory instead of 2Gb.  I downloaded and ran it, selected the Mount & Blade .exe file, and in a matter of seconds it was done.  Instead of crashing every 5-15 minutes at various points with the one mod ("Unable to Lock Vertex Buffer"), I had one in-battle CTD in over 6 hours of playing time.