SP Tutorial Animation How to make animated map icons in OpenBRF

Currently Viewing (Users: 0, Guests: 1)

NPC99

Baron
M&BWBWF&SVC
Best answers
26

small problem .... an icon of lord appears next to the mill .... I have added the script of custom icons of Janycz Maybe that could be causing me something?
https://forums.taleworlds.com/index.php?threads/map-icons-pack.303947/
Janycz's script seems to assign whatever is in ":icon" to every party checked. Try changing the end of his code from:
Code:
    (try_end),
    (party_set_icon, ":party", ":icon"),
(try_end),
]},
to:
Code:
    (try_end),
        (try_begin),
           (neq, ":party", "p_windmill_1"),   
           (party_set_icon, ":party", ":icon"),
        (try_end),
(try_end),
]},
 

mauromagno

Knight at Arms
WBNW
Best answers
7
Janycz's script seems to assign whatever is in ":icon" to every party checked. Try changing the end of his code from:
Code:
    (try_end),
    (party_set_icon, ":party", ":icon"),
(try_end),
]},
to:
Code:
    (try_end),
        (try_begin),
           (neq, ":party", "p_windmill_1"),  
           (party_set_icon, ":party", ":icon"),
        (try_end),
(try_end),
]},
ok thanks i will try it once i connect from the pc ... now i am from the cell phone
 

mauromagno

Knight at Arms
WBNW
Best answers
7
After many tests, there are several things to consider:
1 I did what you told me and there were no changes
2 the instructions to put the banner_windmill says, "insert after banner_135", I have 147 banners and native 136 (which is at the end, after the map_flag_kingdom), so I put it after the 146 flag (over map_flag_kingdom_a), which is the flag of San Martin (the icon that appeared under the mill), this affects its flag.
3 I changed places map_windmill (under one of my icons above) and left banner_windmill under banner_147 but the mill appears in the air and not on the ground.
4 the instructions to put windmill_1 says, "insert before final] bracket", but the icon does not appear on the map, I moved it over spawn_points_end and there it does appear ...
I did so many tests that I don't even remember the combinations, I'll keep trying ...
 

NPC99

Baron
M&BWBWF&SVC
Best answers
26
After many tests, there are several things to consider:
1 I did what you told me and there were no changes
2 the instructions to put the banner_windmill says, "insert after banner_135", I have 147 banners and native 136 (which is at the end, after the map_flag_kingdom), so I put it after the 146 flag (over map_flag_kingdom_a), which is the flag of San Martin (the icon that appeared under the mill), this affects its flag.
3 I changed places map_windmill (under one of my icons above) and left banner_windmill under banner_147 but the mill appears in the air and not on the ground.
4 the instructions to put windmill_1 says, "insert before final] bracket", but the icon does not appear on the map, I moved it over spawn_points_end and there it does appear ...
I did so many tests that I don't even remember the combinations, I'll keep trying ...
As my suggestion didn’t help, I’m not sure what in your mod is swapping the haystack for another map icon. I hope you track it down.
 
Last edited:

mauromagno

Knight at Arms
WBNW
Best answers
7
As my suggestion didn’t help, I’m not sure what in your mod is swapping the haystack for another map icon. I hope you track it down.
I did it, I tried a copy of native and everything was fine, then I did everything again (put codes) and I realized that when I translated the page into Spanish, in the instruction to put map_windmill the numbers at the end, some points " . " I translated them into commas "," ... but putting everything as it should be, it didn't work well for me, so I had to move some things and it finally worked ...
I do not know what happens to my mod in map icons since the bandit lair is at the end of my module and it did not appear until I changed it in a higher place ... thanks anyway.
 

NPC99

Baron
M&BWBWF&SVC
Best answers
26
I did it, I tried a copy of native and everything was fine, then I did everything again (put codes) and I realized that when I translated the page into Spanish, in the instruction to put map_windmill the numbers at the end, some points " . " I translated them into commas "," ... but putting everything as it should be, it didn't work well for me, so I had to move some things and it finally worked ...
I do not know what happens to my mod in map icons since the bandit lair is at the end of my module and it did not appear until I changed it in a higher place ... thanks anyway.
(y)
 

mauromagno

Knight at Arms
WBNW
Best answers
7
Now I have another problem ...
I did all the steps as it should be, the windmill rotates smoothly in its 11 frames in openBRF but in the game (including in native) the sail rotates 1/4 soft and jumps a little space and continues another 1/4 smooth and jumps and so on....
What can be?
 

NPC99

Baron
M&BWBWF&SVC
Best answers
26
Looking nice!
Retry this step:


Next copy map_flag_kingdom_c, highlight my_final_map_windmill and from OpenBRF's edit menu select Paste timings to synch your map icon to Warband's engine.


PS it will never be as smooth as it is in OpenBRF. You can check out the working versions in my WFaS mod for comparison - the link’s in my signature.