In Progress GPU maxed out

Users who are viewing this thread

Goei

Recruit
Sorry I wasted your time ^_^' I forgot to restart in order to disable tesselation again. It is running fine now.
 

Goei

Recruit
Ok...it was not just a Tesselation problem :/

The game ran nice and smooth at 55°C until I visited the village of Saldannis. I spoke with Jemynon about a bandit hideout near their village causing problems. I accepted the quest, left the village and out of a sudden my GPU jumps to 100% usage all the time and the temperature skyrocketed.

I checked the options and everything seems normal. The right GPU was selected, no tesselation and everything like I had it before.

@Heinz Solo: I disabled the sound, but it changed nothing. I have no idea what causes it. Even two restarts didn't fix it. Maybe something in the village, the dialogue or the appearing hideout caused the problem.

Strange is, after the problem started, even just loading into the menu after a restart was maxing out my GPU. :xf-eek:

Edit: e1.0.8 didn't fix it. Creating a complete new start isn't helping either.
 
Last edited:

drallim33

Sergeant
There isn't really anything bannerlord can do about your GPU getting too hot. You have a few options though. You can try limiting the framerate to slightly less than what you normally get, so that the GPU gets a bit of rest to cool down. Or you can lower the clock speed of the GPU so that it uses less power and produces less heat. It will run slightly slower overall but be less likely to run into thermal throttling issues.

Or you could try cleaning all the dust out of it if you've never done that before, and possibly even try replacing the thermal paste under the heatsink if you are game.
 

Goei

Recruit
The GPU is fine and maintained. And the game was running fine for hours in two previous builds. The only changing aspect are the game versions. So I suspect the game and not the GPU.
 

Murat Türe

Developer
Ok...it was not just a Tesselation problem :/

The game ran nice and smooth at 55°C until I visited the village of Saldannis. I spoke with Jemynon about a bandit hideout near their village causing problems. I accepted the quest, left the village and out of a sudden my GPU jumps to 100% usage all the time and the temperature skyrocketed.

I checked the options and everything seems normal. The right GPU was selected, no tesselation and everything like I had it before.

@Heinz Solo: I disabled the sound, but it changed nothing. I have no idea what causes it. Even two restarts didn't fix it. Maybe something in the village, the dialogue or the appearing hideout caused the problem.

Strange is, after the problem started, even just loading into the menu after a restart was maxing out my GPU. :xf-eek:

Edit: e1.0.8 didn't fix it. Creating a complete new start isn't helping either.
Firstly, can you enable make the 'show_framerate' option 1 in the engine_config inside the 'Documents\Mount and Blade II Bannerlord\Configs' folder? This will show use if your GPU is trying to put out too much frames which can be fixed by either setting a frame limiter similar to your monitor's refresh rate or by just enabling 'Vsync'. Additionally, we may have some inconsistencies regarding scene performance. Do you encounter this in any other scene? Also, if the GPU driver crashed because of an issue with the game, the driver may become partially working till the next PC restart. Did you try that? Finally, we have fixed lots of the memory leaks at the lats patch, can you check whether the issue is ongoing with the last patch? Hope this will be fixed for you as fast as possible. Thanks in advance.
 
I have same issue too. But in Update 1.0.5 Game was running great in 1.0.6 problems began again. So for me best performance update is 1.0.5.So developers can check this update hope it helps. My Specs : Gtx 1050ti Ryzen 5 1600 16 GB Ram. Game uses 8~10 GB ram. Additionally Vsync doesnt works in my case and i see the wave like thing(dont remember what was that called) when i move my mouse and it doesnt limits FPS and in the latest update there are no shadows.
 

Goei

Recruit
Thanks for the reply!

I updated the game yesterday from .7 to .8 and restarted the game a few times, but that didn't help. I did not restart the PC though. Normaly if the AMD driver (version 20.2.2) crashes, the whole program turns into a transparent window and doesn't react anymore. That was not the case yesterday and I didn't think about a PC restart. But now with a fresh PC start the GPU temperature doesn't skyrocket anymore, yet the usage was 100%. The menu had 100fps and the campaign map around 86.
Setting vsync to full (was off before) and frame limiter to 90 fixed the 100% usage problem and the fps is now constant at 59,94 on the campaign map and during fights. It works now. But without changing the settings the game was running before without 100% usage. I have no idea what caused the abrupt changes.
 
Top Bottom