Unresolved Crash at the start, during or at the end of every battle (right at the killing blow of the last enemy standing)

Currently viewing this thread:

Version number
e1.5.8
Branch
Main
Modded/unmodded
Yes, I used mods.
Dump identifier (optional)
2021-04-08_08.54.43_077bdb45f3dfc181bd8ad7538e5d5046
Summary: Game randomly (inconsistently) crashes at the start, during or at the end of battles, at times - albeit rarely - at hideouts and sieges.
How to Reproduce: Engage in a battle with mainly anyone, though it seems it mostly happens when there's 150+ people on the battlefield
Have you used cheats and if so which: None, a few mods however. One being a mod that doesn't let clan members die. Though the crashes have been happening far before that.
Scene Name (if related): Any open ground/field battle can trigger it.
Media (Screenshots & Video):
Computer Specs:
OS: Windows 10 Pro - Version 20H2 - Build 19042.906
GPU: Nvidia Gefore GTX 970
GPU Driver Version: 465.89
CPU: Intel i3 2120
RAM: 8gb
Motherboard: Gigabyte H61M-DS2
Storage Device (HDD/SSD): Samsung 400A 960gb SSD
 

momo1

Regular
M&BWBWF&SNWVC
Did you always have this problem? Your CPU is below the minimum requirements needed to play this game.
What might work is setting the battlesize in the settings to the lowest. If it doesn't crash, increase it a little at a time and see how far you can push it before it crashes.
PS. You might need to restart the game to apply the battlesize setting.

EDIT: Which mods have you used and are you using?
Can you replicate this issue on a brand new save with no mods?
 
How could the game crash twice in one battle? When it crashes, the game closes.
To clarify: I attached a save file of mine to maybe help reproduce it. But to reproduce, it isn't necessarily tied to a certain fight. So what I meant was, going into a fight, crashing the first time and reloading (then going into the same fight again) might not cause a second crash during that same fight. It might happen at another fight later on, and it doesn't happen consistently.
 
Did you always have this problem? Your CPU is below the minimum requirements needed to play this game.
What might work is setting the battlesize in the settings to the lowest. If it doesn't crash, increase it a little at a time and see how far you can push it before it crashes.
PS. You might need to restart the game to apply the battlesize setting.

EDIT: Which mods have you used and are you using?
Can you replicate this issue on a brand new save with no mods?
No, before 1.5.7 I didn't have ANY crashes actually, which is quite funny because others were complaining so much about crashing, while I had literally none.

Battle size isn't the issue. I can run the game at high settings with 500 battlesize at a steady 30fps (locked). That being said, to prove my point, I have indeed tampered quite a lot with the battlesize, from the lowest to the highest. It seems very much irrelevant, what's relevant is the amount of people entering a fight.

I.E. 150vs150 could crash the game (despite playing very smoothly), 400vs 250 might not crash at all despite being choppy. Same goes for sieges, I play sieges on the highest battle size possible - since I mostly attack, and defenders are always spawned in full numbers, while attackers have to spawn gradually - and I very rarely crash in those, just did around 4 of them in succession just now actually, no crashes despite the game being laggy as hell.


Mods Im using include: Harmony, ButterLib, UIExtenderEx, Mod Configuration Menu, Detailed Character Creation, Realistic Battle Mod (All it's 3 modules plus spear tweak), Don't Die, Tournament Fair Armor, ArrowCam, RTS Camera/RTS Camera CommandSystem, Enter Castle/Town with horse, CarcassoneMenuWinter, Xoberax's Shoulder Cam, Better Exception Window (this one was added yesterday because I had really had it with all the crashes, shame it doesn't even show any messages for battles.)

As for the last question, I'd need to try, but I'd have to play at least 5-10 hours to get to a point where I can have a big enough party/join an an army and try it multiple times. Not sure if/when I'll have the time. But will update when I do.
 

Fungo

Recruit
I have the same problem. I changed the max number of troops in the setting to 1000. I have less crashes now, but they still happen.
 

momo1

Regular
M&BWBWF&SNWVC
By people, you mean parties or troops? Because the Battlesize setting refers to how many troops can be on the battlefield at once.
 
By people, you mean parties or troops? Because the Battlesize setting refers to how many troops can be on the battlefield at once.
As in, the total amount of troops in a fight. Could be a single party, could be multiple. And it still has nothing to do with the battlesize, the best measure to take is the screen you get when you engage a party when you have a Your Side vs Enemy Side on the top of the screen with the total number of troops on each side.

PS: The game almost never crashes against looters, regardless of numbers.
 

momo1

Regular
M&BWBWF&SNWVC
As in, the total amount of troops in a fight. Could be a single party, could be multiple. And it still has nothing to do with the battlesize, the best measure to take is the screen you get when you engage a party when you have a Your Side vs Enemy Side on the top of the screen with the total number of troops on each side.

PS: The game almost never crashes against looters, regardless of numbers.
I'm no expert, but maybe it doesn't crash by looters because the Ai doesn't control them. They just charge.
Maybe try a few battles without giving any orders except Charge.
 
I'm no expert, but maybe it doesn't crash by looters because the Ai doesn't control them. They just charge.
Maybe try a few battles without giving any orders except Charge.
Come to think of it, it could be on the enemy side in this case. In the battle I made this thread for, the game instantly crashed before I gave any orders, but it could have been the AI lord. I also thought it may have been the horses, I have read that one of the mods I'm using had a previous issue (fixed on the version I'm using) with horses, but in this case, it cant have been the AI lord's because he only had footmen in this fight, so maybe my horses?

That would also explain why it almost never crashes in sieges, there are no horses except the one I spawn in on. But that still would be weird, as that horse bug was announced as fixed and I updated the mod before starting this playthrough.

Edit: Apparently e.1.5.9 is out, will update to that in a few days and start a new playthrough, will see how it goes.
 

momo1

Regular
M&BWBWF&SNWVC
Come to think of it, it could be on the enemy side in this case. In the battle I made this thread for, the game instantly crashed before I gave any orders, but it could have been the AI lord. I also thought it may have been the horses, I have read that one of the mods I'm using had a previous issue (fixed on the version I'm using) with horses, but in this case, it cant have been the AI lord's because he only had footmen in this fight, so maybe my horses?

That would also explain why it almost never crashes in sieges, there are no horses except the one I spawn in on. But that still would be weird, as that horse bug was announced as fixed and I updated the mod before this starting this playthrough.
It could be the horses, however by sieges, there is very little for the Ai to do by both sides which could also explain why it rarely crashes then.
PS. Check your Conversations.
 

Fungo

Recruit
I lowered particle detail and quality and also ragdolls. So far I have not crashed, and I run with max units.

So far so good. The game seems to run smooth now.
 
Last edited:
Top Bottom