In Progress This application faced a problem

Users who are viewing this thread

Version number
No, I didn't use any mods.
Dump identifier (optional)


Summary: Hi.
Each time I play, after some time (sometimes after one minute, sometimes after 10 or more) I get an error that kicks me out of the game. It's unplayable.
I tried custom battles, campaign, multiple sceneries and the result is the same. I either get d3d error or "this application faced a problem" and the game shuts down.
Running on safe mode didn't help. I tried different video settings(lowest, highest) using nvidia optimizing and without, guide about removing shaders folder, reinstalling, veryfying files.
Nothing helped.
The dump identifier comes from beta
How to Reproduce: any moment during the game
Have you used cheats and if so which: No
Scene Name (if related): any
Media (Screenshots & Video):
Computer Specs:
OS: windows 11 pro
GPU: Asus GeForce RTX 4070 Ti TUF-RTX 4070 Ti-12G
GPU Driver Version: 546.11 (newest)
CPU: 13th Gen Intel(R) Core(TM) i5-13600k
RAM: Corsair DDR5 Vengeance RGB 2x16GB 6000
Motherboard: MSI B760 Gaming Plus Wifi (MS-7D9:cool:
Storage Device (HDD/SSD): WD Black SN850X NVMe PCIe M.2 2TB
Hi again,

FYI, when I removed the "bin" folder from C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
and then veryfied the files via steam, I was able to play on ultra without issues, however the moment I closed the game and then tried to play again, the same crashing started. For now I can follow these steps each time and it works but still looking forward for permanent fix.
Hope this gives you some guidance.
Top Bottom