Need More Info Game crashes when entering the Smithy

Users who are viewing this thread

Version number
1.1.6.26219
Branch
Main
Modded/unmodded
No, I didn't use any mods.

Stg

Recruit
Summary: Doesn't happen every time, but happens frequently enough I have to manually save before entering the Smithy now. When entering, if the background is completely black and nothing else loads other than empty boxes, it'll crash.
How to Reproduce: Isn't consistent to where I can replicate it other than just going in and out of the Smithy.
Have you used cheats and if so which: Negative
Scene Name (if related):
Media (Screenshots & Video):
T19H3ee.jpg

Computer Specs:
OS: Windows 11 Pro
GPU: Nvidia RTX 3090 ti
GPU Driver Version: 537.42 (This crashing has spanned several driver updates)
CPU: Intel i9-13900KF @ 5.5GHz
RAM: 32GB G.Skill TridentZ5 DDR5 @ 4800
Motherboard: ROG Strix Z790-E Gaming Wifi
Storage Device (HDD/SSD): Samsung 970 EVO Plus 2TB NVMe.

The error code is: d3d_device_context_->Map at rglGPU_device::lock_texture failed! The GPU device instance has been suspended. Use GetDeviceRemovedReason to determine the appropriate action.

I've looked up this error code as well as searched for other people experiencing this same crashing and tried a few of the suggestions listed but nothing is working.
 
This crash is a GPU crash. Which is different from the other crashes that can be caused by gameplay actions. While we are still investigating the issue there is not a definite fix that we can offer to support this issue at the moment. You can try the workaround below but please note that it is not a solid fix. Thanks for reporting. Sorry for any inconvenience.
A possible fix for RGLGPU_DEVICE::LOCK_TEXTURE Crash
If you are crashing in the middle of the game with the “RGLGPU_DEVICE::LOCK_TEXTURE” error, you can try the workaround below to fix it:
Expanding the swap size on your hard disk. You can find more info regarding this here.
 
This bug has been around for years, it seems to relate to old shaders. You need to get into all directories where shaders are stored. delete them and reinstall the game, and reverify.

From memory there is 3 directories where shaders are cached ? Search bug reports for shader problems.
 
Rather than make a new topic, I'll just reply here. I'm playing on the newest patch and tried both of the above-mentioned issues, and now my game crashes every single time I enter a Smithy. If I start a new campaign, I can enter without issues, but about halfway through a campaign it'll start crashing more and more frequently until it gets to this point where I can't even craft anything.

How has this not been fixed?
 
Back
Top Bottom