1. Unresolved Problems with game deactivation

    I'd like to ask how to deactivate Mount & Blade Fire and Sword? Currently it's activated on two PCs: PC1: After Windows software update the game found new system configuration and used another key to activate itself (2 out of 3 activations are in use). PC2: Recently I've upgraded my hardware (I...
  2. Another key problem

    I have bought the game on steam a couple of years ago and played it with no problem. Trying to get back into it again but it won't let me do manual or automatic activation. Even though my key is correct and the game is allowed through the firewall. I even turned off my firewall entirely and it...
  3. Need More Info Unable to connect to activation server

    Hello after not playing for years,playing bannerlord decided to play warband again, and with a warsword mod.And when i tried to launch the game from WSE it asked for the activation code(like it always does that).And when i tried to enter it it keeps saying ' unable to connect to activation...
  4. Resolved Issue with manual activation of m&b v1.174 is not working. This website is required for activation of the Mount and Blade warband v1.174 manually. I request taleworlds or member friends to suggest for solving the issue.
  5. Meaning481

    Resolved New 1.5.0 bow perks not turned on?

    Hello, The patch notes do not specify whether the new bow tree has been activated. In testing the "dead aim" perk. The 30% increase in headshot damage does not seem to be applied. Can we get clarification on the status of these new perks on the forums or the next hotfix please?
  6. senatauro

    Cant activate the game

    I have the game outside steam, but I can't activate the game with the serial and the site for manual activation is not working. Can someone help me with this problem?
  7. In Progress Game activation problems.

    My friend has recently gifted me a Steam version of WFAS. I downloaded it, played for a little bit, and then the game requested a serial key. It was supplied by Steam, but regular and manual activation don't work. There lies my question - is there any solution to this problem?
Top Bottom