Resolved Windows 10 Map Stutters/Freezes when I move the mouse - but not right away.

Users who are viewing this thread

N0ught

Sergeant Knight at Arms
M&BWB
Hey so, N0ught here - creator of the beloved Solid and Shade mod. I recently got a new computer with Windows 10, and it runs M&B great, mostly - combat is amazing, with the occasional crashes, but that is to be expected - I don't have LODs for most my models in my mod; guilty.

The thing that is bothering me is the map, and the mouse pointer. I am having the same issue in Native and in my Mod - at first, everything runs smoothly on the map - the mouse does not flicker, the map does not stutter.

However, within a short period of time, after having entered scenes or combat, visited menus, etc., the map starts to stutter/freeze with every little mouse pointer movement, and the mouse flickers. It's as if the game can only render the map OR the mouse at the same time, but not both, after running for a little while.

Now here's the kicker: even if I quit the game and reload, it will do the same thing, until I restart my computer.

I have tried every compatibility mode, and no compatibility mode, run as administrator - same results. This is with Mount & Blade 1.011 from the Taleworlds site, and others have had the same issue with the Steam version - I did not think it was a major issue until I upgraded to my new computer here, and experienced it myself.

So... what could be causing this? Is the game breaking D3D? Is there a workaround or a fix for this issue?

Edit: Also tends to CTD when alt+tabbing, and the mouse flickering persists during pause menu.

Could this be related to my monitor's refresh rate? (144.104hz)
 
Last edited:

N0ught

Sergeant Knight at Arms
M&BWB
I am not sure which of these three things solved the problem with the map and menus stuttering/freezing when you move the mouse, and the mouse pointer flickering, in windows 10, but it might work for Warband too:
* I just installed the most recent game-ready driver from Nvidia.
* I set the compatibility mode on the .exe to Windows 8.
* I set the max framerate to my exact refresh rate (144 in my case).
... No more stutters or flickering! Runs perfect, and I can alt+tab without crashing. :smile:
 
Hilariously, I installed M&B again specifically to play the new S&S release. :twisted:

Compatibility mode and max frame rate didn't do anything, but updating the Nvidia driver fixed it.
 
Top Bottom