What version of Mount and Blade to play Brytenwalda?

Currently Viewing (Users: 0, Guests: 1)

Maxwell Hall

Regular
Best answers
0
When I launch Mount and Blade, it says I have version 1.172. When I'm in the game, in the menu, it says I have Brytenwalda. I can update to the latest version of Mount and Blade 1.174, or try to find an older version.

I wish to play the original Brytenwalda. On that page, it says Brytenwalda for 1.153. A developer says on the forum that it's compatabile with 1.158. Is it compatbile with later versions as well?

Which is the best version to play original, non-reworked, non-repolished Brytenwalda?
 

Redleg

Sergeant Knight at Arms
Best answers
0
Maxwell Hall said:
When I launch Mount and Blade, it says I have version 1.172. When I'm in the game, in the menu, it says I have Brytenwalda. I can update to the latest version of Mount and Blade 1.174, or try to find an older version.

I wish to play the original Brytenwalda. On that page, it says Brytenwalda for 1.153. A developer says on the forum that it's compatabile with 1.158. Is it compatbile with later versions as well?

Which is the best version to play original, non-reworked, non-repolished Brytenwalda?
It should be compatible with all versions after 1.153.