[WB] Warband Script Enhancer v4.8.4 for 1.174

Users who are viewing this thread

K700

Sergeant Knight
WB
v4.7.9
-Fixed buggy face_keys_get_morph_key, face_keys_set_morph_key operations - supports all morph keys, not only first 8.
-Fixed fst operation - supports big int.
-Removed currently unnecessary allow_wse_execute_statement_blocks module.ini option.
 

K700

Sergeant Knight
WB
v4.8.0
-Added some Carribean operations - set_random_seed, store_application_time, is_party_skill, agent_get_horse_rotation_velocity, agent_get_current_vertical_speed, agent_set_current_vertical_speed, prop_instance_remove_particle_system, prop_instance_remove_light, cur_item_mesh_set_color, cur_item_add_mesh_with_material, party_switch_stacks, position_get_length, get_dot_product_of_positions, get_cross_product_of_positions, str_store_skill_desc, overlay_button_set_type, overlay_get_scroll_pos, overlay_set_scroll_pos.
-Extended add_point_light and add_point_light_to_entity operations - range parameter.
-Operations that are performed in lua now get context (trigger).
-Fixed particle_system_remove operation.


Thanks to the development sponsor who wished to remain anonymous.
 

horns

Regular
M&BWB
Yo K700, I am seeing the following error when running WSE 4.8.0 on the latest client files:

Co6lA0u.png


I went as far as deleting my current files through the file explorer and reinstalling, but no dice. I am assuming it is some change to the executeable and the checksum is just unhappy. Is there any way I could override this checksum?

The server exe works just fine, but not super happy with the Steam or downloaded client files
 
Last edited:

horns

Regular
M&BWB
Ah, it seems you provide the executables in your post for this reason, my bad. Got it working.
 

horns

Regular
M&BWB
Hello again,

I think there might be a bug with agent_set_current_vertical_speed and agent_get_current_vertical_speed when paired with accelerate_agent.

agent_set_current_vertical_speed:
Seems to apply force in the direction the agent is facing and not up.

agent_get_current_vertical_speed:
Always reports 0 if I apply an upward force for a few frames and fall back down. If I run and jump off a building, behaves as expected

Let me know if you need help reproducing.

*Edited to reflect new findings

Added note, agent_get_speed seems to be behaving the same way. Accelerate agent does not change it's value, only pressing movement keys
 
Last edited:

K700

Sergeant Knight
WB
Hi.
These operations directly work with speed vector, do not interfere with logic of engine.
 

danand

Sergeant
WBNWVC
Can anyone help me with this issue?


Info
Time: 10/05/2021 21:23:19
Type: EXCEPTION_ACCESS_VIOLATION (0xC0000005, 0x00000000, 0x00000014)
Stack trace
0x00444DFD mb_warband_dedicated.exe+0x44DFD (??+0x0)
0x0044502B mb_warband_dedicated.exe+0x4502B (??+0x0)
0x740E1300 mswsock.dll+0x11300 (Tcpip4_WSHSetSocketInformation+0x40EB)
0x740DEA45 mswsock.dll+0xEA45 (Tcpip4_WSHSetSocketInformation+0x1830)
0x749E4FB1 WS2_32.dll+0x14FB1 (WSAAccept+0x8C) 0x749F3F50 WS2_32.dll+0x23F50 (WEP+0xB5D9)
0x749E4F1C WS2_32.dll+0x14F1C (accept+0x17)
0x00444EF6 mb_warband_dedicated.exe+0x44EF6 (??+0x0)
0x004FE9BC mb_warband_dedicated.exe+0xFE9BC (??+0x0)
0x7561919F KERNEL32.DLL+0x1919F (BaseThreadInitThunk+0xE)
0x76FCA8CB ntdll.dll+0x4A8CB (RtlInitializeExceptionChain+0x84)
0x76FCA8A1 ntdll.dll+0x4A8A1 (RtlInitializeExceptionChain+0x5A)
0x76FCA8A1 ntdll.dll+0x4A8A1 (RtlInitializeExceptionChain+0x5A)
 

K700

Sergeant Knight
WB
Can anyone help me with this issue?


Info
Time: 10/05/2021 21:23:19
Type: EXCEPTION_ACCESS_VIOLATION (0xC0000005, 0x00000000, 0x00000014)
Stack trace
0x00444DFD mb_warband_dedicated.exe+0x44DFD (??+0x0)
0x0044502B mb_warband_dedicated.exe+0x4502B (??+0x0)
0x740E1300 mswsock.dll+0x11300 (Tcpip4_WSHSetSocketInformation+0x40EB)
0x740DEA45 mswsock.dll+0xEA45 (Tcpip4_WSHSetSocketInformation+0x1830)
0x749E4FB1 WS2_32.dll+0x14FB1 (WSAAccept+0x8C) 0x749F3F50 WS2_32.dll+0x23F50 (WEP+0xB5D9)
0x749E4F1C WS2_32.dll+0x14F1C (accept+0x17)
0x00444EF6 mb_warband_dedicated.exe+0x44EF6 (??+0x0)
0x004FE9BC mb_warband_dedicated.exe+0xFE9BC (??+0x0)
0x7561919F KERNEL32.DLL+0x1919F (BaseThreadInitThunk+0xE)
0x76FCA8CB ntdll.dll+0x4A8CB (RtlInitializeExceptionChain+0x84)
0x76FCA8A1 ntdll.dll+0x4A8A1 (RtlInitializeExceptionChain+0x5A)
0x76FCA8A1 ntdll.dll+0x4A8A1 (RtlInitializeExceptionChain+0x5A)
try wse2, if the crashes continue, there will be more useful information about it
 

K700

Sergeant Knight
WB
(str_store_string, s1, "@string1"),
(str_store_string, s2, "@string2"),
(str_store_string, s3, "@string3"),
(str_store_join, s0, s1, 3, "@, "),

result s0
string1, string2, string3
 

Eärendil Ardamírë

Subforum Moderator
WBWF&SM&B
Afaik the water level entry at scenes is not having any visual effects (one needs to use a 2d plain to represent the water) but tells the engine at which level it should slow down the players movement and create the extra splash effects.
 
Top Bottom