[WB][S][TC]EmpireIV Ver. 1.0 [WSE for EmpireIII 64 bit OS required]

Users who are viewing this thread

Not open for further replies.
Some screenshots of Frij, my Blue man.  Here he is headed into town in his everyday garb:

Here with his favorite weapons:

Two of his favorite steeds:

And full battle armor on his favorite mount:

A couple of screenshots of my orc, Phydeau:

Managed to get it installed. The map is a lot smoother then it was. Still a bit of lag, but nothing too detrimental. Finally I can try this out.
yea there are less lag and thats good.

Any idea where i get magic gear?

also encoutered some turnament bugs.

I have companion Cathrine, and if i go mode 4 teams 1 each, then my opponents are all cathrine at first round.
I also cant chech my companions out .
cant change turnament rules like chooce weapons to play or disable mounts.
I've been playing around with summonings.  So far I have found that i can take out small tribes of bandits using only summoned creatures, keeping my permanent troops back with me out of the action.  I've been able to take out parties numbering in the twenties with no problem.  I like that the summoned creatures stay around for awhile so you can use them in multiple battles, if they are not too far apart. 

The Magic Sword is awesome!  I am still learning how to use it, however.  Once I accidentally swung it in the middle of my party, and took out several of our mounts, including my own.

Has anyone done anything with any other magic items, like teleport, levitate, banish, etc.?  The only one I have tried so far is levitate, and nothing seemed to happen.  Maybe I just don't know how to use it properly.
I have found that my Blue Man cannot walk up the stairs in the Bordello; I have seen this in every Swadian town I have been in so far.  I have not yet been in any other towns.  He can climb the stairs by jumping, but not walking.  He CAN walk up stairs in the taverns with no problem. Maybe his legs are just too short  :lol:
Great pix!

Here's my blue man about 5 weeks into the game; he's a wizard/warrior who owns several warehouses with lots of caravans.  He has a party of about 80, with 3 healers who started out as novice nurses and then he adopted as heroes, a forager, and a trainer.  He still wants to hire an engineer.

A couple of thoughts about summoned creatures:  I found skeletons and zombies useful as a beginning character against small groups of bandits, but only being able to summon 2 at a time shortly became not that useful.  Looking at the larger summoned characters, or those which can be summoned in groups of any size, requires such a high power throw that a character would need an incredibly high strength to be able to use them at all.  These are just a couple of observations; I do not claim to have any understanding of the game balance that is being sought for magical use.
I found that when I purchased a ship in the village of Buillin, near Chalbek Castle, just NW of Tihr, that I cannot set sail.  Instead I get this message:  "you don't own a ship or your your crew exceeds its boundries" (exact wording).  I tried different party sizes, down to a party of 20, but still got the same message.  If I dock the ship at the port when I leave, I have the same problem, but if I "leave the ship here" I can come back to it on the travel map and set sail.  I went to the nearby village of Locogam (after restarting the game from a save before I purchased a ship), purchased a ship at Locogam, and set sail with no problem, even with a party of 281.
Here's a picture of my blue man wearing a Hobgob Helm I found in the loot from a battle: 

It does make sense, however, that it would not fit, since a hobgob is so much larger... :lol:

I also found that the battle scene at Juter Castle seemed to have a lot of stutter, and would freeze up completely if I fired my Fire Thrower.  It seemed to work "OK" (just with jerky movement) if I attacked conventionally with troops only.  There were a large number of defenders in the castle, so maybe that was the cause of the stutter.

EDIT:  I wonder if the freezing problem is related to the dwarf hit boxes issue. I encountered a bandit group of dwarven crossbowmen and my party was unable to injure them, so I fired my Fire Thrower and the game locked up, just like at Juter Castle.

Met a Nord Trained Footman in a bordello; when I talked to him (to recruit), this was his response:

I think I met a group of these same NPC's while traveling and got the same response when I talked to them (I know I've seen the same response before, but I'm not 100% sure it was the same type of NPC I spoke to).

Got the "you don't own a ship ..." message at Nanj, a Dwarven town on the smaller island.  Everything else I checked seemed ok.  I was unable to check the Black Kergit and the Necro ports, since I was at war with them.

Found this Prison Guard in Timuda; reminded me of the old joke " There is this prison in Timuda with no walls, ceilings, or floors, and yet every day prisoners escape":

Talked to this Nord Cavalry in a tavern, this was his response (by the way, I'm not sure if he is from the land of Nord or from Calvary):

An chance of getting your own forum since you are at version 1.0? It would make things a lot easier.

Downloading now, looking forward to trying this out. Thanks for all the hard work.  :cool:
10 hours in, no bugs yet and the mod is looking great.

Only thing I would change if I could would be to add some gathering areas to the expanded parts of the map and remove the small trees in that one tournament field.

UPDATE: 32 hours in, still have yet to see a bug

UPDATE: 55 hours in, no bugs to report.

UPDATE 60 hours in, no bugs yet.
Around 115 hours in, finally found a bug!

While laying siege to the town of Rasez, many were spawning on top of the roofs, only way to win was a second attack with a bunch of archers/xbowmen. There were at least 50 on top of the roofs in both battles.

UPDATE: 126 hours in and found another two bugs.

I conquered a town while one of its villages was being raided and it is "stuck" in that mode. There are 5 parties taking part in it and they have been stuck in that village for 5 days now and I cant do anything to get them out of it. going to the village brings up the normal village screen. It is the village of Ruv.

Also, the Islands to the south west. The area around Thorne/Thorne's port has caravans trying to "cross" down to the next island yet never go on the water...they just keep walking towards it. Same on the Island to the south, caravans are trying to travel to Thorne but never go on the water.

I am also noticing that my icon is not changing. I currently have 183 troops and its still just me on a horse while other parties have several horses and some foot troop as an icon.
In character creator, there is a semi-built in"cheat". You can keep getting the 2000 gold, press back and get it again. I ended up getting 38k gold lol. I started over to play legit, but I thought it was kinda funny. Thought I'd post it as a heads up to maybe get fixed in the future. Maybe remove the back button at that screen once you select what you want to start with.

Also, it works with all the items, not just the gold.
Lor Dric said:
I need feedback on magic system

I have found the summoned creatures are useful in early stages of the game, against smaller parties; however, when the battles get larger, there is no substitute for lots of hired soldiers.  However, mages summoning creatures could be awesome; I know that going against the dark mages and their summoned creatures is quite difficult.

I still have problems with the Magic Sword, like killing my own horse and soldiers when I use it against enemies. 

I hate to say this, because I simply LOVE to use it, but the staff of Fire Thrower still seems a little too powerful.  This screenshot shows the result of one blast from the staff:

Another spell I like is the healing spell.  It is useful, but does not seem to unbalance the game.

If someone has used some of the other spells like teleport, levitate, banish, etc.?  I would like to hear your results/opinions.
Not open for further replies.
Top Bottom