SP Fantasy Warsword Conquest - New Opening Post

Users who are viewing this thread

Wolas3214 said:
Another small bug report.


All of the women(short of nakwatcha) are bald.

In addition, skalds seem to think you know all of their songs(though other bards/minstrels will teach you normally)

Using the bugfix that you took down. Women had hair prior to getting it.


Edit; started a new save to test. Hair is back.

Though as i teleported around my factions castles and towns i noticed again the lack of marriable women.

Is that intentional? Do they only show up under certain conditions?

Pretty sure that marriable women only show up during tournaments in he feasts. Once you contact them and have good relations, they will summon you to see them in secret, or if you have very good relations with the father he will permit you to see her openly.
 
Wolas3214 said:
Edit; started a new save to test. Hair is back.
The bald women (and also weird looking Dwarves) was a problem in the previous version too. It happened sometimes at the very beginning and the best way to avoid it was just to check after the character creation was over. I never saw it happening during an on-going game (barring savegame corruption).
 
Here we go again

Hotfix 1 reloaded

Fixes companion dialogue issue
Fixes cyrus ward save issue

Somewhat fixes lord bandit quest issue (it often works but sometimes it fails like before so I recommend saving before asking a lord for a quest until I have figured out the last variable)

Vampire starts with items
Fixed some broken scenes and arenas (but not all arenas, I recommend keeping cheats on so you can auto kill tournament combatents who spawn in dodgy locations)

Fixed village elder bug
Many small troop stat and equipment fixes
Wood elf walker fixed

I have made these fixes but I have not been able to test them due to being away with only my laptop. Hopefully they work as intended:

Mounts do not get the same combat skill bonus as their rider

You now get relation penalty for attacking kingdom patrols

Defections no longer occur


Gsanders/Phosphor has also been at ful throttle making changes:

Wages reduced slightly for mercenaries
Slightly higher average pay for prisoners when selling at barkeep
Slight increase in maximum party size calculation

Increased garrison and lord party size
Increased party prisoner limit slightly
Compassionate lords do not attack farmers or raid villages
Auto-calc bonus for high level troops
Auto-calc kills fewer high level troops
Slightly improved rewards for quests

Slightly adjusted space at normal town merchants
Companions slightly add to party morale as more companions are hired
Lowered the cost of village improvements
Slightly increased number of items for sale in town

You can no longer recruit troops for free

Smoother curve for buying and selling in bulk, which really adds up quickly


Romancing female lords, vassals, and female players marrying male lords now as in Diplomacy* (untested)

The ability to zoom in and out after toggling camera mode with the End key is restored*
mini map is removed. It still exists as a part of the backspace view orders mode, but otherwise is removed.




This hotfix is not game save compatible.

There will be another hotfix in a few days (earliest weekend) but we cannot guarantee that it will be game save compatible. Please bear this in mind if you would rather not keep restarting your game it may be worth waiting and seeing. The next hotfix will include all these fixes as well if you would rather wait.

All other issues will be addressed in later patches
 
sobora said:
2oothBrush said:
Hey, I'm new to this mod, I tried installing the newly released version earlier today however the installation process perplexed me. when i extract all the files they are all separate I put them all into a folder then put that folder into the Modules folder in the Mount&Blade: Warband File. I start the game up everything seems to be working until i try and enter the town or do certain actions like enter a tourney. I get a Runtime C++ error and my game crashes - I've only played as WoodElves am i installing the game incorrectly ?

computer spec?

i5,
gtx980
16GB
SS-250GB
HD-750GB
Windows 10 64bit

If you need anymore information ask away.
 
2oothBrush said:
sobora said:
2oothBrush said:
Hey, I'm new to this mod, I tried installing the newly released version earlier today however the installation process perplexed me. when i extract all the files they are all separate I put them all into a folder then put that folder into the Modules folder in the Mount&Blade: Warband File. I start the game up everything seems to be working until i try and enter the town or do certain actions like enter a tourney. I get a Runtime C++ error and my game crashes - I've only played as WoodElves am i installing the game incorrectly ?

computer spec?

i5,
gtx980
16GB
SS-250GB
HD-750GB
Windows 10 64bit

If you need anymore information ask away.

try lowering the texture detail to like 70 and turn load textures on demand on

warband explodes when memory usage for the game exceeds 3gig no matter how good your pc is

and this mod is huge

if it's not a memory issue then upload the crash log
 
sobora said:
2oothBrush said:
sobora said:
2oothBrush said:
Hey, I'm new to this mod, I tried installing the newly released version earlier today however the installation process perplexed me. when i extract all the files they are all separate I put them all into a folder then put that folder into the Modules folder in the Mount&Blade: Warband File. I start the game up everything seems to be working until i try and enter the town or do certain actions like enter a tourney. I get a Runtime C++ error and my game crashes - I've only played as WoodElves am i installing the game incorrectly ?

computer spec?

i5,
gtx980
16GB
SS-250GB
HD-750GB
Windows 10 64bit

If you need anymore information ask away.

try lowering the texture detail to like 70 and turn load textures on demand on

warband explodes when memory usage for the game exceeds 3gig no matter how good your pc is

and this mod is huge

if it's not a memory issue then upload the crash log

Thanks i'll try that and post to confirm or ask for more help aha. Thankyou!
 
2oothBrush said:
sobora said:
2oothBrush said:
sobora said:
2oothBrush said:
Hey, I'm new to this mod, I tried installing the newly released version earlier today however the installation process perplexed me. when i extract all the files they are all separate I put them all into a folder then put that folder into the Modules folder in the Mount&Blade: Warband File. I start the game up everything seems to be working until i try and enter the town or do certain actions like enter a tourney. I get a Runtime C++ error and my game crashes - I've only played as WoodElves am i installing the game incorrectly ?

computer spec?

i5,
gtx980
16GB
SS-250GB
HD-750GB
Windows 10 64bit

If you need anymore information ask away.

try lowering the texture detail to like 70 and turn load textures on demand on

warband explodes when memory usage for the game exceeds 3gig no matter how good your pc is

and this mod is huge

if it's not a memory issue then upload the crash log

Thanks i'll try that and post to confirm or ask for more help aha. Thankyou!
It seems to have worked very well. Thank you :grin:
 
2oothBrush said:
2oothBrush said:
sobora said:
2oothBrush said:
sobora said:
2oothBrush said:
Hey, I'm new to this mod, I tried installing the newly released version earlier today however the installation process perplexed me. when i extract all the files they are all separate I put them all into a folder then put that folder into the Modules folder in the Mount&Blade: Warband File. I start the game up everything seems to be working until i try and enter the town or do certain actions like enter a tourney. I get a Runtime C++ error and my game crashes - I've only played as WoodElves am i installing the game incorrectly ?

computer spec?

i5,
gtx980
16GB
SS-250GB
HD-750GB
Windows 10 64bit

If you need anymore information ask away.

try lowering the texture detail to like 70 and turn load textures on demand on

warband explodes when memory usage for the game exceeds 3gig no matter how good your pc is

and this mod is huge

if it's not a memory issue then upload the crash log

Thanks i'll try that and post to confirm or ask for more help aha. Thankyou!
It seems to have worked very well. Thank you :grin:


don't forget to put your warband folder on your ssd
 
[Possible bug unless intentional?]
Horses don't seem to work for Vampires on the campaign map. There's no animation/icon of it in use, nor are any speed bonuses applied.
Applies to all horses (not just skeletal horses).
 
jajelli said:
[Possible bug unless intentional?]
Horses don't seem to work for Vampires on the campaign map. There's no animation/icon of it in use, nor are any speed bonuses applied.
Applies to all horses (not just skeletal horses).

I was about to report the same thing on Vampires Mounts.

Also, Erasmus (Pit Fighter Trainer background) Hireable Hero, his model is bugged, arms don't line up and head is a bit higher then where his neck says it ought to be.

I'll rehash a lot of what everyone else has said, because you guys really deserve it.  I'm 42 and been gaming since Atari, this is the best MOD I've played for any game.  Played the hell out of the first Warsword and will play the hell out of this.  Kudos to the devs. You deserve more then the admiration you receive, oh and F the negative haters.  Keep up the good fight.
 
casterhald said:
jajelli said:
[Possible bug unless intentional?]
Horses don't seem to work for Vampires on the campaign map. There's no animation/icon of it in use, nor are any speed bonuses applied.
Applies to all horses (not just skeletal horses).

I was about to report the same thing on Vampires Mounts.

Also, Erasmus (Pit Fighter Trainer background) Hireable Hero, his model is bugged, arms don't line up and head is a bit higher then where his neck says it ought to be.

I'll rehash a lot of what everyone else has said, because you guys really deserve it.  I'm 42 and been gaming since Atari, this is the best MOD I've played for any game.  Played the hell out of the first Warsword and will play the hell out of this.  Kudos to the devs. You deserve more then the admiration you receive, oh and F the negative haters.  Keep up the good fight.

This happens because Erasmus wears an armour that is not usable by his "race" (marauder armor) and it seems he is a big tall chaos warrior, so maybe the solution for him would be to match his race with an armour that fits him. Nothing else. What I've done was to recruit him and take out his armour, and done.
 
Theres a laundry list of red text any time you open the shop

Agent_troop_get_banner_mesh

Shields with banners are also see through so im assuming its related to that
 
I just noticed in the base game with no alterations that my Khorne Knights are whack. They have 120 Strength and 165 health, and are killing trolls on the charge.

I mean I'm not complaining, it's glorious and I'm going to build a Khorne Daemonkin armor, but imba as hell.
 
Seckshun said:
Is there any way to disable shield-bash? It messes me up a lot :/

Also, every time you shield bash, it uses the female screaming sound

This is because I turned on PBOD shield bash yesterday.  For tomorrow's patch I'll turn it back off.
The female sound is made by Warband engine deciding anything above skins 0 and 1 must be female, without asking our scripts.
Anyway, noone noticed or cared there were no shield bashes automatically before (manual bashes worked), so I'll revert to that for next time.  There is a PBOD setting for shield bash as "special attacks".
 
Sometimes in Askreved´s arena NPCs spawn partially inside the ground. With only their heads and the upper part of the torso showing. It´s only a minor inconvenience as it doesn´t prevent them from moving or attacking, but they become much harder to detect (for the player) and hit (for everybody).
 
I found a few bugs (I think):
- a Forest Goblin character starts with no weapons
- with this same character the prisoner management skills gives only 3 prisoners per point but in the character window still says 5
- I found a few bald female tavern keepers.

In any case this is one of the best mods, thanks for all the great work
 
Encountered a minor bug. Got married as a Chaos Warrior, had the option to ask my wife to join my warband, did, but the dialogue gives me no options to access her skills or equipment, and instead just gives me the options for the maiden you take into your party after rescuing her from bandits.
 
Wyzilla said:
Encountered a minor bug. Got married as a Chaos Warrior, had the option to ask my wife to join my warband, did, but the dialogue gives me no options to access her skills or equipment, and instead just gives me the options for the maiden you take into your party after rescuing her from bandits.

  This will have to wait.  Moving dialogs around is very prone to errors, and something else is likely to get messed up.
  There are enough emergencies to deal with first.

  I think this is working in my submod with Diplomacy enabled, so I'll focus on that next week.  I merged all changes the last 3 days to my submod this morning, now that nameless took some pressure off me with last night's patch release.  Thus its more profitable for my time to set a pre-release test of diplomacy dialogs with wife as a companion in parallel to the mod release, rather than burn a week on rebuilding a huge dialogs file that will ultimately be replaced in a month (or less) anyway.  Diplomacy has a huge impact on dialogs.

  Today's focus remains timers and background tasks when waiting in town and speeding up time.  This is complicated enough, and useful for my submod, which has rather more time flying during crafting, guild lessons, and harvests.
 
Back
Top Bottom