Resolved Warband wont launch.

Currently viewing this thread:

Jimtrum94

Recruit
For two years now the game is not launching(was hoping for an update or something). I launch it and it just stops. I have tried everything.More people have the same problem and only with this game. Not any other steam game. Is really frustrating when you want to play and you cant. Even if its an old game. HELP :'(

edit: i have installed "M&B fire and sword" since i own the trilogy to play that instead of warband and guess what. It does the same thing. it wont launch. soooo frustrating.
 
Last edited:
I think you have probably tried that, but have you tried unsubscribing to some mods on the steam workshop ? Probably a useless tip,but It worked for me back in the day. I hope you find a fix soon.. I know what it is to be dealing with a problem you simply can't fix.

Edit: Yeah, I saw your reply on the other thread, you have tried unsubbing to mods. Well I hope you find the answer my dude. All I can say is good luck.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
You can download the non-Steam version from our website and activate it with your Steam issued cd-keys to try if that is also not launching.
 

Jimtrum94

Recruit
I think you have probably tried that, but have you tried unsubscribing to some mods on the steam workshop ? Probably a useless tip,but It worked for me back in the day. I hope you find a fix soon.. I know what it is to be dealing with a problem you simply can't fix.

Edit: Yeah, I saw your reply on the other thread, you have tried unsubbing to mods. Well I hope you find the answer my dude. All I can say is good luck.
Thanks for trying though :smile:
 

Jimtrum94

Recruit
You can download the non-Steam version from our website and activate it with your Steam issued cd-keys to try if that is also not launching.
Just tried it. I double click the game and then nothing happens. I had the task manager open on the side and the game showed up for a second and then disappeared. :sad:
thanks for your answer. Any other suggestion? Anything, even through team viewer if you guys do that.

edit . next to the game in task manager it was written suspended if it helps. i have tried disabling antivirus too.
 

Alene

The Queen of Diamonds
Archduke
M&BWBWF&SNWVC
You should have a file called rgl_log.txt in your installed Warband folder. Can you tell what it says?
 

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
This used to happen to me a lot. The solution was to either delete rgl_config.txt or rename it to rgl_config_old.txt and then attempt to relaunch. You can find the file here:

C:\Users\YourName\Documents\Mount&Blade Warband\

If it still happens, open up rgl_config.txt in notepad (or something similar) and scroll down to force_single_threading. Change the value to 0 if it is set to 1 and overwrite the file. It should look like this:

force_single_threading = 0

If it still persists, you can try to change Load Textures On Demand. So reopen rgl_config.txt again and scroll until you find use_ondemand_textures = 1 and then change it to use_ondemand_textures = 0.

However, the simplest solution here is just to delete this entire file, reboot Steam and relaunch Warband to regenerate this file, you can try the editing options first if you want.

Let us know if it worked or not.
 
Last edited:

Jimtrum94

Recruit
This used to happen to me a lot. The solution was to either delete rgl_config.txt or rename it to rgl_config_old.txt and then attempt to relaunch. You can find the file here:

C:\Users\YourName\Documents\Mount&Blade Warband\

If it still happens, open up rgl_config.txt in notepad (or something similar) and scroll down to force_single_threading. Change the value to 0 if it is set to 1 and overwrite the file. It should look like this:

force_single_threading = 0

If it still persists, you can try to change Load Textures On Demand. So reopen rgl_config.txt again and scroll until you find use_ondemand_textures = 1 and then change it to use_ondemand_textures = 0.

However, the simplest solution here is just to delete this entire file, reboot Steam and relaunch Warband to regenerate this file, you can try the editing options first if you want.

Let us know if it worked or not.
Thanks for your message. So, i have searched for the file at the location you told me but there is nowhere to be found. I have the game installed on my D drive so i searched on my D drive too but stil cant find it. I have uninstalled and reinstalled and still could t find it. Since i could't find it i had my brother transfer me the file from his computer and then followed your instructions. still nothing since they are not" connected" with the original file . i have tried moving the files to Documents, and to the other path u mentioned.C:\users\myname\Documents\Mount&Blade Warband\ but stil nothing. if i delete the rgl_config.txt file, restart and relaunch the game it doesnt regenerate the file. Should i move the files my brother have send me to another location on my D drive instead? or even in the game folder? I appreciate it that you try to help me friend
 

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
Thanks for your message. So, i have searched for the file at the location you told me but there is nowhere to be found. I have the game installed on my D drive so i searched on my D drive too but stil cant find it. I have uninstalled and reinstalled and still could t find it. Since i could't find it i had my brother transfer me the file from his computer and then followed your instructions. still nothing since they are not" connected" with the original file . i have tried moving the files to Documents, and to the other path u mentioned.C:\users\myname\Documents\Mount&Blade Warband\ but stil nothing. if i delete the rgl_config.txt file, restart and relaunch the game it doesnt regenerate the file. Should i move the files my brother have send me to another location on my D drive instead? or even in the game folder? I appreciate it that you try to help me friend

Please be a bit patient with me, but when you say there is nothing to be found, are you saying you cannot find rgl_config.txt within your Documents folder? Are you sure you checked the correct path? There are two within Documents, one for the game and one for save games. If you copied the location I gave earlier directly, it would not have worked for you, you will need to change the username to whatever your PC username is. For example, the text highlighted red would be different for you:

C:\Users\SerJon\Documents\Mount&Blade Warband

Let's do a test. Press the Windows Key (it looks like this on your keyboard) and R at the same time. A small window will pop up called "Run". In here, type exactly this: Documents/Mount&Blade Warband. The window should look like this after you have typed in it:

FS95YSy.png


Now, hit ENTER. It should bring you directly to the correct path where rgl_config.txt exists. Take a screenshot/picture of what you see in this new window and post it here for us.

Also, moving your brothers files to your PC probably won't solve anything.

EDIT

I included example pictures, just in case.
 
Last edited:

Jimtrum94

Recruit
Please be a bit patient with me, but when you say there is nothing to be found, are you saying you cannot find rgl_config.txt within your Documents folder? Are you sure you checked the correct path? There are two within Documents, one for the game and one for save games. If you copied the location I gave earlier directly, it would not have worked for you, you will need to change the username to whatever your PC username is. For example, the text highlighted red would be different for you:

C:\Users\SerJon\Documents\Mount&Blade Warband

Let's do a test. Press the Windows Key (it looks like this on your keyboard) and R at the same time. A small window will pop up called "Run". In here, type exactly this: Documents/Mount&Blade Warband. The window should look like this after you have typed in it:

FS95YSy.png


Now, hit ENTER. It should bring you directly to the correct path where rgl_config.txt exists. Take a screenshot/picture of what you see in this new window and post it here for us.

Also, moving your brothers files to your PC probably won't solve anything.

EDIT

I included example pictures, just in case.
Yeah it says. Error not found .

BUT i have just fixed it (Jumping around like crazy) and i cant believe what the problem was for SOOO long time. Brother found this in a forum . I will post by whom as soon as i know to give credits.

"I solved this problem because I found your "Current language for non-unicode programs" should match your game's default language. e.g. You set up a chinese Mount&Blade but your non-unicode programs is English or others, your computer can't compile your game. Go "setting" - "Time & Language" - "Region" - "Additional date, time & regional settings"(right side) - "Change date, tiime, or number formats" - "Administrative" - "Change system locate". "
the only thing i added ,after following the instructions, at the last step there is a box saying : "Beta: Use Unicode UTF-8 for worldwide language support" and it must be checked!

edit will share it to other people having the same problem asap
 

Jimtrum94

Recruit

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Can you send me these files? You can send them to me via e-mail. arda.gunduz at taleworlds dot com
C:\Users\[username]\Documents\Mount&Blade Warband > language.txt and rgl_config.txt
C:\Users\[username]\AppData\Roaming\Mount&Blade Warband\perf.dat
 
Top Bottom