• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Unresolved Warband under perform on modern computer

Users who are viewing this thread

I have a Ryzen 5 3600x with msi GTX 1060 armor 6Go 16 GO ram and i can't play Warband with decent fps and normal battle size compares to the power of processor: I'm barely at 50 fps at 300 battle size and even have a weird lag. I could play Warband at 400 on my i5 4570 3,2 Ghz... And even at 300 with few tweaks on my 2007 computer for which i don't even remenber the processor...

I've read on the internet that GTX 1000 series run bad with new nvidia drivers??? But even if this true it only few fps loss.

Someone helped me and had same issues on his different laptops and processors. I have a friend with a Ryzen 7 and RTX graphic card that play Warband at 1000 battle size...

In video options my estimated performance is at 30%... I was at 125% with my i5 (I know i know everyobody keep syaing it's not related but still everytime this estimated performance suck my fps is ruined).

Everything is up to date bios, chipset, drivers, this is really boring, as M&B is my favorite game and i can't even make bigger battles than ten years ago with a very good computer... Also as i'm a modder and scener i was thiking having a better computer and good performance woud help me get faster in scene editing...

Edit:
I have rebuild my other computer that is special build for Warband, Windows 7 intel core i3 3,7 Ghz with GTX 960, drivers 391.5 = estimated performance 45% i never had something so low with same build WTF happen ? Was at 125% estimated performance with same components before...
 
Last edited:
Top Bottom