Warband Script Enhancer 2 (v1.1.2.6)

Users who are viewing this thread

This is not something you would do as part of engine wide changes. This is something a modder would add themselves on a per-project basis.

Totally unrelated to this thread. This has nothing to do with the game engine or changes that K700 can make to the engine and help you out

To answer your question though, it's the file format you are exporting/importing. The commonly used OBJ format does not contain vertex color information. As far as I can remember you will need to use the PLY file format to be able to retain vertex colors.
Sorry, I touched on an irrelevant topic. Thank you very much for your reply, thank you
 
Hello, I've noticed that certain mods tend to have fps issues combined with WSE2. For example, when I played Prophesy of Pendor, trying to have big battles with like 300-500 becomes super laggy. Same thing with A Clash of Kings, though something odd I noticed is that Siege battles in ACOK work fine without much fps drop but field battles tend to lag and stutter. On the other hand, I played Viking conquest with like 700 troops and even though there was a bit of lag, it functioned fine and was totally manageable. Are there certain mods that just tend to not work very well with WSE2? I have a very high end pc btw so the issue is not on my part I don't think.
 
try disabling Sound occlusion
I did, in fact I even tried putting all my graphics on the lowest setting possible and it still didn't help. Any time I'd play a field battle in a clash of kings with like 300+ troops it would start to stutter and fps would be like 15-40. Playing it without WSE2 though, battles with lots of troops perform okay. I've no idea what this could be.

Also, when I load into Native warband with WSE2 I get a bunch of red messages that say WARNING: Failed to find suitable shader for *blank*
I get about 15 of those. What does that mean?

After some testing it seems that Floris has stuttering issues as well with WSE2. A Clash of Kings is based on it I believe.
 
Last edited:
Hello, I've noticed that certain mods tend to have fps issues combined with WSE2. For example, when I played Prophesy of Pendor, trying to have big battles with like 300-500 becomes super laggy. Same thing with A Clash of Kings, though something odd I noticed is that Siege battles in ACOK work fine without much fps drop but field battles tend to lag and stutter. On the other hand, I played Viking conquest with like 700 troops and even though there was a bit of lag, it functioned fine and was totally manageable. Are there certain mods that just tend to not work very well with WSE2? I have a very high end pc btw so the issue is not on my part I don't think.
Native has morale scripts that causes stutters. Most mods are inherited that stutters. For PoP you can tweak that https://forums.taleworlds.com/index...of-pendor-tweaks-and-talk.386332/post-9750402
 
Native has morale scripts that causes stutters. Most mods are inherited that stutters. For PoP you can tweak that https://forums.taleworlds.com/index...of-pendor-tweaks-and-talk.386332/post-9750402
Thanks for the reply but, the problem is that WSE2 for me runs super smoothly on most modules and mods. For instance, I can run battles in Viking Conquest with like 800 men no problem, the fps is a little slower but it's not choppy. There's just a few mods like like A Clash of Kings, Floris or PoP that have these issues. I'd love to solve this because I'm lowkey working on a revival project for A Clash of Kings, trying to fix the horrific amount of neglect that its creator didn't address such as broken scenes, unbalanced troops/armor values and so forth. My goal is to completely refurbish the mod, make it look beautiful and very similar to the books, fix the combat/armor unbalance, fix all the scenes (oh boy was there a lot to fix), introduce new high quality banners that are exactly as described in the books, which I already finished, etc. The mod also has a lot of issues with crashes which WSE2 fixes, but large battles are also slower with WSE2 for some reason, slower than without it. So as you can guess, I really wanna figure this out.

Sidenote, I'm also super grateful for WSE2 being available on WFAS, since I'm making a mod for that as well and it performs so much better with it.
 
You can run Viking Conquest smoothly because they removed old morale scripts with new. Also number of polygons can affect the maximum fps. I.E., it is not WSE2 problem. It is your work as a modder.
Well, as I’ve said, in ACOK field battles run better if I turn OFF wse2 than if I use it. But for some reason siege battles in the same mod run more smoothly WITH wse2. I’ll test it again today just to make sure. But from what I’ve seen so far, if there are under 200 troops in a field battle, wse2 runs very smoothly with ACOK, but if there are like 400 troops, it gets all choppy. But if I turn OFF wse2, big battles with 400 or so troops run a bit better. So I’m not sure what morale scripts have to do with it.
 
Well, as I’ve said, in ACOK field battles run better if I turn OFF wse2 than if I use it. But for some reason siege battles in the same mod run more smoothly WITH wse2. I’ll test it again today just to make sure. But from what I’ve seen so far, if there are under 200 troops in a field battle, wse2 runs very smoothly with ACOK, but if there are like 400 troops, it gets all choppy. But if I turn OFF wse2, big battles with 400 or so troops run a bit better. So I’m not sure what morale scripts have to do with it.
Try use wse profiler for record your laggy battle. If the problem is in the scripts, we can figure out which ones are consuming the most CPU time.

\Documents\Mount&Blade Warband WSE2\rgl_config.ini
[Profiling]
bEnabled=true
 
It's the morale script. I had the same lagging with ACOK using WSE2 (I think I had the same problem before using WSE too with high battle sizes but I might be wrong) until I implemented Jacobhinds morale codes. No more stuttering with iirc 300 troops in battles. Not sure why the lag would be worse using WSE2 than it is with native. Unfortunately you won't be able to fix this if you plan on releasing your submod as the source code isn't publicly available.
ACOK also uses loads of multi-mesh items, so creating texture atlases and combining might help.
 
Hello, K700. Could you explain how the hit collision bone is determined in warband?
image.png
I have this rig where I changed the bone positions, but item. R is not the hit collision anymore, I hit around the tail area now, when I switched those bones its still did not help.
 
can't you hit or can't you be hit?
I can do both, its just that the hit box is in the wrong place and me changing bones seems to place it somewhere else randomly. Its not hitting where I want it to, its hitting somewhere else. Idk if I can look in game to see where the hitboxes are
 
Back
Top Bottom