Warband Script Enhancer 2 (v1.1.2.5)

Users who are viewing this thread

Opening up edit mode gives me free camera but no edit window. Is this normal or is there some other key combination I need to press. With vanilla exe, it loads fine.
 
Hello Guys!

Thank you for the answer! I am the guy from Gondolin server who had issues with running the game on Linux. I would like to share with you my findings and how I managed to run the game with WSE 2.

This is my OS and my hardware setup at the moment -> System

So with the Linux version of Steam you can play many games and Mount and Blade: Warband is not an exception. The game runs fine but installing mods is sometimes tricky. At first step what I did is I installed the WSE 2 mod to the Linux version of Warband. Linux Warband has different files in its folders and maybe this was the reason why I first had continuous silent crashes while I tried to start the game. I had to install the Windows version of Warband on my system, patch it with WSE 2 and find a way to let it run. Here is my solution:

I installed this -> Bottles

I'm not a technical person and I do not understand correctly how this app works. It creates a container which allows you to run multiple Windows based applications inside, like old games or softwares which are only Windows specific. You can find Bottles on the Flathub repository, you just have to add flatpak to your system. In Debian you can see the instructions here -> Flatpak install for Debian

So after I got Bottles on my system I had to install the Windows version of Steam inside. That was not difficult, there is a software catalogue inside the app and you can choose which one you want to install inside your container. Like these -> 1, 2. Sorry for the language, It is hungarian, I didn't find the option to switch to english...

So after I installed the Windows Steam I log into my Steam account and I installed Warband. Then I just copy the WSE 2 files into the Warband folder and start the wse2_launcher.exe with Bottles. It worked!

The game is running fine however I had crashes randomly after about 30-40 minutes of gameplay. I tried to find a solution and it looks so far that is not caused by Linux. I lowered the graphics, turned off shadows, dead bodies and ragdolls set to 0 and I also turn off music. I disabled the sound variation options at the launcher -> Launcher.

Yesterday I was playing the game for 2-3 hours continuously and I had no crash so it seems stable now but it needs more testing.
 
Hello Guys!

Thank you for the answer! I am the guy from Gondolin server who had issues with running the game on Linux. I would like to share with you my findings and how I managed to run the game with WSE 2.

This is my OS and my hardware setup at the moment -> System

So with the Linux version of Steam you can play many games and Mount and Blade: Warband is not an exception. The game runs fine but installing mods is sometimes tricky. At first step what I did is I installed the WSE 2 mod to the Linux version of Warband. Linux Warband has different files in its folders and maybe this was the reason why I first had continuous silent crashes while I tried to start the game. I had to install the Windows version of Warband on my system, patch it with WSE 2 and find a way to let it run. Here is my solution:

I installed this -> Bottles

I'm not a technical person and I do not understand correctly how this app works. It creates a container which allows you to run multiple Windows based applications inside, like old games or softwares which are only Windows specific. You can find Bottles on the Flathub repository, you just have to add flatpak to your system. In Debian you can see the instructions here -> Flatpak install for Debian

So after I got Bottles on my system I had to install the Windows version of Steam inside. That was not difficult, there is a software catalogue inside the app and you can choose which one you want to install inside your container. Like these -> 1, 2. Sorry for the language, It is hungarian, I didn't find the option to switch to english...

So after I installed the Windows Steam I log into my Steam account and I installed Warband. Then I just copy the WSE 2 files into the Warband folder and start the wse2_launcher.exe with Bottles. It worked!

The game is running fine however I had crashes randomly after about 30-40 minutes of gameplay. I tried to find a solution and it looks so far that is not caused by Linux. I lowered the graphics, turned off shadows, dead bodies and ragdolls set to 0 and I also turn off music. I disabled the sound variation options at the launcher -> Launcher.

Yesterday I was playing the game for 2-3 hours continuously and I had no crash so it seems stable now but it needs more testing.

There's a better way, Steam has fantastic Linux support, there's no reason to run the windows client in a bottle, since the native linux client already has proton(a WINE derivative) to run windows games on linux, it's as simple as enabling an option on steam settings, though for warband specifically you gotta force the use of proton in order for the windows version of the game to be used.

Then to use WSE2 you gotta take an extra step, right click the game on your library and go to properties, then paste this in the launch options:

bash -c 'exec "${@/mb_warband.exe/wse2_launcher.exe}"' -- %command%

if you need to use magohud or gamemode for instance you just place the commands after the "--" like so:

bash -c 'exec "${@/mb_warband.exe/wse2_launcher.exe}"' -- mangohud gamemoderun %command%

It makes so the wse2 launcher is used instead, works great, been playing like this for a good while, and it has been pretty stable with many mods.

BUT, actually, one of the reasons I even came here today is because with version 1.1.1.0 it stopped working, the launcher shows up, but when I click play the game just closes.

I'm not sure if it has anything to do with the new wse2 version though, may have been a system update (I'm using endeavorOS, an arch based distro)

Does anyone know where I can get older versions to test this out?


edit:

nvm... it's working now, I guess it was the reboot, I always forget to first reboot before spending a long while trying to troubleshoot something
 
Last edited:
I'm really happy for your answer! Thank you!

bash -c 'exec "${@/mb_warband.exe/wse2_launcher.exe}"' -- %command%

This worked! I have no idea what these codes mean but Warband WSE 2 is running from the Linux Steam and I'm glad it works. I do not like flatpaks on my system because I think they are a security issue. I test the game with this code for some hours now and if it is stable then I'm going to remove flatpak from my system.
 
WSE had this in wse_settings.ini:
Code:
[memory_optimizer]
;Enable the memory optimizer for systems with low memory or large mods (experimental)
enabled = 0
;Threshold (in MB) after which the optimizer will activate
threshold = 500
is this included in WSE2? Because i cannot find it anywhere.
 
WSE had this in wse_settings.ini:
Code:
[memory_optimizer]
;Enable the memory optimizer for systems with low memory or large mods (experimental)
enabled = 0
;Threshold (in MB) after which the optimizer will activate
threshold = 500
is this included in WSE2? Because i cannot find it anywhere.
no WSE2 doesn't need it
 
I'm really happy for your answer! Thank you!



This worked! I have no idea what these codes mean but Warband WSE 2 is running from the Linux Steam and I'm glad it works. I do not like flatpaks on my system because I think they are a security issue. I test the game with this code for some hours now and if it is stable then I'm going to remove flatpak from my system.
NP :smile:

Happy to help one of my Linux brethren
 
Is it possible to set custom controls/omit keys in wse2? Having the player need to change controls to play a mod is not really a good thing in my opinion. For example Q is bind to quests, but there is no reason to open them in a combat encounter, I would desire to use it for skill activation or something. Is this a possibility?
 
Is it possible to set custom controls/omit keys in wse2? Having the player need to change controls to play a mod is not really a good thing in my opinion. For example Q is bind to quests, but there is no reason to open them in a combat encounter, I would desire to use it for skill activation or something. Is this a possibility?
How do you get around this problem in a warband?
 
How do you get around this problem in a warband?
In native I just set it to a non assigned key, but most of the time they are in a awkward place on the keyboard to use. I set ctrl, v, t, but after that all other keys are quite away from wasd, makes it harder to click during gameplay.
 
I'll need to research the issue, but I think we can load the control template from the module when the player first launches the module and also when the player resets the settings to default. I can make it to order.
 
1.1.1.1
-Increased maximum value for Battle Size in settings.
-Fixed some ai bugs.
-Fixed warband_compatibility.ini processing.
-Fixed left hand mesh for gloves.


No longer needs to be manually edited rgl_config.ini for larger Battle Size. Be careful with high values, thousands of agents are very bad for performance!
 
Back
Top Bottom