Warband Script Enhancer 2 (v1.1.2.1)

Users who are viewing this thread

enum mbSkeletonHumanBoneKind
{
hb_abdomen = 0,
hb_thigh_l = 1,
hb_calf_l = 2,
hb_foot_l = 3,
hb_thigh_r = 4,
hb_calf_r = 5,
hb_foot_r = 6,
hb_spine = 7,
hb_thorax = 8,
hb_head = 9,
hb_shoulder_l = 10,
hb_upperarm_l = 11,
hb_forearm_l = 12,
hb_hand_l = 13,
hb_item_l = 14,
hb_shoulder_r = 15,
hb_upperarm_r = 16,
hb_forearm_r = 17,
hb_hand_r = 18,
hb_item_r = 19,
};

bones hardcoded
for attacks engine used hb_item_r
 
No, I've tested it now. The engine seems to use bone 19 as the attack hitbox. I was able to change what bone 19 was and that was the damage hitbox.
image.png

Here the damage was done by upperarm.R

Now that I reverted it to this
image.png

It works with item.R
Seems I found out something new.
 
Can you earn achievements for using WSE2? They are not popping up, though the steam overlay is along with me having cheats disabled?
 
Hello, i've been using wse for some months and i love it but theres also some bugs that could be fixed,the most annoying one is sometimes you cant download a map, it starts downloading and then i get a connection error that says "unable to connect" the download stays at 0 kb forever no matter how much you try, i usually fix this by launching normal warband, downloading the map there and then copying those new files into my wse warband but its quite annoying to do it everytime, the second bug is not being able to pick up some stuff from the ground/tables like crossbows or siege ladders, i believe this one must be harder or almost impossible to fix since is probably due to object collision, there's probably more bugs that i forgot to mention but those 2 are the most annoying ones by far.

ps: i only play on trollgame servers and ludus if that matters to fix this stuff
 
I need a more detailed description of the problems.
When connecting to which server do you have a problem with maps? Send a screenshot.
Pick up items bug only on WSE2? Is there such a problem in vanilla Warband?
 
Back
Top Bottom