Warband Script Enhancer 2 (v1.0.6.9)

Users who are viewing this thread

K700

Sergeant Knight
WB
Added an alternative for patreon
 

K700

Sergeant Knight
WB
Don't worry, boosty more for one-time transfers because in my country it is no longer possible to transfer directly to paypal.
 

TweT_Anoki

Recruit
Don't worry, boosty more for one-time transfers because in my country it is no longer possible to transfer directly to paypal.

Hello K700, can you help us in this step ? We are trying to uplaod WSE in Server with gaming GTX

"Hi Loïc,

I tried to install this but the server it's stuck on this step: https://gyazo.com/1bc63fd39642e83a83394013d656a504 trying to find some Native.txt file, i don't see any Native.txt file in the files you have to download, or any reference to it on the that forums topic, i also tried to create the file manually but the error it's the same.

Do you have any idea what's that Native.txt file or where we could get it or what should have inside ?

If you have any more questions please do not hesitate to ask.

****
Senior Engineer"
 
Last edited:

TweT_Anoki

Recruit
"I have started the server now, it's doing something but still doesn't seem it's the correct content we should add on Native.txt file, opens and closes a few times, i made a video: https://gyazo.com/4d635ac827fad38f2fbfe797e692ce9a

Something else needs to go inside that Native.txt file but i can't find any information about it, i'm sure it's something simple that we are overlooking, ill keep investigating it.

If you have any more questions please do not hesitate to ask."

*******
Senior Engineer
 

K700

Sergeant Knight
WB
This is dedicated server config file. You can specify the correct path to yours in the bat file.
Most likely port is already in use, so the server is not starting.
 

TweT_Anoki

Recruit
Server is not showing in the list.

"Hi Loïc,

I have installed both WSE2 1.0.6.8 and Full Invasion Osiris, adjusted the files/paths and started the Full Invasion Osiris_WSE2_dedicated file and seems to be doing something, sits on this: https://gyazo.com/4cdf3d6b1fbe776d0fcd6bc6046ff34b not 100% sure if this is good or bad, try to connnect to server see if worked.

If you have any more questions please do not hesitate to ask.
*****
Senior Engineer"
This is dedicated server config file. You can specify the correct path to yours in the bat file.
Most likely port is already in use, so the server is not starting.
 

TweT_Anoki

Recruit

Hektor_Riven

Recruit
M&BWBWF&SNWVC
1.0.6.8
-Added bSyncBlockDirections config option.
-Fixed fWeaponPointsPerLevel, fSkillPointsPerLevel, fAttributePointsPerLevel config options.
-Fixed icons for items on inventory screen.
-Fixed ti_on_agent_spawn trigger - missing trigger_param_2 (entry_no).
I've noticed an update on the patch for Full Invasion Osiris too: the file module_config_template.ini is newer (from May 2nd).
I fear I've missed where it's advised to re-download those specific patch files beside the engine's core ones, maybe it's better to advertise more every update that's made in every separate download so that users have not to download everything and discover by themselves if something got updated.
The Spyglass does not modify hardcoded Shift zoom but acts independently of it due to coding. Download NW's source code if you wish to learn how it works, but I can tell you it is pure ModSys scripting. If it works differently in WSE2 and vanilla, it may be something with the former's malfunctioning operation.
Yes, sorry, It was indeed a illusion, given maybe by the fact that the spyglass limits the visible portion of the screen. You need not to persuade me and I don't need to study the Napoleonic Wars source code to convince myself, it was just a small bug report accompanied by screenshots.
 

Hektor_Riven

Recruit
M&BWBWF&SNWVC
I'd take the opportunity to present another couple of issues, and I'm now able to provide a video concerning the second point of my previous bug report.
  1. Thanks to the fixed Custom Battle mode for Napoleonic Wars it's now more easy for me to catch the moment when distant texture flickering happens. Here is a video showing the problem. Still images, in fact, aren't very explanatory as they don't show the "movement" of textures;
  2. in the Full Invasion Osiris module I've noticed that there are white textures for a waterfall and a pond of water that's above the sea level. While this happened in the Ailando scene (the first of the map list) I suspect it's a problem regarding every occurrence of that specific asset. Screenshots are here, here and here;
  3. it happened to me once in With Fire and Sword, but it was a custom map and I thought it wasn't related to the Warband Script Enhancer. Now I noticed the same odd behavior in the very Ailando scene of Full Invasion Osiris, and I suspect there's something wrong with the rendering of shadows. Here is a screenshot, I'll provide more as soon as I'll find new occurrences of this bug. It's hard for me to tell what projects those shadows;
  4. in Napoleonic Wars there's a very minor issue concerning music volume: differently from every other module supported by the new engine, a user cannot completely mute the main menu music by putting the control slider all the way left. It's possible to still hear the music at a very low volume in the background and, if slider is moved again on the right, volume increases but music doesn't restart, it just keeps playing (while the normal behavior is that music restarts if deactivated by putting its slider all the way left). If game is restarted then one cannot hear anymore the menu music at a very low volume, instead it behaves correctly in the way that, when moving rightward the slider, music starts from its beginning. Here is a video recording I've made. Turn the volume to max to hear what happens.
Thanks for the attention and for the great job, I hope this helps.
 

K700

Sergeant Knight
WB
1)This is not a wse2 bug, since the same thing happens in the warband.
2)I can't reproduce this on my own, please send me yours Documents\Mount&Blade Warband WSE2\rgl_config.ini
3)Need more information. Have you seen this problem in warband?
4)Fixed, will be in the next update.
 

Hektor_Riven

Recruit
M&BWBWF&SNWVC
1)This is not a wse2 bug, since the same thing happens in the warband.
2)I can't reproduce this on my own, please send me yours Documents\Mount&Blade Warband WSE2\rgl_config.ini
3)Need more information. Have you seen this problem in warband?
4)Fixed, will be in the next update.
Thank you for your attention. First of all I apologize for having reported a Warband engine's bug. I haven't noticed before but you're absolutely right.
Regarding the other bugs, here are the details you've asked:
  1. Concerning white textures in Full Invasion Osiris, here is my rgl_config.ini, in addition here is the log from the session where I launched the map again and noticed the white textures bug. A few evenings ago on TweT server a couple of other users told me that they were experiencing the same bug. I've asked another friend of mine to check and he confirmed too the same bug, here is his config file and here his log;
  2. concerning the shadows bug, here are the information you requested. I've tried all the supported modules but, so far, this bug happens only in Full Invasion Osiris, Viking Conquest and With Fire and Sword. It's easily reproducible by hosting a game and starting a randomly generated map. Here is my config file from With Fire and Sword, if you need it, here is the log from the session I experienced the bugs in With Fire and Sword and here is the one from the session of Viking Conquest. Here and here are screenshot of the issue from With Fire and Sword, here and here instead are the ones from Viking Conquest.
I've finally managed to catch another bug I'll briefly report it here in this post.
  1. I've noticed something odd with certain hats in Napoleonic Wars, namely the grenadier hats, this is an image I took, but I thought it may have been a vanilla bug. Then, while playing Viking Conquest, I've noticed this, showed here, here, here and here. I'm totally sure this didn't happen in vanilla Viking Conquest as it's the module I've invested more time in.
As always, I thank you for your patience and dedication towards the developing of this software which is, in my opinion, crucial for the future of this game.
 

Hektor_Riven

Recruit
M&BWBWF&SNWVC
Updated Full Invasion Osiris, fixed white water textures.
I'm so glad that my report helped you at addressing this bug, and I thank you for being so quick!
Have you seen this problem in vanilla warband?
No. This problem doesn't happen in vanilla Viking Conquest, With Fire and Sword and Full Invasion Osiris. Here is an image of the same place where the bugged shadows are in the Ailando map of Full Invasion Osiris.
Don't understand what the bug is?
These are the head wear of Napoleonic Wars and Viking Conquest:
grenadier fluffy hat;
Saxon helm;
helm with nasal.
These instead are how they appear in the same modules if launched with the Warband Script Enhancer 2:
same grenadier fluffy hat;
same Saxon helm;
another helm with nasal.
 
Top Bottom