Warband launcher won't launch (Steam)

Erikas

Recruit
WBNWVCM&BWF&S
Best answers
0
Hello guys, I've been running into this issue lately, that M&B:W wouldn't even launch to the module launcher thru Steam (it used to work fine around a month ago), no error message, no nothing, just says running for a few moments, and stops after.

I've tried launching the game thru steamapps/common/mountblade warband/mb_warband.exe and got the following error message:
https://imgur.com/sIOWDK5

I've tried reinstalling the game on steam, clearing steam config thru win + r and typing "steam://flushconfig/", updating my gpu drivers, anti-virus sweep shows nothing.
Here is my DxDiag.txt: https://pastebin.com/LEwrtbFQ
Entries from Event Viewer: https://imgur.com/gallery/tBBiduS
there is no rgl_log.txt in the game directory after trying to start it.

Mount&Blade and Mount&Blade: With Fire and Sword work without a problem. Hoping you guys can help me solve this.
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Best answers
1
We are aware that some users are experiencing an issue when trying to launch the game. While there are some workarounds that have worked for other users that have experienced this issue, there isn't a definitive solution to this. You can find these workarounds below:

-Unsubscribing from Steam Workshop Modifications:
Unsubscribing from any mods you have installed through the Steam Workshop and deleting them from the Workshop mod installation folder can solve the issue. The Workshop mod installation folder can be found in:
Steam > steamapps > workshop > content > 48700

-Removing Third Party Applications:
Some of the third-party applications might be blocking the game from launching, in particular, security software. You should add the game .exe to the white list of any security software you are using, and close any unnecessary programs before trying to launch the game.

-Clean Install:
The clean install is removing every single game related file from your computer and installing the game again. If any of the game files changed somehow they could possibly be preventing the game from launching. To do that:
Uninstall the game. You can do that by right clicking the game on Steam Library and selecting Delete Local Content.
Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:

My Documents > Mount&Blade Warband & Mount&Blade Warband Savegames folders.
If you have used Steam Workshop to install modifications, Steam > steamapps > workshop > content > 48700 folder.
If you have manually installed modifications, Modules folder inside game install directory.
AppData folder C:\Users\your-username\AppData\Roaming\Mount&Blade Warband
Note: You'll need to allow Windows to display hidden folders and files to see the AppData folder and its contents.
At this stage, everything related to the game on your computer is deleted. Now you can re-install the game and try launching the game again.

Unfortunately, we are unable to reproduce this issue in the office so we aren't entirely sure what is causing it. We will keep trying to work on a solution, however, for now, we can't make any promises.

Thanks for your understanding.
 

Erikas

Recruit
WBNWVCM&BWF&S
Best answers
0
A small update - the d3d9.dll that I had came from some visuals mod that didn't get wiped when uninstalling the game via steam, I've unsubscribed from all the workshop content there was, and did a manual folder wipe, deleting everything. At first windows refused to let me delete the .dll file, stating it was being used by mb_warband.exe, despite no proccess being active, however a quick reboot allowed to delete the file. Did a fresh install on Steam, and the game seems to work without a hitch!

Huge thanks for your time!
 

stryyts

Recruit
Best answers
0
Hello, I'm trying to do the clean instalation. I did every step. And when I want to launch the game it'll say preparing for launch and than the game closes. I think the problem is that it creates new folder in documents but there is nothing in it.

Any solution for this?
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Best answers
1
Some of the third-party maps might be blocking the game from accessing the documents. Try disabling some of them and try again.
OneDrive and MSI Afterburner are known for this issue for example.