Unsolved Warband Launcher will not start. How do I fix this?

Currently viewing this thread:

Nachtel

Recruit
WBNW
Best answers
0
I am on Windows 10. I was playing Warband as usual, until one day I clicked "Play" and the launcher wouldn't even open. It would just saying "starting" then stop. I tried using the exe file, but it didn't do anything. I've tried absolutely everything, including reinstalling and repairing Windows C++ redistributables, getting Windows to update, validating the integrity of the Warband game files, checking if "Run this program in compatibility for" was unchecked in the "Properties" and subsequent "Compatibility" options for the exe file. I've unsubscribed from every mod I had been subscribed to on the steam workshop, and went to Steam/steamapps/workshop/content/48700 and deleted anything in there. Furthermore, I tried running the game on my laptop which is also on Windows 10, and it worked perfectly. This problem is only unique to Warband no other game I have on my steam library.I have absolutely no idea what to do to fix this.

My PC specs^
 
Last edited:

Elk2503

Recruit
Best answers
0
I have the same problem too, I have tried clean uninstall, unsub from any mods, deleted everything, done a reinstallation, turned off window defender, downloaded a new version from taleworlds, run the DirectX setup 3 times (as I have seen s.o solved by this method), restart my laptop. Yet nothing happen, I pressed Play, it starting then nothing happen, then it stopped

This only happens with warband and not any other games

Pls help