[Video] Making weapon textures for .960+

Currently Viewing (Users: 0, Guests: 1)

James

Grandmaster Knight
Best answers
0
Hey,

Here's a short video I made describing the process necessary to texture weapons with the new specular shaders, etc.

It's short, to the point, and perhaps not in depth enough, but it's my first video ever.

http://www.youtube.com/watch?v=OMQKc0Hr6TY

Or, in better detail:

http://rapidshare.com/files/134459253/makingtextures1.wmv.html

Tell me what you think.
 

13 Spider Bloody Chain

Grandmaster Knight
Best answers
0
Thanks for the vids!

Question:

How did you get those .dds files again? Did you take the .bmp textures that you exported from Wings, convert them to .dds, and then open them up with the DXTbmp.exe?
 

James

Grandmaster Knight
Best answers
0
I don't export anything from Wings. Ever. I unwrap a model, then stop. Then I open weapons1.dds or whatever, edit it in Gimp, save it as my own .dds. Then I import into Wings, move the pieces of the model on it, then add both things to BRFedit.
 

gypsydevil

Squire
Best answers
0
First off, thanks for the tutorial.



I've tried to follow the steps in your tutorial, but maybe I'm messing up.

I've already got my model/texture setup and I have put into the game and seems to work fine.

Just so you know, I import items based on the tutorials in the forums so I separate out my brf's into a model brf, a material brf, and a texture brf.


I've already got my model and UV map/texture all done, module.ini stuff as well.  Again, item works fine, just trying to add the specular element

So I desaturate my color texture and save it under a different name(as a dds in the textures dir, wideswordspec.dds)

I open that texture in brfeditor and save it as a brf(wideswordspec).

I open my material(wideswordmat) brf and add in the new settings with the specular_shader, diffuse my color texture, and put my new black and white texture in the specular field(350,500,500,500,1824)

My mesh brf already has wideswordmat set as it's material.

I add wideswordspec to my module.ini

Start it up and I get an error when loading textures at the end of the loading ini file part.

If I remove my new specular texture(wideswordspec) out of the ini, then the game starts fine, but there is no specular setting on my weapon.



Any hints?  I am using the 4 brf's, and it seemed like you were using one brf for everything. 

Also in the middle of you tut you imported you texture into wings, however, I am using an original mesh/texture so I skipped that step.
Also not sure if it's a brf thing with me, but in the tut you only use one, while I am using one for every resource(texture, model, material, spec text)
 

Mad Skillz

Baron
WBM&BVC
Best answers
0
I vote for a sticky. there's a modelling video tut stickied so there should be a texturing tut too.
 

James

Grandmaster Knight
Best answers
0
Gypsydevil: I know exactly what's wrong. What you want to do, since you split them into three files, is, instead of making wideswordspec.dds a brf file (which it isn't, since it's not a model), add it as another texture in your textures.brf file. Then, in your model brf file, add wideswordspec.dds as the specular. It's in the video, so just watch for it carefully. If you need more help, ask.
 

gypsydevil

Squire
Best answers
0
James said:
Gypsydevil: I know exactly what's wrong. What you want to do, since you split them into three files, is, instead of making wideswordspec.dds a brf file (which it isn't, since it's not a model), add it as another texture in your textures.brf file. Then, in your model brf file, add wideswordspec.dds as the specular. It's in the video, so just watch for it carefully. If you need more help, ask.

James!!

Cool, I wasn't sure I'd get an answer thanks.  Er, I will try that, but.. add wideswordspec.dds(my desaturated texture) to the model brf, or the material brf?, I was pretty sure in the video it was the material brf.
 

James

Grandmaster Knight
Best answers
0
Oops. Yeah, to the material. See, I do it all in one, so I think it's all the same.