Need More Info Very high crash probability while loading of (character model) textures [1.8 but it already started 1.7.2]

Users who are viewing this thread

Version number
e1.8
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2022-08-26_01.22.37_ac794753f5e80b23ee88cd7f00c0d22e

Sturmhardt

Recruit
Summary:
Since update to version 1.7.2 I experience very constant freezes or crashes. I can already tell it is going to happen, when an instance or a screen is being loaded and I cannot see char models or parts or their textures.
At that point the game basically crashed already, it just takes a moment till it freezes/crashes. Certainly when I start to leave that screen to contunue.
Within the partially loaded instance I can sometimes still interact with NPC till I freeze, but as soon as something else tries to load, it's freezing.
It's very random what part of the game triggers this, because basically every screen or instance handles (char model) textures.
Most of the time it is just freezing and no crash handler opens. And then I have to close the task manually, because nothing will happen anymore.
In 1.7.2 the crashes are very regular already, but since upgrade to 1.8 I can maybe open 2-3 screens and then it's already crashing.
I cannot even start a campaign anymore, because I certainly crash on the way through the different screens of the char creation already.

How to Reproduce: since 1.8 just start a new campaign, and it will crash after a few choices made, before even finishing the char creation and starting the campaign.
First I had a mod called Bannerlord Online under suspicion causing this. But it is also happening on a fresh and clean (followed all advised procedures for clean reinstall) installment. I followed all instructions to troubleshoot this and am hunting this problem actively for 2 months now. Including all drivers, net framework and so on. Also tried SSD and HDD to rules out any problem with the SSD. But all attempts to get a different result failed.

Have you used cheats and if so which: no

Scene Name (if related): basically every scene imaginable

Media (Screenshots & Video):
I have more if required.

Computer Specs:
OS: Windows 7 Ultimate (64-bit) Service Pack 1
GPU: NVIDIA GeForce GTX 1060 6GB on GPU GP106-A
GPU Driver Version: 473.81
CPU: Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
RAM: 16 GB
Motherboard: MSI - Z170A PC MATE (MS-7971)
Storage Device (HDD/SSD): CT250BX1 00SSD1 SCSI Disk Device (250 GB)
(P.S. The uploaded crash report was triggered using the Bannerlord Online mod. But this issue isn't caused by this mod, as tested many times over. It's just hard to get a hand on uploadable crash reports, so I used the opportunity to send one. It could take me a week getting one otherwise, almost all crashes freeze and don't trigger uploads.
I also have a 1.7.2 native crash report I could send you as well, if interested. I preserved many crash reports since it happens often)
 
Last edited:

Sciohan

Regular
M&BWB
Game's bugged for Windows 7 / 8 right now, workaround is to run Process Monitor in the background.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
From the crash ID you sent we can see that Bannerlord Online mod is enabled. Please disable it and reproduce the issue on non-modded scenario. Thank you!
 

Sturmhardt

Recruit
From the crash ID you sent we can see that Bannerlord Online mod is enabled. Please disable it and reproduce the issue on non-modded scenario. Thank you!
I know, that is what I mentioned in my original post already. But the crash issue got nothing to do with the mod. It even happens without any mod installed at all.
After longer investigation it's now clear it's the Windows 7 instability issue. I could stabalize it somewhat using the Process Monitor from microsoft.

Otherwise I only get one crash report I could upload in a 100 crashes, the rest of the time the application just freezes and I have to close it via task manager.
It would take a seriously long time to create a crash report I could upload again.
I stilll have one saved on HDD from before, though.
If you prefer I can compress it and upload that one, I just can't use the automated upload system for it and would have to send it to you directly.

Let me know if, and if where you want me to upload that file.

Thank you for the support!
 

Sciohan

Regular
M&BWB
I have that same problem. I am using windows 8.1. I couldn't find a solution.
A few Windows 8 users reported the procmon workaround as working for them, as well as one madlad running Windows Server 2019. If you haven't already tried that yet, I would. I haven't seen any other workarounds yet so it's either that, upgrade to Win 10/11, or wait for a patch to fix it.
 
Top Bottom