version 1.154 of warband

Currently Viewing (Users: 0, Guests: 1)

oppai

Sergeant Knight at Arms
WB
Best answers
0
is there any way i can play this mod with v1.154 of the game currently it gets stuck at the father's seppiku and some people have stated is because of the wrong version and something about wse....now is there any way i can play this with my current version or any way i can downgrade to v1.153????? any and all help will be appreciated :grin:
 

Hazzardevil

Master Knight
NW
Best answers
0
It's your lucky day, I just installed that version myself:
http://download.taleworlds.com/mb_warband_setup_1153.exe
Download that and install it, install any WSE dependent mods in there.
 

aragontherin

Regular
Best answers
0
does this give you another version of mount and blade because i have mods that need the newest version to play
 

Hazzardevil

Master Knight
NW
Best answers
0
It gives you another installation so you can still play 1.154.
But remember that there is a chance TW will release 1.155 at some point.