Resolved various texture errors

Users who are viewing this thread

Version number
e1.8.0
Branch
Beta
Modded/unmodded
No, I didn't use any mods.

tojaaa

Recruit
Summary:I experience a lot of texture bugs in the game I have them for several versions of the game, I don't know how to get rid of them. below gives 4 examples (all 4 photos were taken during the 5 minute game I don't even want to check what will happen next) I just downloaded the game but I checked the game files consistency after that and it shows that everything is fine. and I also noticed that a few texture has improved from the previous version, e.g. before I had all the textures in inventory broken but now inventory works (on this version)



How to Reproduce: e1.8.0 Beta I play without any mods, and polish subtitles version
Have you used cheats and if so which:no
Scene Name (if related):
Media (Screenshots & Video):
https://prnt.sc/FPGG28QQiLPo

Computer Specs:
OS: win 11 pro
GPU:msi rtx 2070 super x trio
GPU Driver Version: 516.59
CPU:i5-9600kf 3,70ghz
RAM:16gb 3200mhz
Motherboard: asrock z390 pro4
Storage Device (HDD/SSD): SSD Samsung 860 qvo 1tb





I noticed that you propose to delete the folder C: \ ProgramData \ Mount and Blade II Bannerlord \ Shaders, but the problems remain
if you need more information, I will try to answer as soon as possible :smile:
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, can you try deleting the contents of "C:\ProgramData\Mount and Blade II Bannerlord\Shaders" and "C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\TileSets\pages" folders and
"steamapps\common\Mount & Blade II Bannerlord\Modules\Native\AssetPackages\gauntlet_ui.tpac" and "\steamapps\common\Mount & Blade II Bannerlord\Modules\SandBox\AssetPackages\gauntlet_ui.tpac" files & "\steamapps\common\Mount & Blade II Bannerlord\Modules\Native\GUI" & "\steamapps\common\Mount & Blade II Bannerlord\Modules\SandBox\GUI". Then make a search for " *spritedata " in the "steamapps\common\Mount & Blade II Bannerlord" folder and delete everyting in the results, verify the integrity of the game files and try to reproduce the issue. If the issue is persistent please let me know.
 

tojaaa

Recruit
as the second time I launched the game after deleting these folders, most of the graphic errors returned :sad:
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey. As a last resort, can you try a clean install?
Clean Install
The clean install is removing every single game-related file from your computer and installing the game again. Why do you need to remove the game while you just want to remove the modifications? Unfortunately, some of the modifications do not just add a new modules folder but also change or adds contents to the existent modules folder. Without a reinstall, we can't be sure those files are unchanged.

To perform a Clean Install, Uninstall the game. You can do that by right-clicking the game on Steam Library and selecting Delete Local Content. Delete all folders related to the game that remains after the uninstallation. The folders that might have files inside:
Steam: C:\Program Files (x86)\Steam\steamapps\common\Mount & Blade II Bannerlord
Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord
C:\Users\USERNAME\Documents\Mount and Blade II Bannerlord
C:\ProgramData\Mount and Blade II Bannerlord

Note: You'll need to allow Windows to display hidden folders and files to see the ProgramData folder and its contents.
 

uçanbiblo

Community Support
Community Support
M&BWBWF&SNWVC
Hey, i am glad the problem is solved. Please let us know if you encounter any other issues.
 
Top Bottom