Need More Info V-sync doesn't work in borderless-window mode, and in fullscreen, only works after switching modes and back

Currently viewing this thread:

Version number
1.5.6
Branch
Main
Modded/unmodded
Yes, I used mods.
This is a pretty big issue for me, as the screen-tearing is pretty extreme whenever I turn. It doesn't actually make me nauseous, but it's definitely unsettling and jarring.

Anyway, so v-sync doesn't work at all in borderless-window mode (this is a common problem in games, I've found), and while it does work in fullscreen mode, lately I've been having a problem of it not working until I go into the options, set it to borderless window, apply, and then set it back to fullscreen.
 

MArdA TaleWorlds

Community Support
M&BWBWF&SNWVC
Forwarded to the developers for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 

Holger55

Recruit
i had this problem also and i solved it by in the nvidia control panel under "3D Settings", "Program Settings" and then add Bannerlord and then under "vertical sync" the "use application settings" option while i have vertical sync activated in the bannerlord options. It seems that when you have the vertical sync set under "Global Settings" and then have it set in Games as well it doesnt work, at least thats my theory ..
 
i had this problem also and i solved it by in the nvidia control panel under "3D Settings", "Program Settings" and then add Bannerlord and then under "vertical sync" the "use application settings" option while i have vertical sync activated in the bannerlord options. It seems that when you have the vertical sync set under "Global Settings" and then have it set in Games as well it doesnt work, at least thats my theory ..
I tried this, but the problem persists.
 
Top Bottom