Resolved Unstable after 1.6.0 update (multiple crashes to desktop)

Users who are viewing this thread

Version number
e1.6.0
Branch
Main
Modded/unmodded
Yes, but I removed mods.
Dump identifier (optional)
not applicable (crash to desktop without popups)
Summary: Problem similar to other threads already active since 1.6.0 update, but not exactly the same. It was working fine before the update. I have been using a save game from before the update and received the notification that the Native SandBox Core CustomBattle Sandbox StoryMode modules were different. Am not using any mods (only used the bannerpaste mod at the start of the game). Also tried Beta update 1.6.1 but it did not resolve the issue.
Game keeps crashing to desktop (freezes and closes; no pop-ups or error message of any kind; so I do not see the crash uploader). Problem is mostly when in Inventory (& Trade) screen or Character screen (but cannot rule out any of the other ingame menu's such as Party or Clan).
How to Reproduce: It sometimes crashes in a specific menu, it sometimes doesn't. But when it crashes 100% o the times: when in a city, going to the Trade screen or in the Inventory menu (trade and inventory are the same), and selecting "Shields&Ranged"...Screen freezes.... and Crash to desktop.
Have you used cheats and if so which: not applicable
Scene Name (if related): not applicable
Media (Screenshots & Video): not applicable
Computer Specs:
OS: W10 pro 21H1, 64bit, 19043.1110
GPU: Nvidia GeForce GTX 1070 Ti
GPU Driver Version: GeForce game Ready Driver 471.41
CPU: AMD Ryzen 7 2700X
RAM: 16GB
Motherboard: X470 Aorus Ultra Gaming
Storage Device (HDD/SSD): HDD
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Please note that we can’t support any modding-related issues. You can find more information about how to remove modifications here and more information about what we think about issues related to modding here.
If you can reproduce the issue in a new, un-modded and verified campaign please let us know!
Thanks for reporting and sorry for any inconvenience!
 

xucan

Recruit
Mods ARE utilized. You used a mod (BannerPaste) to add a custom banner that has multiple sigils. Changes in 1.6.0 no longer properly handle multiple layers so now it crashes. You can find a fix in BannerColorPersistence
 
Okay thank you. BannerPaste was already disabled from the start of the current game, since it did not work properly anymore and this was a very long time (and multiple updates) ago. But correct, even the banner did not work, the multiple sigils remained in a two-tone color. This never was a problem before. Now I replaced the multiple sigils with a single one and indeed, this was the problem. Now the game is stable again. Thanks!
 

xucan

Recruit
The two-tone color issue started back in 1.5.6 which is when the BannerColorPersistence mod was created to continue supporting custom banners. As releases have come out, more issues have popped up requiring more fixes. If you still want to use your custom banners I suggest you check that mod out as it fixes the color issues, the saving issues, and armor/clothing color issues, the kingdom color change issues, and now this crash to desktop issue.
 
Top Bottom