In Progress Unmodded Bannerlord crushes on newest hardware[Help, i tried everything :/]

Currently viewing this thread:

Version number
e1.5.9
Branch
Main
Modded/unmodded
No, I didn't use any mods.
Dump identifier (optional)
2021-04-26_17.44.48_e06ffb08adf7c9d185423e6c8a534c0d , 2021-04-26_17.44.48_e06ffb08adf7c9d185423e6c8a534c0d

KaFKA

Recruit
Summary: Unmodded Bannerlord crushes on newest hardware, whole game acts very strange, its too hard to explain so i made a video, sorry for resolution, my first try with OBS :smile:
VIDEO on YT:
Quick Summary:
-I never used any mods/cheats
-Game wasnt working since beggining, then i figure out that its working via Bannerlord.Native.exe but now i want to play multiplayer and mods, thats what i paid for.
-Game crashes after starting new campain, its possible to load old saves but after few steps its crashing, but if im, the phisics looks broken, when i start quick battle im flying in the sky.. Options are not working, everything is catched on video.
- Game started via Bannerlord.Native.exe never crashed
- Game is bough on Epic platform but when im trying to run it via GeForce Experience, its navigating me to the Steam page
- Doesn't matter if im using Launcher or not, game its working only via Bannerlord.Native.exe
What i did: [What i remember, i tried to solve issues several times, i spent few hours on it, IT guy here]
- Updating OS to newest version
- Reinstalling the game, with folders deletions like %appdata%, documents, %programdata%
- Updating graphic drivers, motherboard drivers
- Disabling antivirus
- Reinstalling ,Visual C++ Redistributable for Visual Studio 2015 ,.net Core, .net FrameWork ,Visual C++ Redistributable for Visual Studio 2017
- Running debugger, which showed me a problem with taleworlds.campaign system dll.
- Waiting for Bannerlord updates
- After Bannerlord uninstallation i deleted some registry items
- Verify game files
- Game isn't installed in Epic: C:\Program Files\Epic Games\Mount & Blade II Bannerlord, the default path was C:\Games\Chickadee. I tried to change game directory name but game crushes during installation
- Run game in safe mode
- Run game in different OS compatibility
- Run game with Admin privileges
- Unblock game files with powershell and iObit
- Run game offline
- Deleting Bannerlord from GeForce Experience
- Playing with different Nvidia settings
- Disabling CPU and memory Overclocking XD

How to Reproduce: idk, take a look on my setup ?
Have you used cheats and if so which: nope
Scene Name (if related):
Computer Specs:
OS: Windows 10 Pro 20h2
GPU: Inno3D GeForce RTX 3070 iChill X4
GPU Driver Version: 466.11
CPU: Intel I7-10700K
RAM: 32GB 3600MHz
Motherboard: MSI Z490 MPG Gaming plus
Storage Device (HDD/SSD): NVMe 1TB Crucial P5
Display: 2560 x 1080 (UWHD) LG 29"

PS: everything looks ok with the OS, other games works perfect, Bannerlord via Bannerlord.Native.exe also.
 

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
When you uninstalled, did you ever try to clear the registry from your PC? You can do so with CCleaner. It is possible you have corrupted registries left on the PC. Especially so with Epic.

As for GeForce taking you to the Steam page, it's your existing shortcut, which tells me there are previous registries on the PC, because GE is set up incorrectly. Have you tried to rescan your games and apps within GeForce Experience? Though ultimately that will not solve your crashing, it should at least fix your GE launcher.
 
Last edited:

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
Just make sure you use it AFTER uninstalling again. This is important. It will remove old and unworking registries, and it might help GE fix up its library or at least remove it so you can rescan and get the proper directory. And reboot after running CCleaner. :smile:
 

Ser Jon

Sergeant at Arms
M&BWBWF&SNWVC
Path deletion shouldn't need back ups, unless his system is incredibly broken, but CCleaner can back it up and it can completely uninstall programs within it. A very great tool.
 

KaFKA

Recruit
Right now im trying to force different installation directory. Wish me luck guys ( Chickendee, what the hell thats mean )
 

momo1

Sergeant
M&BWBWF&SNWVC
Can't see any description on the video wierdly.
Game wasnt working since beggining, then i figure out that its working via Bannerlord.Native.exe but now i want to play multiplayer and mods, thats what i paid for.
-Game crashes after starting new campain, its possible to load old saves but after few steps its crashing, but if im, the phisics looks broken, when i start quick battle im flying in the sky.. Options are not working, everything is catched on video.
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Game wasnt working since beggining, then i figure out that its working via Bannerlord.Native.exe but now i want to play multiplayer and mods, thats what i paid for.
-Game crashes after starting new campain, its possible to load old saves but after few steps its crashing, but if im, the phisics looks broken, when i start quick battle im flying in the sky.. Options are not working, everything is catched on video
Is this what is written in the description or are you experiencing these issues?
@KaFKA
Have you tried launching the game through TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder:“...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client”?
 

KaFKA

Recruit
Is this what is written in the description or are you experiencing these issues?
@KaFKA
Have you tried launching the game through TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe and TaleWorlds.MountAndBlade.Launcher.Multiplayer.exe files located in the folder:“...:\SteamLibrary\steamapps\common\Mount & Blade II Bannerlord\bin\Win64_Shipping_Client”?
@marda please, read my post again, there is very much useful informations. I bought the game on Epic games store, im reinstalling the game now, i will try runt it via TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
After reinstalling are you still experiencing this issue? Also is TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe worked?
 

KaFKA

Recruit
Yes, everything is still the same, also via TaleWorlds.MountAndBlade.Launcher.Singleplayer.exe
 

MArdA TaleWorlds

Community Support & Localization
Community Support
M&BWBWF&SNWVC
Forwarded to the QA team for further investigation. We will reach out again if we need more information. Thanks for reporting and sorry for any inconvenience!
 
Top Bottom