• Please note that we've updated the Mount & Blade II: Bannerlord save file system which requires you to take certain steps in order for your save files to be compatible with e1.7.1 and any later updates. You can find the instructions here.

Need More Info Unbearable Stutters

Users who are viewing this thread

Hosam

Recruit
Greetings,
I Do really love this game but this problem is getting really further and more annoying , I bought this game 2 weeks right after the release.. and till now I can't play it !?
I do appreciate the continuous patches but I really can't believe how this problem not getting fixed so far however it's essential !?
My specs:
GPU: GTX 1050 TI
CPU: Intel Core I5 8400
RAM: 8GB DDR4
OS: Windows 10 PRO x64
I waited for many the upcoming patches , and everytime I say hope it will be fixed on the next patch .. till the last patch 1.1.0e Because that was supposed to be a big patch with alot of performance fixes
But sadly the stutter still exists !? (to be honest slightly better than before BUT it's still stuttering as hell)
I tried lowering the graphics to very low & resolution scale to 90 (Which made the game looks sucks but I tried) but it was still stuttering when I go in town or in battles which was completely insane and the constant sound stutters and delays ... Sound Is another major problem no matter what quality I play in (Very Low To High) , There are sound delays up in giving orders in battle or changing equipment ( Sword , Bow ..etc ) or attacking...

That's a video showing the stutters in a normal custom battle , (It was on the 1.0.6e Patch I think)

I do love the series of Mount & Blade
But this is going over limits ... my specs meet the requirements and I can't even play in the very low ? what logic is this ... !!!
How long am I supposed to wait ? 1 month?
Completely frustrating and many players of similar specs complaining about the same issue ... so this was supposed to be fixed as fast as possible as it's essential to play the game.
EDIT :
Normally I was playing with medium graphic settings (With shadows very low and other things turned off) with 1920x1080 Resolution
I tried lowering the resolution to 1440x900 with medium and even tried low graphics ... game was still stuttering (But Honestly not like before but the weird thing that it was still stuttering) In taverns or villages or towns or battles game had stuttering and in battles had to wait like 15 secs after start to get rid of stuttering but on moving and interactions (Attacking enemy or using shield.. or aiming bow ) game stutters ...
That was unbelievable because with that resolution and graphics set to medium game shouldn't stutter at all ... however my GPU & CPU aren't at 100% or even close to that on battles ....
And most annoying thing also is that sounds are delaying and stutters as well...
EDIT:
That's really disappointing how no-one from TaleWorlds contacted or appeared here ... just weird how no developer or support appeared or said anything !!!
I don't know what happened but recently in the 1.1.2 update , game got better ... playing in 1920 resolution with medium quality , game only stutters at the beginning of the fight and doesn't stutter as badly as before , well yeah there are still stutters and even in combat but not as before just when getting near enemy game stutters but around after 2 mins the fight keeps getting better and it becomes stable but the sad part is that I have to do that in every fight I go up into , also in towns and villages it still stutters badly ... and still huge sound stutters
Also tried in 1280x720 resolution (720P) and game was better but there was these stutters but not as bad as before , but it kept stuttering at the beginning of the battle and at the combat but it now takes less time then disappear ... (And still sound stutters)
I Hope Iam Getting Response From TaleWorlds Supports or Developers !!!
 
Last edited:

saneel2014

Regular
There must be something wrong on your end..most of people reported stable and smooth gameplay after 1.1.0 and now 1.2.0.
 

wookdaddy

Veteran
WB
There must be something wrong on your end..most of people reported stable and smooth gameplay after 1.1.0 and now 1.2.0.

Have you seen the number of people crashing? This game is nowhere near stable. A ton of people, myself included, have great PC's and are still crashing constantly and having bad stutter/lag.
 
Last edited:

saneel2014

Regular
Have you seen the number of people crashing? This game is nowhere near stable. A ton of people, myself included, heavy PC's and are still crashing constantly and having bad stutter/lag.
Im using rx 560x and ryzen 5 i can game on medium settings without crashes with 8 gb ram and battle size at 500...i guess the game is not that optimized for nvidia builds.
 

Hosam

Recruit
Im using rx 560x and ryzen 5 i can game on medium settings without crashes with 8 gb ram and battle size at 500...i guess the game is not that optimized for nvidia builds.
Totally right I think that the game isn't optimized well enough for GTX 1030 - 1060 series I think or something like that or some specs similar
Cuz I've seen players playing the game with similar specs and even lower specs and running the game smoothly without any problems at all ...
Also this has nothing to do with my end or PC ,before I posted this thread I've checked for bugs&malwares checked for latest updates even updated windows but nothing got any better & tried sound tricks in windows and disabling Nvidia GeForce Experience but nothing got better , I can say now iam pretty the certain it's problem with optimization , as I could run many games with alot higher requirements ..
 

Hosam

Recruit
Have you try with framerate limit to 30?

Yeah I tried but game still stutters also the game was so heavy ... I don't play any game on that FPS ,especially if it's combat game if it happens in a game that I have a low FPS , I go to lower graphics ...
The fact that I tried on very low & resolution scale to 90 and game was still stuttering was funny cuz when I checked consumption , my GPU & CPU weren't at even 80% of their usage when stutter happens
 

wookdaddy

Veteran
WB
Im using rx 560x and ryzen 5 i can game on medium settings without crashes with 8 gb ram and battle size at 500...i guess the game is not that optimized for nvidia builds.

If that's the case TaleWorld's is not very bright. 80% of the market are Nvidia users, it's not even close. It should be running well on either.
 

drame

Recruit
I've had similar issues running on decent hardware, and my cpu and gpu both seem to be handling it fine however my disk usage is going crazy all the time. How is your disk usage ingame? Both in battle and in 'overworld' ?
 

Hosam

Recruit
If that's the case TaleWorld's is not very bright. 80% of the market are Nvidia users, it's not even close. It should be running well on either.
I Think the problem that , the game isn't well optimized for the medium Nvidia GPU Drivers like (GTX 1050 ... etc)
And even there are problems with intel cores optimization , which I think those issues will fixed by the time , but it must be taken seriously and to be urgent...

I've had similar issues running on decent hardware, and my cpu and gpu both seem to be handling it fine however my disk usage is going crazy all the time. How is your disk usage ingame? Both in battle and in 'overworld' ?
The funny part is, My CPU & GPU aren't taking their full performance and game is stuttering .. before in earlier patches my CPU & GPU was taking 100% or nearly and heavy stutters .. now the game doesn't use my GPU&CPU maximum performance... and about the disk usage before I had 100% disk usage or approximately 100% most of the time , now it doesn't get to 100% alot maybe rarely , I have even tested it just now my PC was left open and my disk usage was 10% before I started the game.. then i jumped into the game and tried a campaign .. tavern & street & battles in 1920x1080 & 1440x900 resolution and my disk was 50% average ... and game was still stuttering and even what makes it funny that in 1440x900 resolution which is like game must run as smooth as possible and I had set graphics to medium >>> the game was still stuttering .. to be honest not like before it was much better but still stuttering which was unbelievable cuz with settings set to that game must run smooth (And I had edited the thread adding that 1440x900 part)
And even when loading like trade items in shops ..etc disk wasn't getting to high ... (Yeah items take time to load but still it's because HDD and disk wasn't getting too high)
So even if ur disk usage is high I don't think that's the problem
Can you tell me if your disk usage gets like that on M&B or like it's high on normal? when u start windows or when u play like any other game disk gets high cuz I can tell u somethings that will help :xf-smile:
 

KoA John

Duke
I had a problem like your describing, turned out to be purely high RAM usage from the game. I upgraded from 8gb to 16gb and now when the game is running my ram is sitting at 10.5/16gb ram being used.

I dont think 8gb ram cuts it right now for Bannerlord

I got a rx 480 and a i5-7400 16gb ram, running on high at 60fps except in bigger battles
 

Hosam

Recruit
I had a problem like your describing, turned out to be purely high RAM usage from the game. I upgraded from 8gb to 16gb and now when the game is running my ram is sitting at 10.5/16gb ram being used.

I dont think 8gb ram cuts it right now for Bannerlord

I got a rx 480 and a i5-7400 16gb ram, running on high at 60fps except in bigger battles
I don't really know... there are players complaining with highers specs and higher RAM , even more there are players with 8 GB RAM with higher or even lower specs running the game smoothly ... I do wanna try that but the thing is iam saving to buy a laptop , so I don't wanna technically to waste money on RAM that wont make things better , I want to be sure that it's a RAM problem , that upgrading will make it better , cuz the recommended was 8 GB RAM so if it was to use more they would say :grin: , Also my RAM usage doesn't reach it's limit I do checked on task manager and afterburner , and in task manager it's like 87% not close to 100% once ... also lowering my specs and resolution should lower the RAM usage and make the issue disappear if it's a RAM problem right ?
 

nemesis234

Recruit
Confirm i still have some stutters but they take longer than previous patches , now i can play for 1 hour before any major stuttering ruins gameplay.

I have 12 gigs of RAM , GTX960 and i5 4460
 

wookdaddy

Veteran
WB
I Think the problem that , the game isn't well optimized for the medium Nvidia GPU Drivers like (GTX 1050 ... etc)
And even there are problems with intel cores optimization , which I think those issues will fixed by the time , but it must be taken seriously and to be urgent...

I have a 1080ti and i7-4790k. While the processor is older, there is only like a 7-12% difference between that and the best processor available. Upgrading your GPU every few years is way more important. I'm getting awful stutter, wild fps, and I was crashing a ton. Also not loading at all. It took me nearly a full week of troubleshooting just to get the game somewhat stable. It's definitely not just mid range cards. Wish they would fix the memory leak and other large issues before addressing the tiny rare crashes.
 

saneel2014

Regular
I have a 1080ti and i7-4790k. While the processor is older, there is only like a 7-12% difference between that and the best processor available. Upgrading your GPU every few years is way more important. I'm getting awful stutter, wild fps, and I was crashing a ton. Also not loading at all. It took me nearly a full week of troubleshooting just to get the game somewhat stable. It's definitely not just mid range cards. Wish they would fix the memory leak and other large issues before addressing the tiny rare crashes.
Check your hdd usage...the stutters are caused by high hdd usage..can confirm
 

Hosam

Recruit
I have a 1080ti and i7-4790k. While the processor is older, there is only like a 7-12% difference between that and the best processor available. Upgrading your GPU every few years is way more important. I'm getting awful stutter, wild fps, and I was crashing a ton. Also not loading at all. It took me nearly a full week of troubleshooting just to get the game somewhat stable. It's definitely not just mid range cards. Wish they would fix the memory leak and other large issues before addressing the tiny rare crashes.
Well yeah but I can't upgrade a graphic card every 2-3 years or smt ... iam not capable of doing this at least not for now ... It's just if I can't play on very high I turn to high , if still can't I turn to medium.. and goes on with games having issues with...
But my specs should handle the game..
And iam surprised how no one from TaleWorlds support replied or anything ...
 

saneel2014

Regular
Yup the stutters are making the game unplayable right now..devs should fix this in upcoming patches. Performance was better earlier i guess they messed something up.
 

wookdaddy

Veteran
WB
Check your hdd usage...the stutters are caused by high hdd usage..can confirm

I'm running it like I run all my other steam games, on an older 1TB HD. I thought an SSD only mattered when launching a game for faster boot times. It's just there for storage and Steam games...all my main programs/OS are on an SSD. What could be causing that? No problems in any other games.
 
Last edited:

drame

Recruit
I'm running it like I run all my other steam games, on an older 1TB HD. I thought an SSD only mattered when launching a game for faster boot times. It's just there for storage and Steam games...all my main programs/OS are on an SSD. What could be causing that? No problems in any other games.

That is true for most games, however from what I gather it appears that bannerlord does a LOT of saving whilst running causing a lot of HD usage. Might be also because it is loading/unloading a lot of items from the HD rather than storing it all further in RAM (i got 16gb but it doesn't too much of it) such as items, characters etc. The result is when the HD is hit harder than it can follow it'll 'freeze' for a moment.

In many other games, autosaves etc are done slowly to ensure it doesn't get in the way or in areas where you won't "notice/mind" such as elevators.
 

wookdaddy

Veteran
WB
Interesting. Can anyone confirm whether it makes a noticeable difference between playing on a standard HD vs. SSD?
 
Top Bottom