trying to play an old game

Users who are viewing this thread


Hello, I've decided to post on this forum as i found a person asking a question about it here while looking for my issue, i hope it's a valid topic as i didn't find it anywhere else at all.

So i've installed this zanzarah game developed for Windows up to XP on a Mac (macbook pro 2011) with 64-bit Windows 7 on parallels desktop. The game works perfectly fine and smooth except for one big graphic glitch throughout the whole world and i have no idea how to cure this acid.
(please ignore the message on top of the screen)

Any ideas what could have caused it?
Ah, Zanzarah. Reinstalled it last year and noticed that indeed, it's still not a very good game at all. Not sure why I thought time would fix it. I guess I could've had a bias against it back then, but no such luck.

Didn't have that issue, though. Try the basic stuff first. Do you have it running in compatablility mode in your virtualized Windows? That's the first thing you should do. You could also try opening the screen resolution window from the control panel and launch the game while it's open. That's my magic colour fix for Starcraft, but I don't think it's the same kind of issue as this.
Yeah, naturally set windows xp compatibility mode first thing after installation, tried older modes too but no change. Second one didn't work either.
Try this and see if it works.

Right click on desktop and choose "Screen Resolution". Click "Advanced Settings". Select "List All Modes". With that window open try launching the game now. I know this is weird but it worked for me for an old game that was on acid just like this.
Like I already said when suggested more or less the same thing two posts up, it's not the same issue. That's a problem with another application (present in newer versions of Windows) steals the game's palette. Not only is that more or less exclusive to 2D games, you can clearly see the trees are completely unaffected.
Have you tried reinstalling yet?
Try ending explorer.exe before launching the game. Be warned, it gets rid of the start/taskbar. To start it back up, press [windows key], run..., "explorer.exe".
Ah , I had this errors and stuffs all the time . I am an old game addict but if you want to play old games nicely , you have to install Windows XP or something  :sad:
A bit of an old thread, but what used to work for me when I used vista was to launch the game and alt tab and open a folder. In Windows 7 I have to run a special program that disables all background apps while playing the games, and that fixes it. Shatari linked me to a program like that a while back, but I can't for the life of me find it.
Top Bottom